summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-23 10:41:25 +0100
committerRemi Collet <remi@php.net>2023-11-23 10:41:25 +0100
commitf239d5046527ef98e74e5a095d755a01c5fb88a1 (patch)
tree9127ae60735f8da169cca5fde85b1aeb093597c4
parent51cde96fee9e970d399e91db0c019dc5a66f6317 (diff)
update to 1.0.1HEADmaster
drop patch merged upstream
-rw-r--r--2.patch58
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-pspell.spec12
4 files changed, 8 insertions, 66 deletions
diff --git a/2.patch b/2.patch
deleted file mode 100644
index 275acf1..0000000
--- a/2.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From f7db92b01bae9fa4dad813c7c7ef62549245549c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 23 Nov 2023 07:37:43 +0100
-Subject: [PATCH 1/2] relax test for PHP 8.1 and 8.2
-
----
- tests/003.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/003.phpt b/tests/003.phpt
-index 2629a64..fff74b7 100644
---- a/tests/003.phpt
-+++ b/tests/003.phpt
-@@ -35,7 +35,7 @@ var_dump(pspell_config_ignore($cfg, PHP_INT_MAX));
- bool(false)
-
- Warning: pspell_new_config(): PSPELL couldn't open the dictionary. reason: The encoding "b0rked" is not known. This could also mean that the file "%sb0rked.%s" could not be opened for reading or does not exist. in %s003.php on line 9
--pspell_check(): Argument #1 ($dictionary) must be of type PSpell\Dictionary, false given
-+pspell_check(): Argument #1 ($dictionary) must be of type PSpell\Dictionary, %s given
- ---
- bool(true)
- bool(true)
-
-From c3502eda30a770006ed2a2750f3c3128eb17be73 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 23 Nov 2023 07:41:12 +0100
-Subject: [PATCH 2/2] Fix ext version and report it in phpinfo
-
----
- php_pspell.h | 2 +-
- pspell.c | 1 +
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/php_pspell.h b/php_pspell.h
-index 322569b..bc0b133 100644
---- a/php_pspell.h
-+++ b/php_pspell.h
-@@ -21,7 +21,7 @@ extern zend_module_entry pspell_module_entry;
- #define pspell_module_ptr &pspell_module_entry
-
- #include "php_version.h"
--#define PHP_PSPELL_VERSION PHP_VERSION
-+#define PHP_PSPELL_VERSION "1.0.0"
-
- #else
- #define pspell_module_ptr NULL
-diff --git a/pspell.c b/pspell.c
-index 7c15472..7ec2eee 100644
---- a/pspell.c
-+++ b/pspell.c
-@@ -780,6 +780,7 @@ static PHP_MINFO_FUNCTION(pspell)
- {
- php_info_print_table_start();
- php_info_print_table_row(2, "PSpell Support", "enabled");
-+ php_info_print_table_row(2, "PSpell extension version", PHP_PSPELL_VERSION);
- php_info_print_table_end();
- }
- /* }}} */
diff --git a/PHPINFO b/PHPINFO
index bb640d4..5ba5cd4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
pspell
PSpell Support => enabled
-PSpell extension version => 1.0.0
+PSpell extension version => 1.0.1
diff --git a/REFLECTION b/REFLECTION
index 16876ff..69bf9e3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #58 pspell version 1.0.0 ] {
+Extension [ <persistent> extension #58 pspell version 1.0.1 ] {
- Constants [4] {
Constant [ int PSPELL_FAST ] { 1 }
diff --git a/php-pecl-pspell.spec b/php-pecl-pspell.spec
index dca618a..db2ca68 100644
--- a/php-pecl-pspell.spec
+++ b/php-pecl-pspell.spec
@@ -19,16 +19,13 @@
Summary: Spell checker extension
Name: %{?scl_prefix}php-pecl-pspell
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/pspell
Source0: https://pecl.php.net/get/%{sources}.tgz
-# Fix tests and version
-Patch0: https://patch-diff.githubusercontent.com/raw/php/pecl-text-pspell/pull/2.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
# 8.1+ is supported by upstream but part of php-src until 8.4
@@ -63,8 +60,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PSPELL_VERSION/{s/.* "//;s/".*$//;p}' php_pspell.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -195,5 +190,10 @@ fi
%changelog
+* Thu Nov 23 2023 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+- drop patch merged upstream
+
* Thu Nov 23 2023 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package for version 1.0.0 (PHP 8.4)
+- open https://github.com/php/pecl-text-pspell/pull/2 tests and version