summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-28 16:48:47 +0200
committerRemi Collet <remi@remirepo.net>2021-09-28 16:48:47 +0200
commita64d40e797d1a398106d892a5631ecbe80b0d627 (patch)
tree37246ba1bbf1749c63228127ada6a81ee2050655
parente4d0619db32d853be0b2729f3ea3a6177fbcb917 (diff)
test build for
https://github.com/steinm/ps/pull/5 retrieve GD class entry https://github.com/steinm/ps/pull/6 fix for PHP 7 https://github.com/steinm/ps/pull/7 use pkg-config
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-ps.spec38
3 files changed, 25 insertions, 26 deletions
diff --git a/PHPINFO b/PHPINFO
index 34af22f..1b5504d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,4 +5,4 @@ PS Support => enabled
PSlib Version => 0.4.5
Extension Version => 1.4.3
Revision => $Revision$
-GD Support => disabled
+GD Support => enabled
diff --git a/REFLECTION b/REFLECTION
index 4696508..ba8cdb7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,5 +1,9 @@
Extension [ <persistent> extension #98 ps version 1.4.3 ] {
+ - Dependencies {
+ Dependency [ gd (Required) ]
+ }
+
- Constants [6] {
Constant [ int PS_LINECAP_BUTT ] { 0 }
Constant [ int PS_LINECAP_ROUND ] { 1 }
@@ -650,6 +654,13 @@ Extension [ <persistent> extension #98 ps version 1.4.3 ] {
Parameter #0 [ <optional> $psdoc ]
}
}
+ Function [ <internal:ps> function ps_open_memory_image ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $psdoc ]
+ Parameter #1 [ <required> $psimage ]
+ }
+ }
Function [ <internal:ps> function ps_hyphenate ] {
- Parameters [2] {
diff --git a/php-pecl-ps.spec b/php-pecl-ps.spec
index 55f14a1..ddd8df9 100644
--- a/php-pecl-ps.spec
+++ b/php-pecl-ps.spec
@@ -16,13 +16,15 @@
Summary: An extension to create PostScript files
Name: %{?scl_prefix}php-pecl-ps
Version: 1.4.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: %{pecl_name}-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -33,9 +35,7 @@ BuildRequires: pkgconfig(libps)
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%if "%{php_version}" > "8.0"
Requires: %{?scl_prefix}php-gd%{?_isa}
-%endif
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -76,11 +76,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
-%if "%{php_version}" < "8.0"
-# https://github.com/steinm/ps/issues/1
-sed -e 's/HAVE_LIBGD/DISABLE_LIBGD/' -i *.c
-sed -e '/GDLIB/d' -i config.m4
-%endif
+%patch0 -p1
# Check version
extver=$(sed -n '/#define PHP_PS_VERSION/{s/.* "//;s/".*$//;p}' php_ps.h)
@@ -108,25 +104,17 @@ cd NTS
%{_bindir}/phpize
%configure \
--with-ps \
-%if "%{php_version}" > "8.0"
--enable-gd \
-%else
- --disable-gd \
-%endif
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
%{__php} --no-php-ini \
-%if "%{php_version}" > "8.0"
- --define extension=gd \
-%endif
+ --define extension=gd.so \
--define extension=modules/%{pecl_name}.so \
--ri %{pecl_name}
%{__php} --no-php-ini \
-%if "%{php_version}" > "8.0"
- --define extension=gd \
-%endif
+ --define extension=gd.so \
--define extension=modules/%{pecl_name}.so \
--re %{pecl_name} >REFLECTION
@@ -135,11 +123,7 @@ cd ../ZTS
%{_bindir}/zts-phpize
%configure \
--with-ps \
-%if "%{php_version}" > "8.0"
--enable-gd \
-%else
- --disable-gd \
-%endif
--with-php-config=%{_bindir}/zts-php-config
make %{?_smp_mflags}
%endif
@@ -170,9 +154,7 @@ done
%check
OPT="-n"
-%if "%{php_version}" > "8.0"
- OPT="$OPT -d extension=gd"
-%endif
+OPT="$OPT -d extension=gd.so"
: Minimal load test for NTS extension
cd NTS
@@ -235,6 +217,12 @@ fi
%changelog
+* Tue Sep 28 2021 Remi Collet <remi@remirepo.net> - 1.4.3-2
+- test build for
+- https://github.com/steinm/ps/pull/5 retrieve GD class entry
+- https://github.com/steinm/ps/pull/6 fix for PHP 7
+- https://github.com/steinm/ps/pull/7 use pkg-config
+
* Tue Sep 28 2021 Remi Collet <remi@remirepo.net> - 1.4.3-1
- update to 1.4.3
- add REFLECTION file to package documentation