summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index bc3bfdc..34d6774 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -22,8 +22,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.9.1
-#global upstream_prever RC1
+%global upstream_version 3.10.0
+%global upstream_prever RC1
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
@@ -33,6 +33,8 @@ License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/protocolbuffers/protobuf/pull/6626.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.5.9
BuildRequires: %{?scl_prefix}php-pear
@@ -98,6 +100,8 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
+%patch0 -p5 -b .pr6626
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -214,6 +218,11 @@ fi
%changelog
+* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 3.10.0~RC1-1
+- update to 3.10.0RC1
+- see https://github.com/protocolbuffers/protobuf/issues/6624
+ broken extension with 7.4.0RC1
+
* Wed Aug 7 2019 Remi Collet <remi@remirepo.net> - 3.9.1-1
- update to 3.9.1 (no change)