summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--LICENSE42
-rw-r--r--REFLECTION97
-rw-r--r--php-pecl-protobuf.spec54
4 files changed, 126 insertions, 74 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index f028c82..0000000
--- a/LICENSE
+++ /dev/null
@@ -1,42 +0,0 @@
-This license applies to all parts of Protocol Buffers except the following:
-
- - Atomicops support for generic gcc, located in
- src/google/protobuf/stubs/atomicops_internals_generic_gcc.h.
- This file is copyrighted by Red Hat Inc.
-
- - Atomicops support for AIX/POWER, located in
- src/google/protobuf/stubs/atomicops_internals_power.h.
- This file is copyrighted by Bloomberg Finance LP.
-
-Copyright 2014, Google Inc. All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are
-met:
-
- * Redistributions of source code must retain the above copyright
-notice, this list of conditions and the following disclaimer.
- * Redistributions in binary form must reproduce the above
-copyright notice, this list of conditions and the following disclaimer
-in the documentation and/or other materials provided with the
-distribution.
- * Neither the name of Google Inc. nor the names of its
-contributors may be used to endorse or promote products derived from
-this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-Code generated by the Protocol Buffer compiler is owned by the owner
-of the input file used when generating it. This code is not
-standalone and requires a support library to be linked with it. This
-support library is itself covered by the above license.
diff --git a/REFLECTION b/REFLECTION
index 9383f89..14ff6ba 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
+Extension [ <persistent> extension #117 protobuf version 3.3.0 ] {
- - Classes [8] {
+ - Classes [9] {
Class [ <internal:protobuf> class Google\Protobuf\Internal\MapField implements ArrayAccess, Countable ] {
- Constants [0] {
@@ -56,7 +56,7 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
}
}
- Class [ <internal:protobuf> class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, Countable ] {
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
- Constants [0] {
}
@@ -70,7 +70,7 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [8] {
Method [ <internal:protobuf, ctor> public method __construct ] {
}
@@ -111,6 +111,59 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:protobuf, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:protobuf> <iterateable> class Google\Protobuf\Internal\RepeatedFieldIter implements Iterator, Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:protobuf, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -164,11 +217,23 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
- Properties [0] {
}
- - Methods [4] {
- Method [ <internal:protobuf> public method encode ] {
+ - Methods [10] {
+ Method [ <internal:protobuf> public method clear ] {
+ }
+
+ Method [ <internal:protobuf> public method serializeToString ] {
}
- Method [ <internal:protobuf> public method decode ] {
+ Method [ <internal:protobuf> public method mergeFromString ] {
+ }
+
+ Method [ <internal:protobuf> public method jsonEncode ] {
+ }
+
+ Method [ <internal:protobuf> public method jsonDecode ] {
+ }
+
+ Method [ <internal:protobuf> public method mergeFrom ] {
}
Method [ <internal:protobuf> protected method readOneof ] {
@@ -176,6 +241,12 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
Method [ <internal:protobuf> protected method writeOneof ] {
}
+
+ Method [ <internal:protobuf> protected method whichOneof ] {
+ }
+
+ Method [ <internal:protobuf, ctor> protected method __construct ] {
+ }
}
}
@@ -245,7 +316,7 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
- Static properties [0] {
}
- - Static methods [12] {
+ - Static methods [13] {
Method [ <internal:protobuf> static public method checkInt32 ] {
- Parameters [1] {
@@ -324,6 +395,16 @@ Extension [ <persistent> extension #16 protobuf version 3.1.0a1 ] {
}
}
+ Method [ <internal:protobuf> static public method checkMapField ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> &$val ]
+ Parameter #1 [ <required> $key_type ]
+ Parameter #2 [ <required> $value_type ]
+ Parameter #3 [ <optional> $klass ]
+ }
+ }
+
Method [ <internal:protobuf> static public method checkRepeatedField ] {
- Parameters [3] {
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 233c929..7fcaf21 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -7,11 +7,7 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-protobuf
%endif
@@ -22,19 +18,16 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever a1
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 3.1.0
-Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.3.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{prever}.tgz
-Source1: https://raw.githubusercontent.com/google/protobuf/master/LICENSE
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel >= 5.5.9
BuildRequires: %{?scl_prefix}php-pear
@@ -65,6 +58,18 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -85,17 +90,21 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version}%{prever} NTS
-cp %{SOURCE1} LICENSE
+mv %{pecl_name}-%{version}%{?prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir: -e '/LICENSE/s/role="doc"/role="src"/' } \
+ %{!?_licensedir:-e '/LICENSE/s/role="src"/role="doc"/' } \
+ -i package.xml
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
-if test "x${extver}" != "x%{version}%{prever}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{prever}.
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
cd ..
@@ -131,7 +140,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -190,15 +198,9 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-#doc #{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -211,6 +213,10 @@ rm -rf %{buildroot}
%changelog
+* Fri May 5 2017 Remi Collet <remi@fedoraproject.org> - 3.3.0-1
+- update to 3.3.0
+- open https://github.com/google/protobuf/issues/3058 - PHP 7.1
+
* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-0.1.a1
- initial package, version 3.1.0a1 (alpha)
- open https://github.com/google/protobuf/issues/2185 - License