summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION727
-rw-r--r--php-pecl-protobuf.spec16
3 files changed, 734 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index e86f72d..ebffa40 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 3.14.0
+Version => 3.15.0RC1
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index c1427fd..d43ff1f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
+Extension [ <persistent> extension #120 protobuf version 3.15.0RC1 ] {
- Dependencies {
Dependency [ date (Optional) ]
@@ -280,12 +280,21 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [3] {
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getField ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getFieldCount ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -306,9 +315,15 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [2] {
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getNumber ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -329,12 +344,21 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [3] {
Method [ <internal:protobuf> public method getPublicDescriptor ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValueCount ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -355,24 +379,45 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [7] {
Method [ <internal:protobuf> public method getClass ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getFullName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getField ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getFieldCount ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getOneofDecl ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getOneofDeclCount ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getPublicDescriptor ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -393,24 +438,45 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [7] {
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getNumber ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getLabel ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getType ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method isMap ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getEnumType ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getMessageType ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -425,6 +491,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method getGeneratedPool ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -433,15 +502,29 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [4] {
Method [ <internal:protobuf> public method getDescriptorByClassName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getDescriptorByProtoName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getEnumDescriptorByClassName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method internalAddGeneratedFile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <required> $data_len ]
+ }
}
}
}
@@ -456,6 +539,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method getGeneratedPool ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -738,6 +824,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -764,27 +853,55 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [21] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getTypeUrl ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setTypeUrl ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method is ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $proto ]
+ }
}
Method [ <internal:protobuf> public method pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method unpack ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -888,6 +1005,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -914,48 +1034,100 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [28] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getMethods ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setMethods ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getVersion ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSourceContext ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSourceContext ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getMixins ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setMixins ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSyntax ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSyntax ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1065,48 +1237,100 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [28] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getRequestTypeUrl ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setRequestTypeUrl ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getRequestStreaming ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setRequestStreaming ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getResponseTypeUrl ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setResponseTypeUrl ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getResponseStreaming ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setResponseStreaming ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSyntax ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSyntax ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1216,18 +1440,35 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getRoot ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setRoot ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1331,6 +1572,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -1357,18 +1601,35 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getSeconds ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSeconds ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getNanos ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNanos ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1472,6 +1733,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -1498,6 +1762,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [14] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1601,6 +1868,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -1627,12 +1897,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getPaths ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setPaths ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1736,6 +2016,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -1762,12 +2045,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getFileName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setFileName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -1871,6 +2164,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -1897,12 +2193,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getFields ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setFields ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2012,18 +2318,35 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getKey ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2133,45 +2456,93 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [27] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getNullValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNullValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getNumberValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNumberValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getStringValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setStringValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getBoolValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setBoolValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getStructValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setStructValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getListValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setListValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getKind ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2281,12 +2652,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValues ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValues ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2391,9 +2772,15 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> static public method value ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -2414,6 +2801,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -2440,42 +2830,87 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [26] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getFields ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setFields ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOneofs ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOneofs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSourceContext ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSourceContext ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSyntax ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSyntax ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2585,66 +3020,139 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [34] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getKind ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setKind ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getCardinality ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setCardinality ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getNumber ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getTypeUrl ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setTypeUrl ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOneofIndex ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOneofIndex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getPacked ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setPacked ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getJsonName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setJsonName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getDefaultValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setDefaultValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2767,9 +3275,15 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> static public method value ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -2794,9 +3308,15 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> static public method value ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -2823,36 +3343,74 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [24] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getEnumvalue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setEnumvalue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSourceContext ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSourceContext ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getSyntax ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSyntax ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -2962,24 +3520,48 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [20] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getNumber ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getOptions ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3089,18 +3671,35 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3206,9 +3805,15 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> static public method value ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -3229,6 +3834,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -3255,24 +3863,48 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [20] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getSeconds ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setSeconds ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method getNanos ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setNanos ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf> public method fromDateTime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $datetime ]
+ }
}
Method [ <internal:protobuf> public method toDateTime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3376,6 +4008,9 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Static methods [1] {
Method [ <internal:protobuf> static public method initOnce ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -3402,12 +4037,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3517,12 +4162,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3632,12 +4287,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3747,12 +4412,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3862,12 +4537,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -3977,12 +4662,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -4092,12 +4787,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -4207,12 +4912,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
@@ -4322,12 +5037,22 @@ Extension [ <persistent> extension #117 protobuf version 3.14.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method getValue ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:protobuf> public method setValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
}
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method clear ] {
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index d17c6ef..8144b11 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-protobuf
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -18,8 +18,8 @@
%global pecl_name protobuf
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.14.0
-#global upstream_prever RC3
+%global upstream_version 3.15.0
+%global upstream_prever RC1
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
@@ -29,6 +29,7 @@ License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
@@ -59,12 +60,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Google's language-neutral, platform-neutral, extensible mechanism for
@@ -206,6 +201,9 @@ fi
%changelog
+* Wed Feb 10 2021 Remi Collet <remi@remirepo.net> - 3.15.0~RC1-1
+- update to 3.15.0RC1
+
* Sat Nov 14 2020 Remi Collet <remi@remirepo.net> - 3.14.0-1
- update to 3.14.0