summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-25 09:43:23 +0200
committerRemi Collet <remi@remirepo.net>2021-05-25 09:43:23 +0200
commita17de88435b2e40748df2139b060b056709a27c7 (patch)
tree50ac00950f3d8524866365ea58bb1f560865317d
parent97b53aa9c0fcd634b9e8ca2ea23985c9ae585135 (diff)
update to 3.17.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION221
-rw-r--r--php-pecl-protobuf.spec5
3 files changed, 152 insertions, 76 deletions
diff --git a/PHPINFO b/PHPINFO
index 57d73e0..2699657 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 3.17.0
+Version => 3.17.1
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 686060a..a8d095a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
+Extension [ <persistent> extension #118 protobuf version 3.17.1 ] {
- Dependencies {
Dependency [ date (Optional) ]
@@ -189,8 +189,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> static public method checkEnum ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $value ]
+ Parameter #1 [ <required> $class ]
}
}
@@ -217,8 +218,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> static public method checkString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $value ]
+ Parameter #1 [ <optional> $check_utf8 ]
}
}
@@ -287,7 +289,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> public method getField ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
}
}
@@ -357,7 +360,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> public method getValue ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
}
}
}
@@ -392,7 +396,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> public method getField ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
}
}
@@ -404,7 +409,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> public method getOneofDecl ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
}
}
@@ -503,19 +509,22 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [4] {
Method [ <internal:protobuf> public method getDescriptorByClassName ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
}
}
Method [ <internal:protobuf> public method getDescriptorByProtoName ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
}
}
Method [ <internal:protobuf> public method getEnumDescriptorByClassName ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
}
}
@@ -750,8 +759,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -808,7 +818,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, ctor> protected method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
}
@@ -854,7 +865,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [21] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -937,8 +949,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1035,7 +1048,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [28] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1163,8 +1177,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1238,7 +1253,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [28] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1366,8 +1382,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1441,7 +1458,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1504,8 +1522,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1602,7 +1621,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1665,8 +1685,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1763,7 +1784,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [14] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1800,8 +1822,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -1898,7 +1921,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -1948,8 +1972,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2046,7 +2071,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2096,8 +2122,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2194,7 +2221,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2244,8 +2272,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2319,7 +2348,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2382,8 +2412,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2457,7 +2488,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [27] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2578,8 +2610,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2653,7 +2686,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2703,8 +2737,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -2773,13 +2808,15 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
Method [ <internal:protobuf> static public method value ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
}
@@ -2831,7 +2868,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [26] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -2946,8 +2984,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -3021,7 +3060,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [34] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -3188,8 +3228,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -3276,13 +3317,15 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
Method [ <internal:protobuf> static public method value ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
}
@@ -3309,13 +3352,15 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
Method [ <internal:protobuf> static public method value ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
}
@@ -3344,7 +3389,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [24] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -3446,8 +3492,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -3521,7 +3568,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [20] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -3597,8 +3645,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -3672,7 +3721,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [18] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -3735,8 +3785,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -3806,13 +3857,15 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Static methods [2] {
Method [ <internal:protobuf> static public method name ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
Method [ <internal:protobuf> static public method value ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
}
@@ -3864,7 +3917,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [20] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -3940,8 +3994,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4038,7 +4093,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4088,8 +4144,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4163,7 +4220,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4213,8 +4271,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4288,7 +4347,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4338,8 +4398,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4413,7 +4474,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4463,8 +4525,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4538,7 +4601,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4588,8 +4652,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4663,7 +4728,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4713,8 +4779,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4788,7 +4855,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4838,8 +4906,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -4913,7 +4982,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -4963,8 +5033,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
@@ -5038,7 +5109,8 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
- Methods [16] {
Method [ <internal:protobuf, overwrites Google\Protobuf\Internal\Message, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data ]
}
}
@@ -5088,8 +5160,9 @@ Extension [ <persistent> extension #118 protobuf version 3.17.0 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method mergeFromJsonString ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $arg ]
}
}
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 455c876..bf2375a 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -18,7 +18,7 @@
%global pecl_name protobuf
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.17.0
+%global upstream_version 3.17.1
#global upstream_prever RC2
Summary: Mechanism for serializing structured data
@@ -201,6 +201,9 @@ fi
%changelog
+* Tue May 25 2021 Remi Collet <remi@remirepo.net> - 3.17.1-1
+- update to 3.17.1
+
* Thu May 13 2021 Remi Collet <remi@remirepo.net> - 3.17.0-1
- update to 3.17.0 (no change)