summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-18 12:55:08 +0200
committerRemi Collet <remi@remirepo.net>2021-09-18 12:55:08 +0200
commit79f188a39c68e9d83f37b908c5f81c454f5b9430 (patch)
tree065bc7c7ec9c2353197472a24f9243bf8a502e81
parent8d8f84b2bebd02ffc2e16335dad17e401f98b157 (diff)
update to 3.18.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-protobuf.spec11
-rw-r--r--protobuf-php81.patch49
4 files changed, 8 insertions, 58 deletions
diff --git a/PHPINFO b/PHPINFO
index 9226357..5834814 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 3.17.3
+Version => 3.18.0
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index faaf099..048cb40 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,11 +1,11 @@
-Extension [ <persistent> extension #119 protobuf version 3.17.3 ] {
+Extension [ <persistent> extension #124 protobuf version 3.18.0 ] {
- Dependencies {
Dependency [ date (Optional) ]
}
- INI {
- Entry [ protobuf.keep_descriptor_pool_after_request <SYSTEM> ]
+ Entry [ protobuf.keep_descriptor_pool_after_request <ALL> ]
Current = '0'
}
}
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 9919a19..ce5fa6a 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -18,19 +18,17 @@
%global pecl_name protobuf
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.17.3
+%global upstream_version 3.18.0
#global upstream_prever RC2
Summary: Mechanism for serializing structured data
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-php81.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -87,8 +85,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%patch0 -p5 -b .php81
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PROTOBUF_VERSION/{s/.* "//;s/".*$//;p}' protobuf.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -208,6 +204,9 @@ fi
%changelog
+* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 3.18.0-1
+- update to 3.18.0
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 3.17.3-2
- rebuild for 8.1.0RC1
diff --git a/protobuf-php81.patch b/protobuf-php81.patch
deleted file mode 100644
index 2eef0dc..0000000
--- a/protobuf-php81.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 5e89bfbb99ea2e20a0875c6feb3a61977d711511 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 8 Jun 2021 17:36:45 +0200
-Subject: [PATCH] fix for PHP 8.1
-
----
- php/ext/google/protobuf/array.c | 5 +++++
- php/ext/google/protobuf/map.c | 5 +++++
- 2 files changed, 10 insertions(+)
-
-diff --git a/php/ext/google/protobuf/array.c b/php/ext/google/protobuf/array.c
-index 765e90297..2736f1a22 100644
---- a/php/ext/google/protobuf/array.c
-+++ b/php/ext/google/protobuf/array.c
-@@ -640,8 +640,13 @@ void Array_ModuleInit() {
- repeated_field_methods);
-
- RepeatedField_class_entry = zend_register_internal_class(&tmp_ce);
-+#if PHP_VERSION_ID < 70200
- zend_class_implements(RepeatedField_class_entry, 3, spl_ce_ArrayAccess,
- zend_ce_aggregate, spl_ce_Countable);
-+#else
-+ zend_class_implements(RepeatedField_class_entry, 3, zend_ce_arrayaccess,
-+ zend_ce_aggregate, zend_ce_countable);
-+#endif
- RepeatedField_class_entry->ce_flags |= ZEND_ACC_FINAL;
- RepeatedField_class_entry->create_object = RepeatedField_create;
-
-diff --git a/php/ext/google/protobuf/map.c b/php/ext/google/protobuf/map.c
-index f5890d99e..74f25e5bc 100644
---- a/php/ext/google/protobuf/map.c
-+++ b/php/ext/google/protobuf/map.c
-@@ -636,8 +636,13 @@ void Map_ModuleInit() {
- MapField_methods);
-
- MapField_class_entry = zend_register_internal_class(&tmp_ce);
-+#if PHP_VERSION_ID < 70200
- zend_class_implements(MapField_class_entry, 3, spl_ce_ArrayAccess,
- zend_ce_aggregate, spl_ce_Countable);
-+#else
-+ zend_class_implements(MapField_class_entry, 3, zend_ce_arrayaccess,
-+ zend_ce_aggregate, zend_ce_countable);
-+#endif
- MapField_class_entry->ce_flags |= ZEND_ACC_FINAL;
- MapField_class_entry->create_object = MapField_create;
-
---
-2.31.1
-