summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 07:36:38 +0100
committerRemi Collet <remi@php.net>2023-02-03 07:36:38 +0100
commit11f0c080ee712fa492ae6fe8226068441c97e5c4 (patch)
tree77a1f2997b81476c30010b859de3f9fef911544d
parent19d1f32c40c0d0bf55c4d7822a5ce5ae05417218 (diff)
update to 3.22.0RC2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-protobuf.spec14
3 files changed, 20 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 639e6e8..1413d17 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 3.21.12
+Version => 3.22.0RC2
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index ff1fd54..8436353 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #123 protobuf version 3.21.12 ] {
+Extension [ <persistent> extension #121 protobuf version 3.22.0RC2 ] {
- Dependencies {
Dependency [ date (Optional) ]
@@ -70,8 +70,9 @@ Extension [ <persistent> extension #123 protobuf version 3.21.12 ] {
Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $index ]
+ Parameter #0 [ <optional> $index = <default> ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
@@ -133,12 +134,14 @@ Extension [ <persistent> extension #123 protobuf version 3.21.12 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype Iterator> public method next ] {
@@ -652,8 +655,9 @@ Extension [ <persistent> extension #123 protobuf version 3.21.12 ] {
Method [ <internal:protobuf, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $index ]
+ Parameter #0 [ <optional> $index = <default> ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype ArrayAccess> public method offsetSet ] {
@@ -715,12 +719,14 @@ Extension [ <persistent> extension #123 protobuf version 3.21.12 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:protobuf, prototype Iterator> public method next ] {
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index fcfb78b..6123a0d 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-protobuf
#
-# Copyright (c) 2016-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -15,8 +15,8 @@
%global pecl_name protobuf
%global with_zts 0
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.21.12
-#global upstream_prever RC2
+%global upstream_version 3.22.0
+%global upstream_prever RC2
Summary: Mechanism for serializing structured data
Name: %{?scl_prefix}php-pecl-%{pecl_name}
@@ -185,6 +185,12 @@ fi
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.22.0~RC2-1
+- update to 3.22.0RC2
+
+* Tue Jan 31 2023 Remi Collet <remi@remirepo.net> - 3.22.0~RC1-1
+- update to 3.22.0RC1
+
* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 3.21.12-1
- update to 3.21.12