summaryrefslogtreecommitdiffstats
path: root/php-pecl-propro.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-propro.spec')
-rw-r--r--php-pecl-propro.spec39
1 files changed, 31 insertions, 8 deletions
diff --git a/php-pecl-propro.spec b/php-pecl-propro.spec
index 85d7820..4e753d0 100644
--- a/php-pecl-propro.spec
+++ b/php-pecl-propro.spec
@@ -1,4 +1,7 @@
-# spec file for php-pecl-propro
+# remirepo spec file for php-pecl-propro
+# with SCL stuff, from:
+#
+# Fedora spec file for php-pecl-propro
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -6,6 +9,14 @@
#
# Please, preserve the changelog entries
#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
%{?scl: %scl_package php-pecl-raphf}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?php_incldir: %global php_incldir %{_includedir}/php}
@@ -21,9 +32,9 @@
%endif
Summary: Property proxy
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -33,8 +44,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -70,6 +79,9 @@ Obsoletes: php56w-pecl-%{pecl_name}
%description
A reusable split-off of pecl_http's property proxy API.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+
+
%package devel
Summary: %{name} developer files (header)
Group: Development/Libraries
@@ -146,12 +158,20 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -215,6 +235,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Jun 21 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-5
+- allow build against rh-php56 (as more-php56)
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-4.1
- Fedora 21 SCL mass rebuild