summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-07 14:41:55 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-07 14:41:55 +0100
commit41508f3df7c32ae2b00993087a0374795030f003 (patch)
treeadaad2b9538da0f43ebb3ecc30661767c4f87e12
parent436c1053d16d5e4136dbf90b8bc59c4dcb8761c7 (diff)
php-pecl-propro: 2.0.0RC1
-rw-r--r--REFLECTION-PHP731
-rw-r--r--php-pecl-propro-php7.spec (renamed from php-pecl-propro-dev.spec)24
2 files changed, 50 insertions, 5 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..a8c9c45
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,31 @@
+Extension [ <persistent> extension #83 propro version 2.0.0RC1 ] {
+
+ - Classes [1] {
+ Class [ <internal:propro> final class php\PropertyProxy ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:propro, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> &$object ]
+ Parameter #1 [ <required> $member ]
+ Parameter #2 [ <optional> php\PropertyProxy or NULL $parent ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-propro-dev.spec b/php-pecl-propro-php7.spec
index cf69d4a..889040c 100644
--- a/php-pecl-propro-dev.spec
+++ b/php-pecl-propro-php7.spec
@@ -27,8 +27,9 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner m6w6
%global gh_project ext-propro
-%global gh_date 20150930
-%global with_zts 0%{?__ztsphp:1}
+#global gh_date 20150930
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global prever RC1
%global pecl_name propro
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -43,14 +44,19 @@
Summary: Property proxy
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.0.0
+%if 0%{?ghdate}
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+%else
+Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+%endif
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -107,8 +113,12 @@ These are the files needed to compile programs using %{name}.
%prep
%setup -qc
+%if 0%{?ghdate}
mv %{gh_project}-%{gh_commit} NTS
mv NTS/package.xml .
+%else
+mv %{pecl_name}-%{version}%{?prever} NTS
+%endif
cd NTS
# Sanity check, really often broken
@@ -165,7 +175,8 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Test & Documentation
for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
+do [ -f NTS/tests/$i ] && install -Dpm 644 NTS/tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
+ [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
done
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -249,6 +260,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 7 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.2.RC1
+- Update to 2.0.0RC1 (beta)
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.20150930git55c3639
- rebuild for PHP 7.0.0RC5 new API version
- new snapshot