summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--950b257a9376d4f83fd24a7afadeafaf31f8855a.patch55
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-pq.spec17
4 files changed, 16 insertions, 68 deletions
diff --git a/950b257a9376d4f83fd24a7afadeafaf31f8855a.patch b/950b257a9376d4f83fd24a7afadeafaf31f8855a.patch
deleted file mode 100644
index efb6385..0000000
--- a/950b257a9376d4f83fd24a7afadeafaf31f8855a.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 950b257a9376d4f83fd24a7afadeafaf31f8855a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 18 Jul 2018 07:39:47 +0200
-Subject: [PATCH] fix for 7.3.0alpha4
-
----
- src/php_pq_params.c | 15 ++++++++++-----
- 1 file changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/src/php_pq_params.c b/src/php_pq_params.c
-index 6739b45..3c6b920 100644
---- a/src/php_pq_params.c
-+++ b/src/php_pq_params.c
-@@ -123,7 +123,7 @@ static int apply_to_param_from_array(zval *zparam, void *arg_ptr)
- struct apply_to_param_from_array_arg subarg, *arg = arg_ptr;
- char *tmp;
- size_t len;
-- zend_string *str;
-+ zend_string *str, *tmpstr;
-
- if (arg->index++) {
- smart_str_appendc(arg->buffer, arg->delim);
-@@ -134,7 +134,7 @@ static int apply_to_param_from_array(zval *zparam, void *arg_ptr)
-
- ZVAL_LONG(&ztype, arg->type);
- zend_call_method_with_2_params(arg->zconv, NULL, NULL, "converttostring", &rv, zparam, &ztype);
-- str = zval_get_string(&rv);
-+ tmpstr = zval_get_string(&rv);
- zval_ptr_dtor(&rv);
- goto append_string;
-
-@@ -176,15 +176,20 @@ static int apply_to_param_from_array(zval *zparam, void *arg_ptr)
- break;
-
- case IS_OBJECT:
-- if ((str = object_param_to_string(arg->params, zparam, arg->type))) {
-+ if ((tmpstr = object_param_to_string(arg->params, zparam, arg->type))) {
- goto append_string;
- }
- /* no break */
- default:
-- str = zval_get_string(zparam);
-+ tmpstr = zval_get_string(zparam);
-
- append_string:
-- str = php_addslashes(str, 1);
-+#if PHP_VERSION_ID < 70300
-+ str = php_addslashes(tmpstr, 1);
-+#else
-+ str = php_addslashes(tmpstr);
-+ zend_string_release(tmpstr);
-+#endif
- smart_str_appendc(arg->buffer, '"');
- smart_str_appendl(arg->buffer, str->val, str->len);
- smart_str_appendc(arg->buffer, '"');
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..1fcbe86
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+pq
+
+PQ Support => enabled
+Extension Version => 2.1.5
+
+Used Library => Compiled => Linked
+libpq => 10.6 => 10.0.6
diff --git a/REFLECTION b/REFLECTION
index 8abbca0..40686f7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 pq version 2.1.4 ] {
+Extension [ <persistent> extension #194 pq version 2.1.5 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -73,7 +73,7 @@ Extension [ <persistent> extension #191 pq version 2.1.4 ] {
- Parameters [3] {
Parameter #0 [ <required> $format ]
Parameter #1 [ <required> $datetime ]
- Parameter #2 [ <optional> $timezone ]
+ Parameter #2 [ <optional> DateTimeZone or NULL $object ]
}
}
diff --git a/php-pecl-pq.spec b/php-pecl-pq.spec
index 3152942..a9bc90a 100644
--- a/php-pecl-pq.spec
+++ b/php-pecl-pq.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-pq
#
-# Copyright (c) 2014-2018 Remi Collet
+# Copyright (c) 2014-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -30,19 +30,17 @@
Summary: PostgreSQL client library (libpq) binding
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.4
+Version: 2.1.5
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
-Patch0: https://github.com/m6w6/ext-pq/commit/950b257a9376d4f83fd24a7afadeafaf31f8855a.patch
-
%if 0%{?fedora} >= 29 && 0%{?rhel} >= 8
BuildRequires: libpq-devel > 9
%else
@@ -75,10 +73,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -129,8 +123,6 @@ sed -e '/role="test"/d' \
-i package.xml
cd NTS
-%patch0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PQ_VERSION/{s/.* "//;s/".*$//;p}' php_pq.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -305,6 +297,9 @@ exit $RET
%changelog
+* Mon Jan 14 2019 Remi Collet <remi@remirepo.net> - 2.1.5-1
+- update to 2.1.5
+
* Tue Dec 4 2018 Remi Collet <remi@remirepo.net> - 2.1.4-4
- EL-8 build