summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-04 10:27:35 +0200
committerRemi Collet <remi@remirepo.net>2021-08-04 10:27:35 +0200
commitfc8f6b2ff58745f4df7c088f0598afc5c42da1bb (patch)
tree06f115438b09228d6b27a6ac163049bacb3bf239
parent703bf6e99af890f6b7903499431b2116a9cbca1a (diff)
add patch for 8.1.0beta2 from
https://github.com/m6w6/ext-pq/pull/41
-rw-r--r--php-pecl-pq.spec6
-rw-r--r--pq-php81.patch40
2 files changed, 45 insertions, 1 deletions
diff --git a/php-pecl-pq.spec b/php-pecl-pq.spec
index ce9c285..2519e75 100644
--- a/php-pecl-pq.spec
+++ b/php-pecl-pq.spec
@@ -32,7 +32,7 @@ Version: 2.1.8
Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: BSD
@@ -287,6 +287,10 @@ exit $RET
%changelog
+* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 2.1.8-6
+- add patch for 8.1.0beta2 from
+ https://github.com/m6w6/ext-pq/pull/41
+
* Fri Jun 11 2021 Remi Collet <remi@remirepo.net> - 2.1.8-5
- add patches for 8.1 from upstream and from
https://github.com/m6w6/ext-pq/pull/40
diff --git a/pq-php81.patch b/pq-php81.patch
index f8e2c0a..556904a 100644
--- a/pq-php81.patch
+++ b/pq-php81.patch
@@ -289,3 +289,43 @@ index 9e622b4..70f32da 100644
ZEND_BEGIN_ARG_INFO_EX(ai_pqdt_to_string, 0, 0, 0)
ZEND_END_ARG_INFO();
+From 94c127a7e5fe56ed53a4f5fad0a7abad101a1fe9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 4 Aug 2021 10:23:43 +0200
+Subject: [PATCH] fix prototype for 8.1.0beta2
+
+---
+ src/php_pqres.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/php_pqres.c b/src/php_pqres.c
+index be3d039..56c7444 100644
+--- a/src/php_pqres.c
++++ b/src/php_pqres.c
+@@ -1146,7 +1146,11 @@ static PHP_METHOD(pqres, fetchAll) {
+ }
+ }
+
++#if PHP_VERSION_ID >= 80100
++ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(ai_pqres_count, 0, 0, IS_LONG, 0)
++#else
+ ZEND_BEGIN_ARG_INFO_EX(ai_pqres_count, 0, 0, 0)
++#endif
+ ZEND_END_ARG_INFO();
+ static PHP_METHOD(pqres, count) {
+ zend_error_handling zeh;
+@@ -1194,7 +1198,11 @@ static PHP_METHOD(pqres, desc) {
+ }
+
+ #if PHP_VERSION_ID >= 80000
++#if PHP_VERSION_ID >= 80100
++ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_OBJ_INFO_EX(ai_pqres_getIterator, 0, 0, Iterator, 0)
++#else
+ ZEND_BEGIN_ARG_INFO_EX(ai_pqres_getIterator, 0, 0, 0)
++#endif
+ ZEND_END_ARG_INFO();
+ static PHP_METHOD(pqres, getIterator)
+ {
+--
+2.31.1
+