summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-20 11:55:08 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-20 11:55:08 +0200
commit85fe801966b926dbc4991ea03b6a87d583ea02b8 (patch)
tree1c7b59ba0ce3e593930c010cbcfd356d5c024765
parent483d98fca63c84dceaae8495e1923baf6c722c89 (diff)
php-pecl-pq: 1.1.1 (php 5)
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-pq.spec16
2 files changed, 27 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 3407e5c..8249c13 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #204 pq version 1.0.1 ] {
+Extension [ <persistent> extension #205 pq version 1.1.1 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -535,7 +535,7 @@ Extension [ <persistent> extension #204 pq version 1.0.1 ] {
- Static methods [0] {
}
- - Properties [20] {
+ - Properties [21] {
Property [ <default> public $status ]
Property [ <default> public $transactionStatus ]
Property [ <default> public $socket ]
@@ -543,6 +543,7 @@ Extension [ <persistent> extension #204 pq version 1.0.1 ] {
Property [ <default> public $busy ]
Property [ <default> public $encoding ]
Property [ <default> public $unbuffered ]
+ Property [ <default> public $nonblocking ]
Property [ <default> public $db ]
Property [ <default> public $user ]
Property [ <default> public $pass ]
@@ -558,7 +559,7 @@ Extension [ <persistent> extension #204 pq version 1.0.1 ] {
Property [ <default> public $defaultAutoConvert ]
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:pq, ctor> public method __construct ] {
- Parameters [2] {
@@ -585,6 +586,12 @@ Extension [ <persistent> extension #204 pq version 1.0.1 ] {
}
}
+ Method [ <internal:pq> public method flush ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:pq> public method exec ] {
- Parameters [1] {
@@ -1043,10 +1050,11 @@ Extension [ <persistent> extension #204 pq version 1.0.1 ] {
- Static methods [0] {
}
- - Properties [8] {
+ - Properties [9] {
Property [ <default> public $status ]
Property [ <default> public $statusMessage ]
Property [ <default> public $errorMessage ]
+ Property [ <default> public $diag ]
Property [ <default> public $numRows ]
Property [ <default> public $numCols ]
Property [ <default> public $affectedRows ]
diff --git a/php-pecl-pq.spec b/php-pecl-pq.spec
index ddc2dd7..780fe67 100644
--- a/php-pecl-pq.spec
+++ b/php-pecl-pq.spec
@@ -35,7 +35,7 @@
Summary: PostgreSQL client library (libpq) binding
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.1.1
%if 0%{?rcver:1}
Release: 0.1.%{rcver}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -202,6 +202,11 @@ fi
%check
+if ! pkg-config libpq --atleast-version=9.3; then
+ : ignore some tests only because of "diag" content
+ rm ?TS/tests/{async003,async004,async005,async006,cancel001}.phpt
+fi
+
OPT="-n"
[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
[ -f %{php_extdir}/raphf.so ] && OPT="$OPT -d extension=raphf.so"
@@ -290,6 +295,15 @@ rm -rf %{buildroot}
%changelog
+* Fri May 20 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- update to 1.1.1 (php 5, stable)
+- open https://github.com/m6w6/ext-pq/issues/19 failed tests
+ so temporarily ignore them with pgsql < 9.3
+
+* Fri May 20 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- update to 1.1.0 (php 5, stable)
+- open https://github.com/m6w6/ext-pq/issues/18 pgsql < 9.3
+
* Wed May 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
- update to 1.0.1 (php 5, stable)