summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-pinpoint.spec10
-rw-r--r--pinpoint_php-cxx.patch30
3 files changed, 6 insertions, 36 deletions
diff --git a/REFLECTION b/REFLECTION
index a0be6ba..1997a66 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 pinpoint_php version 0.5.2 ] {
+Extension [ <persistent> extension #110 pinpoint_php version 0.5.3 ] {
- INI {
Entry [ pinpoint_php.SendSpanTimeOutMs <ALL> ]
diff --git a/php-pecl-pinpoint.spec b/php-pecl-pinpoint.spec
index f1efa29..e34c4f2 100644
--- a/php-pecl-pinpoint.spec
+++ b/php-pecl-pinpoint.spec
@@ -12,7 +12,7 @@
%global pecl_name pinpoint_php
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.5.2
+%global upstream_version 0.5.3
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -25,8 +25,6 @@ License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-cxx.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -61,8 +59,6 @@ sed -e 's/role="test"/role="src"/' \
cd %{sources}
sed -e 's/\r//' -i config.m4
-%patch -P0 -p1 -b .pr655
-
# Sanity check, really often broken
extver=$(sed -n '/PHP_PINPOINT_PHP_VERSION/{s/.* "//;s/".*$//;p}' php_pinpoint_php.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -169,6 +165,10 @@ cd ../ZTS
%changelog
+* Thu Aug 1 2024 Remi Collet <remi@remirepo.net> - 0.5.3-1
+- update to 0.5.3
+- drop patch merged upstream
+
* Mon Jul 29 2024 Remi Collet <remi@remirepo.net> - 0.5.2-1
- initial package
- open https://github.com/pinpoint-apm/pinpoint-c-agent/issues/656 license
diff --git a/pinpoint_php-cxx.patch b/pinpoint_php-cxx.patch
deleted file mode 100644
index 1eb0f3a..0000000
--- a/pinpoint_php-cxx.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 27d46dcca6d74a30cd2df81b3f23977b8131957c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 29 Jul 2024 10:28:12 +0200
-Subject: [PATCH] This is cxx extension
-
----
- config.m4 | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/config.m4 b/config.m4
-index 2dbfbff9..fcbc2aa6 100644
---- a/config.m4
-+++ b/config.m4
-@@ -11,7 +11,6 @@ if test "$PHP_PINPOINT_PHP" != "no"; the
-
- PHP_REQUIRE_CXX()
- PHP_SUBST(PINPOINT_PHP_SHARED_LIBADD)
-- PHP_ADD_LIBRARY(stdc++, 1, PINPOINT_PHP_SHARED_LIBADD)
- PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/include)
- PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/jsoncpp/include)
- PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/jsoncpp/include)
-@@ -47,5 +46,5 @@ if test "$PHP_PINPOINT_PHP" != "no"; the
-
- PINPOINT_PHP_SHARED_LIBADD="$PINPOINT_PHP_SHARED_LIBADD -lrt"
-
-- PHP_NEW_EXTENSION(pinpoint_php,$PINPOINT_SRCS, $ext_shared)
--fi
-\ No newline at end of file
-+ PHP_NEW_EXTENSION(pinpoint_php,$PINPOINT_SRCS, $ext_shared,,, cxx)
-+fi