summaryrefslogtreecommitdiffstats
path: root/php-pecl-pinpoint.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-21 10:09:02 +0200
committerRemi Collet <remi@php.net>2024-10-21 10:09:02 +0200
commit865a09a585e4e4b38255d4b0b06cf7666ac7600c (patch)
tree2f4ef59fa45e0528e0727e4aa1f848fdefd7d740 /php-pecl-pinpoint.spec
parent263911b62501e2f5e50c032dd582a5c000b69e44 (diff)
update to 0.6.0 (alpha)
Diffstat (limited to 'php-pecl-pinpoint.spec')
-rw-r--r--php-pecl-pinpoint.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-pecl-pinpoint.spec b/php-pecl-pinpoint.spec
index 9f2d699..3080ad3 100644
--- a/php-pecl-pinpoint.spec
+++ b/php-pecl-pinpoint.spec
@@ -12,7 +12,7 @@
%global pecl_name pinpoint_php
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.5.4
+%global upstream_version 0.6.0
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -91,6 +91,8 @@ EOF
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
@@ -98,7 +100,7 @@ cd ../NTS
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -107,14 +109,14 @@ cd ../ZTS
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -123,7 +125,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -165,6 +167,9 @@ cd ../ZTS
%changelog
+* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 0.6.0-1
+- update to 0.6.0 (alpha)
+
* Wed Aug 7 2024 Remi Collet <remi@remirepo.net> - 0.5.4-1
- update to 0.5.4 (stable)