summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 15:12:54 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 15:12:54 +0100
commitc6fb5e04497292af9acc8f9f3ec909bc2dd3c0c2 (patch)
tree0239d64fef7daa350f717b0e6ab7936c595f6b02
parent5385883b28c65c76de05e4925305c953365c9fc9 (diff)
php-pecl-phk: F24
-rw-r--r--php-pecl-phk.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-phk.spec b/php-pecl-phk.spec
index a201fd1..e3bfee0 100644
--- a/php-pecl-phk.spec
+++ b/php-pecl-phk.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-phk}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name phk
@@ -23,7 +20,7 @@
Summary: Accelerator for Automap and PHK
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 3.0.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -38,10 +35,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -84,7 +83,7 @@ Note that there is no 'Automap' PECL extension anymore. The PHK extension now
includes it. So, this is the one you need, even if using Automap out of PHK
packages.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -93,6 +92,7 @@ mv %{pecl_name}-%{version} NTS
# Don't install tests
sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
cd NTS
@@ -160,6 +160,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -176,6 +177,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -232,6 +234,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-2
+- adapt for F24
+
* Mon Jun 01 2015 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
- Update to 3.0.1 (beta)
@@ -242,4 +247,5 @@ rm -rf %{buildroot}
- initial package for upcoming version 3.0.0
- open # https://github.com/flaupretre/pecl-phk/pull/1 PHP 5.5
- open # https://github.com/flaupretre/pecl-phk/pull/2 ZTS
-- open # https://github.com/flaupretre/pecl-phk/pull/3 zpp \ No newline at end of file
+- open # https://github.com/flaupretre/pecl-phk/pull/3 zpp
+