summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 15:12:45 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 15:12:45 +0100
commitf682d6eb2a62ac5744e8e39936b1697a801e6743 (patch)
treec5aef93852c59f17da61323c32765bc5622b7318
parent3fd19a4319dac41daab0ce0a676ef163b7c651da (diff)
php-pecl-pcsc: F24
-rw-r--r--php-pecl-pcsc.spec27
1 files changed, 18 insertions, 9 deletions
diff --git a/php-pecl-pcsc.spec b/php-pecl-pcsc.spec
index ef667e3..b0b1f10 100644
--- a/php-pecl-pcsc.spec
+++ b/php-pecl-pcsc.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-pcsc}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name pcsc
@@ -22,7 +19,7 @@
Summary: An extension for PHP using the winscard PC/SC API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.3.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -37,10 +34,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -70,7 +69,7 @@ This is an extension for using PC/SC based smart cards with PHP.
It is a wrapper to the wonderful and free project PCSC-Lite which is the
middleware to access a smart card using SCard API (PC/SC).
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%package devel
@@ -87,6 +86,8 @@ These are the files needed to compile programs using %{name}.
%setup -q -c
mv %{pecl_name}-%{version} NTS
+%{?_licensedir:sed -e '/COPYING/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PCSC_VERSION/{s/.* "//;s/".*$//;p}' php_pcsc.h)
@@ -151,6 +152,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -167,6 +169,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -191,6 +194,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/COPYING}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -212,6 +216,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.3.1-2
+- adapt for F24
+- fix license management
+
* Fri Jan 23 2015 Remi Collet <remi@fedoraproject.org> - 0.3.1-1
- Update to 0.3.1 (alpha)
- drop runtime dependency on pear, new scriptlets
@@ -223,4 +231,5 @@ rm -rf %{buildroot}
- improve SCL build
* Sun May 4 2014 Remi Collet <remi@fedoraproject.org> - 0.3-1
-- initial package, version 0.3 (alpha) \ No newline at end of file
+- initial package, version 0.3 (alpha)
+