summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION30
-rw-r--r--php-pecl-pcs.spec11
2 files changed, 29 insertions, 12 deletions
diff --git a/REFLECTION b/REFLECTION
index 93b86c9..f3ae384 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #131 pcs version 1.3.0 ] {
+Extension [ <persistent> extension #137 pcs version 1.3.1 ] {
- Dependencies {
Dependency [ tokenizer (Required) ]
@@ -6,6 +6,24 @@ Extension [ <persistent> extension #131 pcs version 1.3.0 ] {
Dependency [ SPL (Required) ]
}
+ - Functions {
+ Function [ <internal:pcs> function _pcs_autoload ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $symbol ]
+ Parameter #1 [ <optional> $type ]
+ }
+ }
+ Function [ <internal:pcs> function _pcs_autoload_register ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $autoload_function ]
+ Parameter #1 [ <optional> $throw ]
+ Parameter #2 [ <optional> $prepend ]
+ }
+ }
+ }
+
- Classes [1] {
Class [ <internal:pcs> class PCS\Mgr ] {
@@ -15,15 +33,7 @@ Extension [ <persistent> extension #131 pcs version 1.3.0 ] {
- Static properties [0] {
}
- - Static methods [10] {
- Method [ <internal:pcs> static public method autoloadHook ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $symbol ]
- Parameter #1 [ <optional> $type ]
- }
- }
-
+ - Static methods [9] {
Method [ <internal:pcs> static public method getFunction ] {
- Parameters [1] {
diff --git a/php-pecl-pcs.spec b/php-pecl-pcs.spec
index ed97dd8..d5cb451 100644
--- a/php-pecl-pcs.spec
+++ b/php-pecl-pcs.spec
@@ -31,7 +31,7 @@
Summary: PHP Code Service
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.0
+Version: 1.3.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -127,6 +127,9 @@ cp -pr NTS ZTS
cat << 'EOF' | tee %{ini_name}
; Enable '%{summary}' extension module
extension=%{pecl_name}.so
+
+; For compatibility with Suhosin
+suhosin.executor.include.whitelist=pcs://
EOF
@@ -264,8 +267,12 @@ rm -rf %{buildroot}
%changelog
+* Thu Dec 17 2015 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
+- Update to 1.3.1 (beta)
+- add suhosin.executor.include.whitelist=pcs://
+
* Sat Dec 05 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- Update to 1.3.0
+- Update to 1.3.0 (beta)
* Thu Dec 03 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1 (beta)