summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-pcov.spec56
3 files changed, 29 insertions, 33 deletions
diff --git a/PHPINFO b/PHPINFO
index 2980007..46ebfc2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
pcov
PCOV support => Disabled
-PCOV version => 1.0.11
+PCOV version => 1.0.12
pcov.directory => auto
pcov.exclude => none
pcov.initial.memory => 65336 bytes
diff --git a/REFLECTION b/REFLECTION
index 11e0352..6103f7b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #89 pcov version 1.0.11 ] {
+Extension [ <persistent> extension #128 pcov version 1.0.12 ] {
- Dependencies {
Dependency [ pcre (Required) ]
@@ -26,7 +26,7 @@ Extension [ <persistent> extension #89 pcov version 1.0.11 ] {
Constant [ int pcov\all ] { 0 }
Constant [ int pcov\inclusive ] { 1 }
Constant [ int pcov\exclusive ] { 2 }
- Constant [ string pcov\version ] { 1.0.11 }
+ Constant [ string pcov\version ] { 1.0.12 }
}
- Functions {
diff --git a/php-pecl-pcov.spec b/php-pecl-pcov.spec
index d647447..8dd8ea7 100644
--- a/php-pecl-pcov.spec
+++ b/php-pecl-pcov.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-pcov
#
-# Copyright (c) 2019-2023 Remi Collet
+# Copyright (c) 2019-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,11 +16,11 @@
Summary: Code coverage driver
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.11
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.0.12
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -47,7 +47,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -88,6 +88,8 @@ EOF
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
@@ -95,7 +97,7 @@ cd ../NTS
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -104,14 +106,14 @@ cd ../ZTS
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -120,7 +122,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -132,26 +134,6 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{sources}
@@ -180,7 +162,7 @@ REPORT_EXIT_STATUS=1 \
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -194,6 +176,20 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Dec 4 2024 Remi Collet <remi@remirepo.net> - 1.0.12-1
+- update to 1.0.12
+- drop patch merged upstream
+
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.0.11-5
+- rebuild for 8.4.0RC1
+
+* Fri Jul 12 2024 Remi Collet <remi@remirepo.net> - 1.0.11-4
+- add patch for PHP 8.4 from
+ https://github.com/krakjoe/pcov/pull/111
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.0.11-3
+- rebuild for PHP 8.3.0RC1
+
* Tue Jul 18 2023 Remi Collet <remi@remirepo.net> - 1.0.11-2
- build out of sources tree