summaryrefslogtreecommitdiffstats
path: root/php-pecl-parle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-parle.spec')
-rw-r--r--php-pecl-parle.spec21
1 files changed, 9 insertions, 12 deletions
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 4ee63da..c48a380 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -10,30 +10,26 @@
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
+%bcond_without tests
%if 0%{?scl:1}
%scl_package php-pecl-parle
%global sub_prefix %{scl_prefix}
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global with_tests 0%{!?_without_tests:1}
%global pecl_name parle
# After json
%global ini_name 40-%{pecl_name}.ini
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.8.1
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.8.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://github.com/weltling/parle/commit/7c692b9880aa6a501b6627d923bbc8ed1da1465f.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/weltling/parle/pull/17.patch
-Patch2: https://patch-diff.githubusercontent.com/raw/weltling/parle/pull/22.patch
-
BuildRequires: make
%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
# Always use DTS as c++14 is required
@@ -107,9 +103,6 @@ mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
-%patch0 -p1 -b .up
-%patch1 -p1 -b .pr17
-%patch2 -p1 -b .pr22
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
@@ -186,7 +179,7 @@ cd NTS
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite
make test "TESTS=--show-diff"
%endif
@@ -198,7 +191,7 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite
make test "TESTS=--show-diff"
%endif
@@ -241,6 +234,10 @@ fi
######### TODO : use --enable-parle-utf32 ?
%changelog
+* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 0.8.2-1
+- update to 0.8.2
+- drop patches merged upstream
+
* Fri Jan 15 2021 Remi Collet <remi@remirepo.net> - 0.8.1-9
- add patch for 8.0 from
https://github.com/weltling/parle/pull/22