summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-03 08:11:26 +0200
committerRemi Collet <remi@php.net>2023-07-03 08:11:26 +0200
commitf156c2303f8df44e4e797433b2c2818ce8ebd346 (patch)
tree990597476f8bbb87a938d96f59e05526558b8d59
parentea158f4b8b2e62427e72a9d5dc83cc5487f7ac98 (diff)
update to 0.8.5
build out of sources tree
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-parle.spec39
3 files changed, 38 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 8610ac8..61088c8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
parle
Lexing and parsing support => enabled
-Parle version => 0.8.4
+Parle version => 0.8.5
Parle internal UTF-32 => no
diff --git a/REFLECTION b/REFLECTION
index 1d8ccfe..6e812eb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 parle version 0.8.4 ] {
+Extension [ <persistent> extension #123 parle version 0.8.5 ] {
- Constants [1] {
Constant [ bool Parle\INTERNAL_UTF32 ] { }
@@ -259,7 +259,7 @@ Extension [ <persistent> extension #122 parle version 0.8.4 ] {
Property [ public $reduceId = 0 ]
}
- - Methods [18] {
+ - Methods [19] {
Method [ <internal:parle> public method token ] {
- Parameters [1] {
@@ -390,6 +390,13 @@ Extension [ <persistent> extension #122 parle version 0.8.4 ] {
}
- Return [ int ]
}
+
+ Method [ <internal:parle> public method readBison ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $input ]
+ }
+ }
}
}
@@ -417,7 +424,7 @@ Extension [ <persistent> extension #122 parle version 0.8.4 ] {
Property [ public $reduceId = 0 ]
}
- - Methods [18] {
+ - Methods [19] {
Method [ <internal:parle> public method token ] {
- Parameters [1] {
@@ -548,6 +555,13 @@ Extension [ <persistent> extension #122 parle version 0.8.4 ] {
}
- Return [ int ]
}
+
+ Method [ <internal:parle> public method readBison ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $input ]
+ }
+ }
}
}
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 8f8744e..023b5a1 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -17,10 +17,12 @@
%global pecl_name parle
# After json
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Parsing and lexing
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.8.4
+Version: 0.8.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD-2-Clause AND BSL-1.0
@@ -48,14 +50,13 @@ Provides: bundled(lexertl)
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Obsoletes: %{name}-devel < %{version}
+Obsoletes: %{name}-devel < %{version}
%description
@@ -70,8 +71,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{pecl_name}-%{version} NTS
-
# Don't install/register tests
sed -e '/tests/s/role="test"/role="src"/'\
-i package.xml
@@ -79,11 +78,11 @@ sed -e '/tests/s/role="test"/role="src"/'\
%if 0%{?_licensedir:1}
sed -e '/LICENSE/s/role="doc"/role="src"/;/licence/s/role="doc"/role="src"/' \
-i package.xml
-mv NTS/lib/parsertl14/include/parsertl/licence_1_0.txt NTS/LICENSE.lexert14
-mv NTS/lib/lexertl14/include/lexertl/licence_1_0.txt NTS/LICENSE.parsertl14
+mv %{sources}/lib/parsertl14/include/parsertl/licence_1_0.txt %{sources}/LICENSE.lexert14
+mv %{sources}/lib/lexertl14/include/lexertl/licence_1_0.txt %{sources}/LICENSE.parsertl14
%endif
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -92,9 +91,9 @@ if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -115,13 +114,14 @@ peclbuild() {
make %{?_smp_mflags}
}
-cd NTS
+cd %{sources}
%{__phpize}
+
+cd ../NTS
peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-%{__ztsphpize}
peclbuild %{__ztsphpconfig}
%endif
@@ -145,14 +145,11 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
-export NO_INTERACTION=1
-export REPORT_EXIT_STATUS=1
-
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
@@ -161,7 +158,7 @@ cd NTS
%if %{with tests}
: Upstream test suite
-make test "TESTS=--show-diff %{?_smp_mflags}"
+make test "TESTS=--show-diff -q %{?_smp_mflags}"
%endif
%if %{with_zts}
@@ -173,7 +170,7 @@ cd ../ZTS
%if %{with tests}
: Upstream test suite
-make test "TESTS=--show-diff %{?_smp_mflags}"
+make test "TESTS=--show-diff -q %{?_smp_mflags}"
%endif
%endif
@@ -199,7 +196,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE*}
+%{?_licensedir:%license %{sources}/LICENSE*}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -214,6 +211,10 @@ fi
######### TODO : use --enable-parle-utf32 ?
%changelog
+* Sun Jul 2 2023 Remi Collet <remi@remirepo.net> - 0.8.5-1
+- update to 0.8.5
+- build out of sources tree
+
* Sun May 14 2023 Remi Collet <remi@remirepo.net> - 0.8.4-1
- update to 0.8.4
- raise dependency on PHP 7.4