summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-16 08:06:20 +0200
committerRemi Collet <remi@php.net>2022-04-16 08:06:20 +0200
commite6ba26423d79464647ee0214dc978763cfece967 (patch)
tree2de72b1e3155d6db8601dafea4795bb41978f0db
parent9a4ae3386f2373bb814e7fe35a44d6aba62abadf (diff)
update to 0.8.3
drop patch merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--parle-php81.patch52
-rw-r--r--php-pecl-parle.spec20
4 files changed, 9 insertions, 67 deletions
diff --git a/PHPINFO b/PHPINFO
index 843bba4..1960e9c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
parle
Lexing and parsing support => enabled
-Parle version => 0.8.2
+Parle version => 0.8.3
Parle internal UTF-32 => no
diff --git a/REFLECTION b/REFLECTION
index 9a9b951..6e0a060 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 parle version 0.8.2 ] {
+Extension [ <persistent> extension #120 parle version 0.8.3 ] {
- Constants [1] {
Constant [ bool Parle\INTERNAL_UTF32 ] { }
diff --git a/parle-php81.patch b/parle-php81.patch
deleted file mode 100644
index 7025a4f..0000000
--- a/parle-php81.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 2d3c09723b0571250b58d717076214da9721e8a9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 9 Sep 2021 16:37:04 +0200
-Subject: [PATCH] Use ZEND_ACC_NOT_SERIALIZABLE for 8.1
-
----
- parle.cpp | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/parle.cpp b/parle.cpp
-index b2b6819..b966ab6 100644
---- a/parle.cpp
-+++ b/parle.cpp
-@@ -2818,8 +2818,12 @@ PHP_MINIT_FUNCTION(parle)
- zend_declare_property_long(ce, "state", sizeof("state")-1, 0, ZEND_ACC_PUBLIC);
- zend_declare_property_long(ce, "marker", sizeof("marker")-1, Z_L(-1), ZEND_ACC_PUBLIC);
- zend_declare_property_long(ce, "cursor", sizeof("cursor")-1, Z_L(-1), ZEND_ACC_PUBLIC);
-+#if PHP_VERSION_ID < 80100
- ce->serialize = zend_class_serialize_deny;
- ce->unserialize = zend_class_unserialize_deny;
-+#else
-+ ce->ce_flags |= ZEND_ACC_NOT_SERIALIZABLE;
-+#endif
- };
-
- memcpy(&parle_lexer_handlers, zend_get_std_object_handlers(), sizeof(zend_object_handlers));
-@@ -2865,8 +2869,12 @@ PHP_MINIT_FUNCTION(parle)
- #undef DECL_CONST
- zend_declare_property_long(ce, "action", sizeof("action")-1, 0, ZEND_ACC_PUBLIC);
- zend_declare_property_long(ce, "reduceId", sizeof("reduceId")-1, 0, ZEND_ACC_PUBLIC);
-+#if PHP_VERSION_ID < 80100
- ce->serialize = zend_class_serialize_deny;
- ce->unserialize = zend_class_unserialize_deny;
-+#else
-+ ce->ce_flags |= ZEND_ACC_NOT_SERIALIZABLE;
-+#endif
- };
-
- memcpy(&parle_parser_handlers, zend_get_std_object_handlers(), sizeof(zend_object_handlers));
-@@ -2915,8 +2923,12 @@ PHP_MINIT_FUNCTION(parle)
- zend_declare_property_bool(ParleStack_ce, "empty", sizeof("empty")-1, 0, ZEND_ACC_PUBLIC);
- zend_declare_property_long(ParleStack_ce, "size", sizeof("size")-1, 0, ZEND_ACC_PUBLIC);
- zend_declare_property_long(ParleStack_ce, "top", sizeof("top")-1, 0, ZEND_ACC_PUBLIC);
-+#if PHP_VERSION_ID < 80100
- ParleStack_ce->serialize = zend_class_serialize_deny;
- ParleStack_ce->unserialize = zend_class_unserialize_deny;
-+#else
-+ ParleStack_ce->ce_flags |= ZEND_ACC_NOT_SERIALIZABLE;
-+#endif
-
- INIT_CLASS_ENTRY(ce, "Parle\\LexerException", NULL);
- ParleLexerException_ce = zend_register_internal_class_ex(&ce, zend_exception_get_default());
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 5b7ac4a..232046f 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-parle
#
-# Copyright (c) 2017-2021 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,15 +23,13 @@
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.8.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.8.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php81.patch
-
BuildRequires: make
%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
# Always use DTS as c++14 is required
@@ -67,12 +65,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
Obsoletes: %{name}-devel < %{version}
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
@@ -108,8 +100,6 @@ mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
-%patch0 -p1 -b .php81
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -240,6 +230,10 @@ fi
######### TODO : use --enable-parle-utf32 ?
%changelog
+* Sat Apr 16 2022 Remi Collet <remi@remirepo.net> - 0.8.3-1
+- update to 0.8.3
+- drop patch merged upstream
+
* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 0.8.2-2
- add patch for PHP 8.1 from
https://github.com/weltling/parle/pull/28