summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION38
-rw-r--r--php-pecl-parallel.spec16
3 files changed, 28 insertions, 28 deletions
diff --git a/PHPINFO b/PHPINFO
index c5bff55..6d9d42d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
parallel
parallel support => enabled
-parallel version => 1.1.3
+parallel version => 1.1.4
diff --git a/REFLECTION b/REFLECTION
index a877e1d..cd932f3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
+Extension [ <persistent> extension #127 parallel version 1.1.4 ] {
- Functions {
Function [ <internal:parallel> function parallel\bootstrap ] {
@@ -19,7 +19,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
}
@@ -1677,21 +1677,21 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:parallel> public method cancel ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:parallel> public method cancelled ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
}
}
@@ -1699,7 +1699,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
Class [ <internal:parallel> final class parallel\Channel ] {
- Constants [1] {
- Constant [ public integer Infinite ] { -1 }
+ Constant [ public int Infinite ] { -1 }
}
- Static properties [0] {
@@ -1710,7 +1710,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> string $name ]
- Parameter #1 [ <optional> integer $capacity ]
+ Parameter #1 [ <optional> int $capacity ]
}
- Return [ \parallel\Channel ]
}
@@ -1731,7 +1731,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
Method [ <internal:parallel, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $capacity ]
+ Parameter #0 [ <optional> int $capacity ]
}
}
@@ -1812,7 +1812,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
Method [ <internal:parallel> public method setBlocking ] {
- Parameters [1] {
- Parameter #0 [ <required> boolean $blocking ]
+ Parameter #0 [ <required> bool $blocking ]
}
- Return [ void ]
}
@@ -1820,7 +1820,7 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
Method [ <internal:parallel> public method setTimeout ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $timeout ]
+ Parameter #0 [ <required> int $timeout ]
}
- Return [ void ]
}
@@ -1864,12 +1864,12 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
Class [ <internal:parallel> final class parallel\Events\Event\Type ] {
- Constants [6] {
- Constant [ public integer Read ] { 1 }
- Constant [ public integer Write ] { 2 }
- Constant [ public integer Close ] { 3 }
- Constant [ public integer Cancel ] { 5 }
- Constant [ public integer Kill ] { 6 }
- Constant [ public integer Error ] { 4 }
+ Constant [ public int Read ] { 1 }
+ Constant [ public int Write ] { 2 }
+ Constant [ public int Close ] { 3 }
+ Constant [ public int Cancel ] { 5 }
+ Constant [ public int Kill ] { 6 }
+ Constant [ public int Error ] { 4 }
}
- Static properties [0] {
@@ -1965,15 +1965,15 @@ Extension [ <persistent> extension #125 parallel version 1.1.3 ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:parallel> public method notify ] {
- Parameters [1] {
- Parameter #0 [ <optional> boolean $all ]
+ Parameter #0 [ <optional> bool $all ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:parallel> public method __invoke ] {
diff --git a/php-pecl-parallel.spec b/php-pecl-parallel.spec
index 56d869d..a4b938b 100644
--- a/php-pecl-parallel.spec
+++ b/php-pecl-parallel.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-parallel
#
-# Copyright (c) 2019 Remi Collet
+# Copyright (c) 2019-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,11 +13,11 @@
Summary: Parallel concurrency API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.3
+Version: 1.1.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
BuildRequires: %{?scl_prefix}php-zts-devel > 7.2
BuildRequires: %{?scl_prefix}php-pear
@@ -35,17 +35,14 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -168,6 +165,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Sep 17 2020 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- update to 1.1.4
+
* Wed Aug 14 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
- update to 1.1.3