summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-19 10:59:57 +0100
committerRemi Collet <remi@remirepo.net>2020-12-19 10:59:57 +0100
commitf321164d14784f03fe929eac38f941bbf569c601 (patch)
treed4204398ecafae9b84536281f79b0a3dc2dc5ccd
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION461
-rw-r--r--php-pecl-orng.spec201
5 files changed, 679 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..774c63c
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+orng
+
+orng support => enabled
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..29f0d84
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,461 @@
+Extension [ <persistent> extension #89 orng version 0.0.2 ] {
+
+ - Classes [6] {
+ Interface [ <internal:orng> interface ORNG\RNGInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:orng, ctor> abstract public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng> abstract public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng> abstract public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng> abstract public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng> abstract public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng> abstract public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng> abstract public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:orng> class ORNG\GLibCRand implements ORNG\RNGInterface, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:orng, prototype ORNG\RNGInterface, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:orng, prototype Serializable> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:orng, prototype Serializable> public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:orng> class ORNG\XorShift128Plus implements ORNG\RNGInterface, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:orng, prototype ORNG\RNGInterface, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:orng, prototype Serializable> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:orng, prototype Serializable> public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:orng> class ORNG\MT19937 implements ORNG\RNGInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:orng, prototype ORNG\RNGInterface, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:orng> class ORNG\MT19937PHP implements ORNG\RNGInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:orng, prototype ORNG\RNGInterface, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:orng> class ORNG\MT19937MB implements ORNG\RNGInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:orng, prototype ORNG\RNGInterface, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $seed ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method next64 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method range ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $min ]
+ Parameter #1 [ <required> int $max ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method shuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$array ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method arrayRand ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $arg ]
+ Parameter #1 [ <optional> $num ]
+ }
+ }
+
+ Method [ <internal:orng, prototype ORNG\RNGInterface> public method strShuffle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
+ }
+ - Return [ string ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-orng.spec b/php-pecl-orng.spec
new file mode 100644
index 0000000..1b748be
--- /dev/null
+++ b/php-pecl-orng.spec
@@ -0,0 +1,201 @@
+# remirepo spec file for php-pecl-orng
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-orng}
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name orng
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Object scoped PRNG Extension
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP
+Group: Development/Languages
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+
+%description
+Provides a past PHP compatible PRNG implementation of object scope.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+# Sanity check, really often broken
+extver=$(sed -n '/# define PHP_ORNG_VERSION/{s/.* "//;s/".*$//;p}' php_orng.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sat Dec 19 2020 Remi Collet <remi@remirepo.net> - 0.0.2-1
+- initial package
+