summaryrefslogtreecommitdiffstats
path: root/php-pecl-opentelemetry.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-30 13:48:54 +0200
committerRemi Collet <remi@php.net>2023-03-30 13:48:54 +0200
commitb239e3087599706102bfc6a3dd8b8a0178dcefa9 (patch)
treed9f71e9cee93d6b01ad39431eef6a410609b940d /php-pecl-opentelemetry.spec
initial package, version 1.0.0beta2
open https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/45 missing license file and tests open https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/46 missing extension version
Diffstat (limited to 'php-pecl-opentelemetry.spec')
-rw-r--r--php-pecl-opentelemetry.spec209
1 files changed, 209 insertions, 0 deletions
diff --git a/php-pecl-opentelemetry.spec b/php-pecl-opentelemetry.spec
new file mode 100644
index 0000000..90c7cfc
--- /dev/null
+++ b/php-pecl-opentelemetry.spec
@@ -0,0 +1,209 @@
+# remirepo spec file for php-pecl-opentelemetry
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl:%scl_package php-pecl-opentelemetry}
+
+# https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/46
+%bcond_with tests
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global proj_name opentelemetry
+%global pecl_name otel_instrumentation
+%global ini_name 40-%{proj_name}.ini
+
+%global upstream_version 1.0.0
+%global upstream_prever beta2
+%global sources %{proj_name}-%{upstream_version}%{?upstream_prever}
+
+Summary: OpenTelemetry auto-instrumentation support extension
+Name: %{?scl_prefix}php-pecl-%{proj_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: Apache-2.0
+URL: https://pecl.php.net/package/%{proj_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+# https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/45
+Source1: https://raw.githubusercontent.com/open-telemetry/opentelemetry-php-instrumentation/main/LICENSE
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{proj_name} = %{version}
+Provides: %{?scl_prefix}php-%{proj_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
+
+
+%description
+OpenTelemetry auto-instrumentation extension.
+
+This is a PHP extension for OpenTelemetry, to enable auto-instrumentation.
+It is based on zend_observer and requires php8+
+
+The extension allows creating pre and post hook functions to arbitrary PHP
+functions and methods, which allows those methods to be wrapped with telemetry.
+
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd %{sources}
+cp %{SOURCE1} LICENSE
+
+: Sanity check, really often broken
+extver=$(sed -n '/# define PHP_OTEL_INSTRUMENTATION_VERSION /{s/.* "//;s/".*$//;p}' php_otel_instrumentation.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+mkdir ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{proj_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%global _configure ../%{sources}/configure
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{_bindir}/phpize
+
+cd ../NTS
+%configure \
+ --with-otel_instrumentation \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --with-otel_instrumentation \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep -i '^%{pecl_name}$'
+
+%if %{with tests}
+cd %{sources}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep -i '^%{pecl_name}$'
+%endif
+
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{proj_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+#%%doc %%{pecl_docdir}/%%{pecl_name}
+%{?_licensedir:%license %{sources}/LICENSE*}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Mar 30 2023 Remi Collet <remi@remirepo.net> - 1.0.0~beta2-1
+- initial package, version 1.0.0beta2
+- open https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/45
+ missing license file and tests
+- open https://github.com/open-telemetry/opentelemetry-php-instrumentation/issues/46
+ missing extension version