summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-03 08:47:18 +0100
committerRemi Collet <remi@php.net>2025-02-03 08:47:18 +0100
commit300418f98a81020ef17497fd0e961c5a7d8587f9 (patch)
treeb4db0313cc7132b7ad70c6041429424ae718fa95
parent8b0f5993eeb5b89003d16596ef59013297966191 (diff)
update to 25.2.0HEADmaster
re-license spec file to CECILL-2.1 fix cpu affinity check and futext check using patch from https://github.com/openswoole/ext-openswoole/pull/376 raise dependency on PHP 8.2 rename to php-pecl-openswoole25 for new API update to 25.2.0 re-license spec file to CECILL-2.1 fix cpu affinity check and futext check using patch from https://github.com/openswoole/ext-openswoole/pull/376 raise dependency on PHP 8.2 rename to php-pecl-openswoole25 for new API
-rw-r--r--0001-fix-cpu-affinity-check.patch31
-rw-r--r--0002-fix-futex-check.patch24
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION50
-rw-r--r--php-pecl-openswoole25.spec39
5 files changed, 113 insertions, 41 deletions
diff --git a/0001-fix-cpu-affinity-check.patch b/0001-fix-cpu-affinity-check.patch
new file mode 100644
index 0000000..0f2f385
--- /dev/null
+++ b/0001-fix-cpu-affinity-check.patch
@@ -0,0 +1,31 @@
+From 4104a48da128cec17b9ffdc8d4a15c434e1499ec Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 3 Feb 2025 06:56:47 +0100
+Subject: [PATCH] fix cpu affinity check
+
+---
+ config.m4 | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/config.m4 b/config.m4
+index 729404684..f49e6a58f 100644
+--- a/config.m4
++++ b/config.m4
+@@ -129,6 +129,7 @@ AC_DEFUN([AC_SWOOLE_CPU_AFFINITY],
+ #include <sys/cpuset.h>
+ typedef cpuset_t cpu_set_t;
+ #else
++ #define _GNU_SOURCE 1
+ #include <sched.h>
+ #endif
+ ]], [[
+@@ -874,4 +875,4 @@ if test "$PHP_SWOOLE" != "no"; then
+ PHP_ADD_BUILD_DIR($ext_builddir/thirdparty/php/sockets)
+ PHP_ADD_BUILD_DIR($ext_builddir/thirdparty/php/standard)
+ PHP_ADD_BUILD_DIR($ext_builddir/thirdparty/php/curl)
+-fi
+\ No newline at end of file
++fi
+--
+2.48.1
+
diff --git a/0002-fix-futex-check.patch b/0002-fix-futex-check.patch
new file mode 100644
index 0000000..2b973ab
--- /dev/null
+++ b/0002-fix-futex-check.patch
@@ -0,0 +1,24 @@
+From 6f3d532e744dd8bfdfd1ce264a559c2f47bc49e3 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 3 Feb 2025 07:27:53 +0100
+Subject: [PATCH 2/2] fix futex check
+
+---
+ config.m4 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/config.m4 b/config.m4
+index f49e6a58f..f09daa052 100644
+--- a/config.m4
++++ b/config.m4
+@@ -163,6 +163,7 @@ AC_DEFUN([AC_SWOOLE_HAVE_FUTEX],
+ [
+ AC_MSG_CHECKING([for futex])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
++ #define _GNU_SOURCE 1
+ #include <linux/futex.h>
+ #include <syscall.h>
+ #include <unistd.h>
+--
+2.48.1
+
diff --git a/PHPINFO b/PHPINFO
index 0873c3f..f6345ec 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ openswoole
Open Swoole => enabled
Author => Open Swoole Group <hello@openswoole.com>
-Version => 22.1.2
-Built => Dec 11 2023 00:00:00
+Version => 25.2.0
+Built => Feb 3 2025 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,13 +14,13 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 3.1.1 30 May 2023
+openssl => OpenSSL 3.2.2 4 Jun 2024
dtls => enabled
http2 => enabled
hook-curl => enabled
pcre => enabled
-c-ares => 1.21.0
-zlib => 1.2.13
+c-ares => 1.34.4
+zlib => 1.3.1.zlib-ng
brotli => E16781312/D16781312
mutex_timedlock => enabled
pthread_barrier => enabled
diff --git a/REFLECTION b/REFLECTION
index a6806a0..15fb85a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
+Extension [ <persistent> extension #93 openswoole version 25.2.0 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -23,11 +23,11 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
}
- Constants [357] {
- Constant [ string OPENSWOOLE_VERSION ] { 22.1.2 }
- Constant [ int OPENSWOOLE_VERSION_ID ] { 220102 }
- Constant [ int OPENSWOOLE_MAJOR_VERSION ] { 22 }
- Constant [ int OPENSWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int OPENSWOOLE_RELEASE_VERSION ] { 2 }
+ Constant [ string OPENSWOOLE_VERSION ] { 25.2.0 }
+ Constant [ int OPENSWOOLE_VERSION_ID ] { 250200 }
+ Constant [ int OPENSWOOLE_MAJOR_VERSION ] { 25 }
+ Constant [ int OPENSWOOLE_MINOR_VERSION ] { 2 }
+ Constant [ int OPENSWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string OPENSWOOLE_EXTRA_VERSION ] { }
Constant [ int SWOOLE_SOCK_TCP ] { 1 }
Constant [ int SWOOLE_SOCK_TCP6 ] { 3 }
@@ -542,7 +542,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [0] {
}
- - Return [  ]
+ - Return [ Swoole\Timer\Iterator ]
}
Method [ <internal:openswoole> public method swoole_timer_clear ] {
@@ -2526,7 +2526,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method ksort ] {
@@ -2534,7 +2534,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uasort ] {
@@ -2542,7 +2542,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uksort ] {
@@ -2550,21 +2550,21 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natsort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natcasesort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method unserialize ] {
@@ -3077,7 +3077,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method ksort ] {
@@ -3085,7 +3085,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uasort ] {
@@ -3093,7 +3093,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method uksort ] {
@@ -3101,21 +3101,21 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natsort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator> public method natcasesort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayIterator, prototype Serializable> public method unserialize ] {
@@ -3301,7 +3301,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject> public method ksort ] {
@@ -3309,7 +3309,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject> public method uasort ] {
@@ -3317,7 +3317,7 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject> public method uksort ] {
@@ -3325,21 +3325,21 @@ Extension [ <persistent> extension #67 openswoole version 22.1.2 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject> public method natsort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject> public method natcasesort ] {
- Parameters [0] {
}
- - Tentative return [ bool ]
+ - Tentative return [ true ]
}
Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method unserialize ] {
diff --git a/php-pecl-openswoole25.spec b/php-pecl-openswoole25.spec
index 92b3a46..f802b41 100644
--- a/php-pecl-openswoole25.spec
+++ b/php-pecl-openswoole25.spec
@@ -1,13 +1,13 @@
-# remirepo spec file for php-pecl-openswoole22
+# remirepo spec file for php-pecl-openswoole25
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%{?scl:%scl_package php-pecl-openswoole22}
+%{?scl:%scl_package php-pecl-openswoole25}
# See https://github.com/openswoole/swoole-src/issues/287
%global with_zts 0
@@ -20,14 +20,14 @@
%bcond_without brotli
%bcond_without pgsql
-%global upstream_version 22.1.2
+%global upstream_version 25.2.0
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: High Performance Programmatic Server for PHP with Async IO, Coroutines and Fibers
-Name: %{?scl_prefix}php-pecl-%{pecl_name}22
+Name: %{?scl_prefix}php-pecl-%{pecl_name}25
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# SPDX: extension is Apache-2.0
@@ -36,10 +36,13 @@ License: Apache-2.0 AND BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
+Patch0: 0001-fix-cpu-affinity-check.patch
+Patch1: 0002-fix-futex-check.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 8.1
+BuildRequires: %{?scl_prefix}php-devel >= 8.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-sockets
@@ -68,19 +71,22 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10 || "%{php_version}" > "8.3"
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 22
+%if 0%{?fedora} >= 42 || 0%{?rhel} >= 10 || "%{php_version}" > "8.4"
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 25
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}22 < 25
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%else
# A single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 22
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 25
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}22 < 25
%endif
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-swoole
Conflicts: %{?scl_prefix}php-pecl-swoole2
Conflicts: %{?scl_prefix}php-pecl-swoole4
Conflicts: %{?scl_prefix}php-pecl-swoole5
+Conflicts: %{?scl_prefix}php-pecl-swoole6
%description
@@ -117,6 +123,9 @@ sed \
cd %{sources}
+%patch -P0 -p1 -b .pr376.1
+%patch -P1 -p1 -b .pr376.2
+
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -261,6 +270,14 @@ OPT="--no-php-ini"
%changelog
+* Mon Feb 3 2025 Remi Collet <remi@remirepo.net> - 25.2.0-1
+- update to 25.2.0
+- re-license spec file to CECILL-2.1
+- fix cpu affinity check and futext check using patch from
+ https://github.com/openswoole/ext-openswoole/pull/376
+- raise dependency on PHP 8.2
+- rename to php-pecl-openswoole25 for new API
+
* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 22.1.2-3
- drop BuildRequires pcre-devel