summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-08 13:43:21 +0100
committerRemi Collet <remi@php.net>2023-11-08 13:43:21 +0100
commitfb12e02e68457a8d466639290675e00b5817b01a (patch)
tree7c22bf6da4bceff2a9fd435203d87a92ab749150
parentb8766f3b78bc9a0cc00a035b87d255a85eaeb132 (diff)
update to 22.1.0
drop patches merged upstream raise dependency on PHP 8.1
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION187
-rw-r--r--openswoole-gcc13.patch21
-rw-r--r--openswoole-php83.patch29
-rw-r--r--php-pecl-openswoole22.spec17
5 files changed, 128 insertions, 134 deletions
diff --git a/PHPINFO b/PHPINFO
index 659f30d..d3cc7ce 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ openswoole
Open Swoole => enabled
Author => Open Swoole Group <hello@openswoole.com>
-Version => 22.0.0
-Built => Dec 22 2022 00:00:00
+Version => 22.1.0
+Built => Nov 8 2023 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,12 +14,12 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 3.0.5 5 Jul 2022
+openssl => OpenSSL 3.0.9 30 May 2023
dtls => enabled
http2 => enabled
hook-curl => enabled
pcre => enabled
-c-ares => 1.17.2
+c-ares => 1.19.1
zlib => 1.2.12
brotli => E16777225/D16777225
mutex_timedlock => enabled
diff --git a/REFLECTION b/REFLECTION
index 5d35426..cc07aaf 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
+Extension [ <persistent> extension #88 openswoole version 22.1.0 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -23,10 +23,10 @@ Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
}
- Constants [357] {
- Constant [ string OPENSWOOLE_VERSION ] { 22.0.0 }
- Constant [ int OPENSWOOLE_VERSION_ID ] { 220000 }
+ Constant [ string OPENSWOOLE_VERSION ] { 22.1.0 }
+ Constant [ int OPENSWOOLE_VERSION_ID ] { 220100 }
Constant [ int OPENSWOOLE_MAJOR_VERSION ] { 22 }
- Constant [ int OPENSWOOLE_MINOR_VERSION ] { 0 }
+ Constant [ int OPENSWOOLE_MINOR_VERSION ] { 1 }
Constant [ int OPENSWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string OPENSWOOLE_EXTRA_VERSION ] { }
Constant [ int SWOOLE_SOCK_TCP ] { 1 }
@@ -732,7 +732,7 @@ Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
}
}
- - Classes [49] {
+ - Classes [50] {
Class [ <internal:openswoole> final class OpenSwoole\Constant ] {
- Constants [411] {
@@ -7552,16 +7552,7 @@ Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
Class [ <internal:openswoole> class OpenSwoole\Coroutine\PostgreSQL ] {
- - Constants [17] {
- Constant [ public int PGSQL_ASSOC ] { 1 }
- Constant [ public int PGSQL_NUM ] { 2 }
- Constant [ public int PGSQL_BOTH ] { 3 }
- Constant [ public int PGRES_EMPTY_QUERY ] { 0 }
- Constant [ public int PGRES_COMMAND_OK ] { 1 }
- Constant [ public int PGRES_TUPLES_OK ] { 2 }
- Constant [ public int PGRES_BAD_RESPONSE ] { 5 }
- Constant [ public int PGRES_NONFATAL_ERROR ] { 6 }
- Constant [ public int PGRES_FATAL_ERROR ] { 7 }
+ - Constants [8] {
Constant [ public int PG_CONNECTION_OK ] { 0 }
Constant [ public int PG_CONNECTION_BAD ] { 1 }
Constant [ public int PG_CONNECTION_STARTED ] { 2 }
@@ -7586,7 +7577,7 @@ Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
Property [ public $notices = NULL ]
}
- - Methods [20] {
+ - Methods [14] {
Method [ <internal:openswoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -7595,144 +7586,198 @@ Extension [ <persistent> extension #120 openswoole version 22.0.0 ] {
Method [ <internal:openswoole> public method connect ] {
- - Parameters [1] {
- Parameter #0 [ <required> $conninfo ]
+ - Parameters [2] {
+ Parameter #0 [ <required> string $conninfo ]
+ Parameter #1 [ <optional> float $timeout = 2 ]
}
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method query ] {
- Parameters [1] {
- Parameter #0 [ <optional> $query = <default> ]
+ Parameter #0 [ <required> string $query ]
}
+ - Return [ OpenSwoole\Coroutine\PostgreSQLStatement|false ]
}
Method [ <internal:openswoole> public method prepare ] {
- - Parameters [2] {
- Parameter #0 [ <required> $stmtname ]
- Parameter #1 [ <required> $query ]
+ - Parameters [1] {
+ Parameter #0 [ <required> string $query ]
}
+ - Return [ OpenSwoole\Coroutine\PostgreSQLStatement|false ]
}
- Method [ <internal:openswoole> public method execute ] {
+ Method [ <internal:openswoole> public method metaData ] {
- - Parameters [2] {
- Parameter #0 [ <required> $stmtname ]
- Parameter #1 [ <required> $pv_param_arr ]
+ - Parameters [1] {
+ Parameter #0 [ <required> string $table_name ]
}
+ - Return [ array|false ]
}
- Method [ <internal:openswoole> public method fetchAll ] {
+ Method [ <internal:openswoole> public method escape ] {
- - Parameters [2] {
- Parameter #0 [ <optional> $result = <default> ]
- Parameter #1 [ <optional> $result_type = <default> ]
+ - Parameters [1] {
+ Parameter #0 [ <required> string $string ]
}
+ - Return [ string|false ]
}
- Method [ <internal:openswoole> public method affectedRows ] {
+ Method [ <internal:openswoole> public method escapeLiteral ] {
- Parameters [1] {
- Parameter #0 [ <optional> $result = <default> ]
+ Parameter #0 [ <required> string $string ]
}
+ - Return [ string|false ]
}
- Method [ <internal:openswoole> public method numRows ] {
+ Method [ <internal:openswoole> public method escapeIdentifier ] {
- Parameters [1] {
- Parameter #0 [ <optional> $result = <default> ]
+ Parameter #0 [ <required> string $string ]
}
+ - Return [ string|false ]
}
- Method [ <internal:openswoole> public method fieldCount ] {
+ Method [ <internal:openswoole> public method createLOB ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $result = <default> ]
+ - Parameters [0] {
}
+ - Return [ int|false ]
}
- Method [ <internal:openswoole> public method metaData ] {
+ Method [ <internal:openswoole> public method openLOB ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $oid ]
+ Parameter #1 [ <optional> string $mode = "rb" ]
+ }
+ }
+
+ Method [ <internal:openswoole> public method unlinkLOB ] {
- Parameters [1] {
- Parameter #0 [ <required> $table_name ]
+ Parameter #0 [ <required> int $oid ]
}
+ - Return [ bool ]
}
- Method [ <internal:openswoole> public method escape ] {
+ Method [ <internal:openswoole> public method status ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:openswoole> public method reset ] {
- Parameters [1] {
- Parameter #0 [ <required> $string ]
+ Parameter #0 [ <optional> float $timeout = 0 ]
}
+ - Return [ bool ]
}
- Method [ <internal:openswoole> public method escapeLiteral ] {
+ Method [ <internal:openswoole> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:openswoole> class OpenSwoole\Coroutine\PostgreSQLStatement ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ public $error = NULL ]
+ Property [ public $errCode = 0 ]
+ Property [ public $resultStatus = 0 ]
+ Property [ public $resultDiag = NULL ]
+ Property [ public $notices = NULL ]
+ }
+
+ - Methods [9] {
+ Method [ <internal:openswoole> public method execute ] {
- Parameters [1] {
- Parameter #0 [ <required> $string ]
+ Parameter #0 [ <optional> array $params = [] ]
}
+ - Return [ bool ]
}
- Method [ <internal:openswoole> public method escapeIdentifier ] {
+ Method [ <internal:openswoole> public method fetchAll ] {
- Parameters [1] {
- Parameter #0 [ <required> $string ]
+ Parameter #0 [ <optional> int $result_type = OPENSWOOLE_PGSQL_ASSOC ]
}
+ - Return [ array|false ]
}
- Method [ <internal:openswoole> public method fetchObject ] {
+ Method [ <internal:openswoole> public method affectedRows ] {
- - Parameters [5] {
- Parameter #0 [ <required> $result ]
- Parameter #1 [ <optional> $row = <default> ]
- Parameter #2 [ <optional> $class_name = <default> ]
- Parameter #3 [ <optional> $l = <default> ]
- Parameter #4 [ <optional> $ctor_params = <default> ]
+ - Parameters [0] {
}
+ - Return [ int|false ]
}
- Method [ <internal:openswoole> public method fetchAssoc ] {
+ Method [ <internal:openswoole> public method numRows ] {
- - Parameters [2] {
- Parameter #0 [ <required> $result ]
- Parameter #1 [ <optional> $row = <default> ]
+ - Parameters [0] {
}
+ - Return [ int|false ]
}
- Method [ <internal:openswoole> public method fetchArray ] {
+ Method [ <internal:openswoole> public method fieldCount ] {
- - Parameters [3] {
- Parameter #0 [ <required> $result ]
- Parameter #1 [ <optional> $row = <default> ]
- Parameter #2 [ <optional> $result_type = <default> ]
+ - Parameters [0] {
}
+ - Return [ int|false ]
}
- Method [ <internal:openswoole> public method fetchRow ] {
+ Method [ <internal:openswoole> public method fetchObject ] {
- Parameters [3] {
- Parameter #0 [ <required> $result ]
- Parameter #1 [ <optional> $row = <default> ]
- Parameter #2 [ <optional> $result_type = <default> ]
+ Parameter #0 [ <optional> int $row = null ]
+ Parameter #1 [ <optional> ?string $class_name = null ]
+ Parameter #2 [ <optional> array $ctor_params = [] ]
}
+ - Return [ object|false ]
}
- Method [ <internal:openswoole> public method status ] {
+ Method [ <internal:openswoole> public method fetchAssoc ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $row = null ]
}
+ - Return [ array|false ]
}
- Method [ <internal:openswoole> public method reset ] {
+ Method [ <internal:openswoole> public method fetchArray ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <optional> int $row = null ]
+ Parameter #1 [ <optional> int $result_type = OPENSWOOLE_PGSQL_BOTH ]
}
+ - Return [ array|false ]
}
- Method [ <internal:openswoole> public method __destruct ] {
+ Method [ <internal:openswoole> public method fetchRow ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <optional> int $row = null ]
+ Parameter #1 [ <optional> int $result_type = OPENSWOOLE_PGSQL_NUM ]
}
+ - Return [ array|false ]
}
}
}
diff --git a/openswoole-gcc13.patch b/openswoole-gcc13.patch
deleted file mode 100644
index ec7c379..0000000
--- a/openswoole-gcc13.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From de189ecb0c8ba3c1e1bab01e4f82f7d7ba54d4e2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 17 Feb 2023 09:23:33 +0100
-Subject: [PATCH] Add missing header for GCC 13
-
----
- include/swoole_proxy.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/include/swoole_proxy.h b/include/swoole_proxy.h
-index b74701ef0..6abf3cd24 100644
---- a/include/swoole_proxy.h
-+++ b/include/swoole_proxy.h
-@@ -17,6 +17,7 @@
- #pragma once
-
- #include <string>
-+#include <cstdint>
-
- #define SW_SOCKS5_VERSION_CODE 0x05
-
diff --git a/openswoole-php83.patch b/openswoole-php83.patch
deleted file mode 100644
index cfc37e2..0000000
--- a/openswoole-php83.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7aef32c30f37b9278ab86a0f0b64c0e740a6d06e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 4 Sep 2023 08:36:21 +0200
-Subject: [PATCH] fix php_url_encode_hash_ex call for 8.3
-
----
- ext-src/php_swoole_private.h | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/ext-src/php_swoole_private.h b/ext-src/php_swoole_private.h
-index 08053f6c9..7bcfaaa84 100644
---- a/ext-src/php_swoole_private.h
-+++ b/ext-src/php_swoole_private.h
-@@ -1041,10 +1041,14 @@ static sw_inline char *php_swoole_http_build_query(zval *zdata, size_t *length,
- #if PHP_VERSION_ID < 80000
- if (php_url_encode_hash_ex(
- HASH_OF(zdata), formstr, NULL, 0, NULL, 0, NULL, 0, NULL, NULL, (int) PHP_QUERY_RFC1738) == FAILURE) {
--#else
-+#elif PHP_VERSION_ID < 80300
- if (HASH_OF(zdata)) {
- php_url_encode_hash_ex(HASH_OF(zdata), formstr, NULL, 0, NULL, 0, NULL, 0, NULL, NULL, (int) PHP_QUERY_RFC1738);
- } else {
-+#else
-+ if (HASH_OF(zdata)) {
-+ php_url_encode_hash_ex(HASH_OF(zdata), formstr, NULL, NULL, NULL, NULL, NULL, (int) PHP_QUERY_RFC1738);
-+ } else {
- #endif
- if (formstr->s) {
- smart_str_free(formstr);
diff --git a/php-pecl-openswoole22.spec b/php-pecl-openswoole22.spec
index e0980b6..d53b7b5 100644
--- a/php-pecl-openswoole22.spec
+++ b/php-pecl-openswoole22.spec
@@ -24,7 +24,7 @@
%endif
%bcond_without pgsql
-%global upstream_version 22.0.0
+%global upstream_version 22.1.0
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -40,13 +40,10 @@ License: Apache-2.0 AND BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-gcc13.patch
-Patch1: %{pecl_name}-php83.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-sockets
@@ -129,9 +126,6 @@ sed \
cd %{sources}
-%patch -P0 -p1 -b .pr304
-%patch -P1 -p1 -b .pr328
-
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -289,7 +283,7 @@ OPT="--no-php-ini"
%doc %{pecl_docdir}/%{pecl_name}/gdbinit
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/tools
-%doc %{pecl_docdir}/%{pecl_name}/travis
+%doc %{pecl_docdir}/%{pecl_name}/ci
%doc %{pecl_docdir}/%{pecl_name}/CHANGELOG
%{php_incldir}/ext/%{pecl_name}
@@ -299,6 +293,11 @@ OPT="--no-php-ini"
%changelog
+* Wed Nov 8 2023 Remi Collet <remi@remirepo.net> - 22.1.0-1
+- update to 22.1.0
+- drop patches merged upstream
+- raise dependency on PHP 8.1
+
* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 22.0.0-3
- build out of sources tree
- add patch for PHP 8.3 from