summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-29 15:42:28 +0100
committerRemi Collet <remi@php.net>2021-11-29 15:42:28 +0100
commit872986b6d6a4e607bfa2bea763450bbab28de07b (patch)
treeaa4e1d61b74009fb7d73efd29199008c748e5676
parentf4b8a5058dd6ba9c416c394254c1e02c1d863bcd (diff)
update to 4.8.1
drop patch merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION36
-rw-r--r--php-pecl-openswoole.spec10
3 files changed, 24 insertions, 24 deletions
diff --git a/PHPINFO b/PHPINFO
index e99cb7b..f10b133 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ openswoole
Open Swoole => enabled
Author => Open Swoole Group & Contributors <hello@swoole.co.uk>
-Version => 4.8.0
+Version => 4.8.1
Built => Nov 29 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
diff --git a/REFLECTION b/REFLECTION
index 11e5888..239296c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
+Extension [ <persistent> extension #88 openswoole version 4.8.1 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -30,11 +30,11 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
}
- Constants [378] {
- Constant [ string SWOOLE_VERSION ] { 4.8.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 40800 }
+ Constant [ string SWOOLE_VERSION ] { 4.8.1 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40801 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -1272,7 +1272,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [1] {
Parameter #0 [ <required> int $value ]
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method wait ] {
@@ -1352,7 +1352,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [1] {
Parameter #0 [ <required> int $value ]
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method cmpset ] {
@@ -1731,7 +1731,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $settings ]
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method on ] {
@@ -1780,7 +1780,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [0] {
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method stop ] {
@@ -2403,7 +2403,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #1 [ <optional> int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ]
Parameter #2 [ <optional> int $limit = 0 ]
}
- - Return [ false|void ]
+ - Return [ void ]
}
Method [ <internal:openswoole> static public method getElapsed ] {
@@ -3263,7 +3263,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #0 [ <required> callable $callback ]
Parameter #1 [ <optional> mixed ...$params ]
}
- - Return [ false|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method parallel ] {
@@ -3288,7 +3288,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [0] {
}
- - Return [ array|void ]
+ - Return [ ?array ]
}
Method [ <internal:openswoole> public method start ] {
@@ -7449,7 +7449,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $settings ]
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method on ] {
@@ -7615,7 +7615,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #7 [ <optional> string $sameSite = "" ]
Parameter #8 [ <optional> string $priority = "" ]
}
- - Return [ false|void ]
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method setCookie ] {
@@ -7631,7 +7631,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #7 [ <optional> string $sameSite = "" ]
Parameter #8 [ <optional> string $priority = "" ]
}
- - Return [ false|void ]
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method rawcookie ] {
@@ -7647,7 +7647,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #7 [ <optional> string $sameSite = "" ]
Parameter #8 [ <optional> string $priority = "" ]
}
- - Return [ false|void ]
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method status ] {
@@ -7675,7 +7675,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #1 [ <required> string $value ]
Parameter #2 [ <optional> bool $format = true ]
}
- - Return [ false|void ]
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method setHeader ] {
@@ -7685,7 +7685,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #1 [ <required> string $value ]
Parameter #2 [ <optional> bool $format = true ]
}
- - Return [ false|void ]
+ - Return [ bool ]
}
Method [ <internal:openswoole> public method write ] {
@@ -7720,7 +7720,7 @@ Extension [ <persistent> extension #88 openswoole version 4.8.0 ] {
Parameter #0 [ <required> string $url ]
Parameter #1 [ <optional> int $status_code = 302 ]
}
- - Return [ bool|void ]
+ - Return [ ?bool ]
}
Method [ <internal:openswoole> public method detach ] {
diff --git a/php-pecl-openswoole.spec b/php-pecl-openswoole.spec
index b6ef144..0ba2c64 100644
--- a/php-pecl-openswoole.spec
+++ b/php-pecl-openswoole.spec
@@ -28,7 +28,7 @@
%endif
%bcond_without pgsql
-%global upstream_version 4.8.0
+%global upstream_version 4.8.1
#global upstream_prever RC2
@@ -42,8 +42,6 @@ License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-pg9.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -156,8 +154,6 @@ sed \
cd NTS
-%patch0 -p1
-
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -330,6 +326,10 @@ cd ../ZTS
%changelog
+* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 4.8.1-1
+- update to 4.8.1
+- drop patch merged upstream
+
* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 4.8.0-1
- update to 4.8.0
- enable postgresql support