summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION141
-rw-r--r--php-pecl-opencensus.spec19
2 files changed, 146 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..ddaabe1
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,141 @@
+Extension [ <persistent> extension #15 opencensus version 0.0.2 ] {
+
+ - Functions {
+ Function [ <internal:opencensus> function opencensus_version ] {
+ }
+ Function [ <internal:opencensus> function opencensus_trace_function ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $functionName ]
+ Parameter #1 [ <optional> $handler ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_method ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $className ]
+ Parameter #1 [ <required> string $methodName ]
+ Parameter #2 [ <optional> $handler ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_list ] {
+ }
+ Function [ <internal:opencensus> function opencensus_trace_begin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $spanName ]
+ Parameter #1 [ <optional> array $spanOptions ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_finish ] {
+ }
+ Function [ <internal:opencensus> function opencensus_trace_clear ] {
+ }
+ Function [ <internal:opencensus> function opencensus_trace_set_context ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $traceId ]
+ Parameter #1 [ <optional> string $parentSpanId ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_context ] {
+ }
+ Function [ <internal:opencensus> function opencensus_trace_add_label ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $value ]
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_trace_add_root_label ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $value ]
+ }
+ }
+ }
+
+ - Classes [2] {
+ Class [ <internal:opencensus> class OpenCensus\Trace\Span ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [6] {
+ Property [ <default> protected $name ]
+ Property [ <default> protected $spanId ]
+ Property [ <default> protected $parentSpanId ]
+ Property [ <default> protected $startTime ]
+ Property [ <default> protected $endTime ]
+ Property [ <default> protected $labels ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:opencensus, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $spanOptions ]
+ }
+ }
+
+ Method [ <internal:opencensus> public method name ] {
+ }
+
+ Method [ <internal:opencensus> public method spanId ] {
+ }
+
+ Method [ <internal:opencensus> public method parentSpanId ] {
+ }
+
+ Method [ <internal:opencensus> public method labels ] {
+ }
+
+ Method [ <internal:opencensus> public method startTime ] {
+ }
+
+ Method [ <internal:opencensus> public method endTime ] {
+ }
+ }
+ }
+
+ Class [ <internal:opencensus> class OpenCensus\Trace\Context ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> protected $spanId ]
+ Property [ <default> protected $traceId ]
+ }
+
+ - Methods [3] {
+ Method [ <internal:opencensus, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $contextOptions ]
+ }
+ }
+
+ Method [ <internal:opencensus> public method spanId ] {
+ }
+
+ Method [ <internal:opencensus> public method traceId ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-opencensus.spec b/php-pecl-opencensus.spec
index 71dea73..86a6b19 100644
--- a/php-pecl-opencensus.spec
+++ b/php-pecl-opencensus.spec
@@ -22,16 +22,13 @@
Summary: A stats collection and distributed tracing framework
Name: %{?sub_prefix}php-pecl-opencensus
-Version: 0.0.1
+Version: 0.0.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/census-instrumentation/opencensus-php/issues/12
-Source1: https://raw.githubusercontent.com/census-instrumentation/opencensus-php/master/ext/tests/common.php
-
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -92,7 +89,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} tests
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_OPENCENSUS_VERSION/{s/.* "//;s/".*$//;p}' php_opencensus.h)
@@ -159,11 +155,6 @@ done
%check
-%if %{__isa_bits} < 64
-# https://github.com/census-instrumentation/opencensus-php/issues/13
-rm ?TS/tests/manual_spans_default_options.phpt
-%endif
-
cd NTS
: Minimal load test for NTS extension
@@ -188,14 +179,11 @@ cd ../ZTS
--modules | grep %{pecl_name}
%if %{with_tests}
-# ignore ZTS test suite, see
-# https://github.com/census-instrumentation/opencensus-php/issues/14
-
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=0 \
+REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
%endif
%endif
@@ -236,6 +224,9 @@ fi
%changelog
+* Wed Aug 16 2017 Remi Collet <remi@remirepo.net> - 0.0.2-1
+- Update to 0.0.2
+
* Tue Aug 15 2017 Remi Collet <remi@remirepo.net> - 0.0.1-1
- new package, version 0.0.1 (devel)
- open https://github.com/census-instrumentation/opencensus-php/issues/13