summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION21
-rw-r--r--common.php69
-rw-r--r--php-pecl-opencensus.spec5
3 files changed, 21 insertions, 74 deletions
diff --git a/REFLECTION b/REFLECTION
index ddaabe1..d87dfc6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #15 opencensus version 0.0.2 ] {
+Extension [ <persistent> extension #114 opencensus version 0.0.3 ] {
- Functions {
Function [ <internal:opencensus> function opencensus_version ] {
@@ -59,7 +59,12 @@ Extension [ <persistent> extension #15 opencensus version 0.0.2 ] {
- Classes [2] {
Class [ <internal:opencensus> class OpenCensus\Trace\Span ] {
- - Constants [0] {
+ - Constants [5] {
+ Constant [ integer SPAN_KIND_UNKNOWN ] { 0 }
+ Constant [ integer SPAN_KIND_CLIENT ] { 1 }
+ Constant [ integer SPAN_KIND_SERVER ] { 2 }
+ Constant [ integer SPAN_KIND_PRODUCER ] { 3 }
+ Constant [ integer SPAN_KIND_CONSUMER ] { 4 }
}
- Static properties [0] {
@@ -68,16 +73,18 @@ Extension [ <persistent> extension #15 opencensus version 0.0.2 ] {
- Static methods [0] {
}
- - Properties [6] {
+ - Properties [8] {
Property [ <default> protected $name ]
Property [ <default> protected $spanId ]
Property [ <default> protected $parentSpanId ]
Property [ <default> protected $startTime ]
Property [ <default> protected $endTime ]
+ Property [ <default> protected $kind ]
Property [ <default> protected $labels ]
+ Property [ <default> protected $backtrace ]
}
- - Methods [7] {
+ - Methods [9] {
Method [ <internal:opencensus, ctor> public method __construct ] {
- Parameters [1] {
@@ -102,6 +109,12 @@ Extension [ <persistent> extension #15 opencensus version 0.0.2 ] {
Method [ <internal:opencensus> public method endTime ] {
}
+
+ Method [ <internal:opencensus> public method backtrace ] {
+ }
+
+ Method [ <internal:opencensus> public method kind ] {
+ }
}
}
diff --git a/common.php b/common.php
deleted file mode 100644
index 7d06872..0000000
--- a/common.php
+++ /dev/null
@@ -1,69 +0,0 @@
-<?php
-
-namespace
-{
- function bar()
- {
- return 1;
- }
-
- function foo($x)
- {
- $sum = 0;
- for ($idx = 0; $idx < $x; $idx++) {
- $sum += bar();
- }
- return $sum;
- }
-
- function add($a, $b)
- {
- return $a + $b;
- }
-
- class Foo
- {
- public $val;
-
- public function __construct($val = null)
- {
- $this->val = $val;
- }
-
- public static function asdf()
- {
- return 'qwer';
- }
-
- public static function plus($a, $b)
- {
- return $a + $b;
- }
-
- public function bar()
- {
- return 1;
- }
-
- public function add($a, $b)
- {
- return $a + $b;
- }
-
- public function context()
- {
- return opencensus_trace_context();
- }
- }
-}
-
-namespace Illuminate\Database\Eloquent
-{
- // fake class with method we know is traced
- class Model
- {
- public function delete() {
-
- }
- }
-}
diff --git a/php-pecl-opencensus.spec b/php-pecl-opencensus.spec
index 86a6b19..d6e8435 100644
--- a/php-pecl-opencensus.spec
+++ b/php-pecl-opencensus.spec
@@ -22,7 +22,7 @@
Summary: A stats collection and distributed tracing framework
Name: %{?sub_prefix}php-pecl-opencensus
-Version: 0.0.2
+Version: 0.0.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
@@ -224,6 +224,9 @@ fi
%changelog
+* Sat Aug 26 2017 Remi Collet <remi@remirepo.net> - 0.0.3-1
+- Update to 0.0.3
+
* Wed Aug 16 2017 Remi Collet <remi@remirepo.net> - 0.0.2-1
- Update to 0.0.2