summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-03 06:27:53 +0200
committerRemi Collet <remi@remirepo.net>2018-04-03 06:27:53 +0200
commitf6dd79250791f6dfedc9b01fda4fc17b6b2abce5 (patch)
tree79e204ef7bc905df57ecafdd5228e06e79ed8d7c
parent625e106270d0feb837faaa2e0cb33886f09bb875 (diff)
v0.2.0
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-opencensus.spec6
2 files changed, 15 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 52f3afa..080a5b4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #192 opencensus version 0.1.4 ] {
+Extension [ <persistent> extension #196 opencensus version 0.2.0 ] {
- Functions {
Function [ <internal:opencensus> function opencensus_version ] {
@@ -85,7 +85,7 @@ Extension [ <persistent> extension #192 opencensus version 0.1.4 ] {
- Static methods [0] {
}
- - Properties [9] {
+ - Properties [11] {
Property [ <default> protected $name ]
Property [ <default> protected $spanId ]
Property [ <default> protected $parentSpanId ]
@@ -95,9 +95,11 @@ Extension [ <persistent> extension #192 opencensus version 0.1.4 ] {
Property [ <default> protected $stackTrace ]
Property [ <default> protected $links ]
Property [ <default> protected $timeEvents ]
+ Property [ <default> protected $kind ]
+ Property [ <default> protected $sameProcessAsParentSpan ]
}
- - Methods [11] {
+ - Methods [13] {
Method [ <internal:opencensus, ctor> public method __construct ] {
- Parameters [1] {
@@ -134,6 +136,12 @@ Extension [ <persistent> extension #192 opencensus version 0.1.4 ] {
Method [ <internal:opencensus> public method timeEvents ] {
}
+
+ Method [ <internal:opencensus> public method kind ] {
+ }
+
+ Method [ <internal:opencensus> public method sameProcessAsParentSpan ] {
+ }
}
}
diff --git a/php-pecl-opencensus.spec b/php-pecl-opencensus.spec
index 54d958e..44d9a58 100644
--- a/php-pecl-opencensus.spec
+++ b/php-pecl-opencensus.spec
@@ -24,7 +24,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 0.1.4
+%global upstream_version 0.2.0
#global upstream_prever RC2
Summary: A stats collection and distributed tracing framework
@@ -43,7 +43,6 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < 1.2.7
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
@@ -231,6 +230,9 @@ fi
%changelog
+* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0
+
* Tue Mar 6 2018 Remi Collet <remi@remirepo.net> - 0.1.4-1
- Update to 0.1.4