summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-10 08:57:53 +0200
committerRemi Collet <remi@remirepo.net>2021-06-10 08:57:53 +0200
commita85ab2114ebd344f3d78bd624cf72744bf813450 (patch)
tree58e9f319a5b6f567faea4d00f157b5e27cf70a27
parent00ce044206ea5f761e05c9dfedc6b00d16c8550b (diff)
update to 0.3.0
report segfault with PHP 7.0 https://github.com/census-instrumentation/opencensus-php/issues/274 report 1 failed test with PHP 8.1.0alpha1 https://github.com/census-instrumentation/opencensus-php/issues/273
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION102
-rw-r--r--php-pecl-opencensus.spec59
3 files changed, 139 insertions, 30 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..5c4f6ed
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+opencensus
+
+OpenCensus support => enabled
+OpenCensus module version => 0.3.0
+
+Directive => Local Value => Master Value
+opencensus.client.path => /tmp/oc-daemon.sock => /tmp/oc-daemon.sock
diff --git a/REFLECTION b/REFLECTION
index 5f8bb1b..627442d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,23 @@
-Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
+Extension [ <persistent> extension #119 opencensus version 0.3.0 ] {
+
+ - INI {
+ Entry [ opencensus.client.path <ALL> ]
+ Current = '/tmp/oc-daemon.sock'
+ }
+ }
- Functions {
Function [ <internal:opencensus> function opencensus_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:opencensus> function opencensus_core_send_to_daemonclient ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $msgType ]
+ Parameter #1 [ <required> string $msgData ]
+ }
}
Function [ <internal:opencensus> function opencensus_trace_function ] {
@@ -19,6 +35,9 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
}
}
Function [ <internal:opencensus> function opencensus_trace_list ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:opencensus> function opencensus_trace_begin ] {
@@ -28,8 +47,14 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
}
}
Function [ <internal:opencensus> function opencensus_trace_finish ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:opencensus> function opencensus_trace_clear ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:opencensus> function opencensus_trace_set_context ] {
@@ -39,6 +64,9 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
}
}
Function [ <internal:opencensus> function opencensus_trace_context ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:opencensus> function opencensus_trace_add_attribute ] {
@@ -108,39 +136,75 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
}
Method [ <internal:opencensus, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method name ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method spanId ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method parentSpanId ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method attributes ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method startTime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method endTime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method stackTrace ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method links ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method timeEvents ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method kind ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method sameProcessAsParentSpan ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -170,9 +234,15 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
}
Method [ <internal:opencensus> public method spanId ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method traceId ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -196,12 +266,21 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
- Methods [3] {
Method [ <internal:opencensus> public method description ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method time ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method options ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -225,12 +304,21 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
- Methods [3] {
Method [ <internal:opencensus> public method traceId ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method spanId ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method options ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -255,15 +343,27 @@ Extension [ <persistent> extension #196 opencensus version 0.2.2 ] {
- Methods [4] {
Method [ <internal:opencensus> public method type ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method id ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method time ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:opencensus> public method options ] {
+
+ - Parameters [0] {
+ }
}
}
}
diff --git a/php-pecl-opencensus.spec b/php-pecl-opencensus.spec
index cb7d914..4f1028e 100644
--- a/php-pecl-opencensus.spec
+++ b/php-pecl-opencensus.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-opencensus
#
-# Copyright (c) 2017-2019 Remi Collet
+# Copyright (c) 2017-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,19 +24,21 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 0.2.2
+%global upstream_version 0.3.0
#global upstream_prever RC2
Summary: A stats collection and distributed tracing framework
Name: %{?sub_prefix}php-pecl-opencensus
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+# upstream say 7.0 but https://github.com/census-instrumentation/opencensus-php/issues/274
+BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -52,32 +54,20 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{relea
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -122,6 +112,9 @@ cp -pr NTS ZTS
cat << 'EOF' | tee %{ini_name}
; Enable '%{pecl_name}' module
extension = %{pecl_name}.so
+
+; Configuration
+;opencensus.client.path = /tmp/oc-daemon.sock
EOF
@@ -170,8 +163,11 @@ done
%check
-cd NTS
+%if "%{php_version}" > "8.1"
+rm ?TS/tests/span_stacktrace_default.phpt
+%endif
+cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -181,9 +177,8 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || : ignore
+%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -197,9 +192,8 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
%endif
@@ -239,6 +233,13 @@ fi
%changelog
+* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+- report segfault with PHP 7.0
+ https://github.com/census-instrumentation/opencensus-php/issues/274
+- report 1 failed test with PHP 8.1.0alpha1
+ https://github.com/census-instrumentation/opencensus-php/issues/273
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.2.2-5
- rebuild for 7.4.0RC1