summaryrefslogtreecommitdiffstats
path: root/php-pecl-oci8.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-oci8.spec')
-rw-r--r--php-pecl-oci8.spec32
1 files changed, 20 insertions, 12 deletions
diff --git a/php-pecl-oci8.spec b/php-pecl-oci8.spec
index 3db52f4..8b6084d 100644
--- a/php-pecl-oci8.spec
+++ b/php-pecl-oci8.spec
@@ -16,10 +16,10 @@
%global _configure ../%{sources}/configure
%ifarch aarch64
-%global oraclever 19.23
+%global oraclever 19.24
%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.23
+%global oracledir 19.24
%else
%global oraclever 23.5
%global oraclemax 24
@@ -32,7 +32,7 @@
Summary: Extension for Oracle Database
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 3.4.0
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -40,13 +40,12 @@ Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?scl_prefix}php-devel >= 8.2
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
%if %{with_dtrace}
-BuildRequires: systemtap-sdt-devel
+BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
%ifarch aarch64
BuildRequires: oracle-instantclient%{oraclever}-devel
# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
@@ -56,6 +55,11 @@ AutoReq: 0
BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+# as we obsolete php-oci8 which provides both oci8 and pdo_oci extensions
+Recommends: %{?scl_prefix}php-pecl-pdo-oci
+
%if "%{php_version}" > "8.4"
Obsoletes: %{?scl_prefix}php-%{pecl_name} < 8.4
%else
@@ -184,15 +188,16 @@ peclconf() {
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
peclconf %{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
peclconf %{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -200,7 +205,7 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
@@ -208,7 +213,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Install the ZTS stuff
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -247,6 +252,9 @@ done
%changelog
+* Wed Sep 25 2024 Remi Collet <remi@remirepo.net> - 3.4.0-2
+- spec cleanup
+
* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0
- use oracle client library version 23.5 on x86_64, 19.23 on aarch64