summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION-PHP7451
-rw-r--r--php-pecl-oauth-php7.spec47
-rw-r--r--php-pecl-oauth.spec5
3 files changed, 469 insertions, 34 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..6ce38f9
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,451 @@
+Extension [ <persistent> extension #60 OAuth version 2.0.0 ] {
+
+ - Constants [32] {
+ Constant [ string OAUTH_SIG_METHOD_HMACSHA1 ] { HMAC-SHA1 }
+ Constant [ string OAUTH_SIG_METHOD_HMACSHA256 ] { HMAC-SHA256 }
+ Constant [ string OAUTH_SIG_METHOD_RSASHA1 ] { RSA-SHA1 }
+ Constant [ string OAUTH_SIG_METHOD_PLAINTEXT ] { PLAINTEXT }
+ Constant [ integer OAUTH_AUTH_TYPE_AUTHORIZATION ] { 3 }
+ Constant [ integer OAUTH_AUTH_TYPE_URI ] { 1 }
+ Constant [ integer OAUTH_AUTH_TYPE_FORM ] { 2 }
+ Constant [ integer OAUTH_AUTH_TYPE_NONE ] { 4 }
+ Constant [ string OAUTH_HTTP_METHOD_GET ] { GET }
+ Constant [ string OAUTH_HTTP_METHOD_POST ] { POST }
+ Constant [ string OAUTH_HTTP_METHOD_PUT ] { PUT }
+ Constant [ string OAUTH_HTTP_METHOD_HEAD ] { HEAD }
+ Constant [ string OAUTH_HTTP_METHOD_DELETE ] { DELETE }
+ Constant [ integer OAUTH_REQENGINE_STREAMS ] { 1 }
+ Constant [ integer OAUTH_REQENGINE_CURL ] { 2 }
+ Constant [ integer OAUTH_SSLCHECK_NONE ] { 0 }
+ Constant [ integer OAUTH_SSLCHECK_HOST ] { 1 }
+ Constant [ integer OAUTH_SSLCHECK_PEER ] { 2 }
+ Constant [ integer OAUTH_SSLCHECK_BOTH ] { 3 }
+ Constant [ integer OAUTH_OK ] { 0 }
+ Constant [ integer OAUTH_BAD_NONCE ] { 4 }
+ Constant [ integer OAUTH_BAD_TIMESTAMP ] { 8 }
+ Constant [ integer OAUTH_CONSUMER_KEY_UNKNOWN ] { 16 }
+ Constant [ integer OAUTH_CONSUMER_KEY_REFUSED ] { 32 }
+ Constant [ integer OAUTH_INVALID_SIGNATURE ] { 64 }
+ Constant [ integer OAUTH_TOKEN_USED ] { 128 }
+ Constant [ integer OAUTH_TOKEN_EXPIRED ] { 256 }
+ Constant [ integer OAUTH_TOKEN_REVOKED ] { 512 }
+ Constant [ integer OAUTH_TOKEN_REJECTED ] { 1024 }
+ Constant [ integer OAUTH_VERIFIER_INVALID ] { 2048 }
+ Constant [ integer OAUTH_PARAMETER_ABSENT ] { 4096 }
+ Constant [ integer OAUTH_SIGNATURE_METHOD_REJECTED ] { 8192 }
+ }
+
+ - Functions {
+ Function [ <internal:OAuth> function oauth_urlencode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $uri ]
+ }
+ }
+ Function [ <internal:OAuth> function oauth_get_sbs ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $http_method ]
+ Parameter #1 [ <required> $uri ]
+ Parameter #2 [ <required> $parameters ]
+ }
+ }
+ }
+
+ - Classes [3] {
+ Class [ <internal:OAuth> class OAuth ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $debug ]
+ Property [ <default> public $sslChecks ]
+ Property [ <default> public $debugInfo ]
+ }
+
+ - Methods [26] {
+ Method [ <internal:OAuth, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $consumer_key ]
+ Parameter #1 [ <required> $consumer_secret ]
+ Parameter #2 [ <optional> $signature_method ]
+ Parameter #3 [ <optional> $auth_type ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setRSACertificate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cert ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method getRequestToken ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $request_token_url ]
+ Parameter #1 [ <optional> $callback_url ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method getAccessToken ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $access_token_url ]
+ Parameter #1 [ <optional> $auth_session_handle ]
+ Parameter #2 [ <optional> $auth_verifier ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method getLastResponse ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method getLastResponseInfo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method getLastResponseHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method setToken ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $token ]
+ Parameter #1 [ <required> $token_secret ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setRequestEngine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $reqengine ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $version ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setAuthType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $auth_type ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setNonce ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $nonce ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setTimestamp ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $ts ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method fetch ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $protected_resource_url ]
+ Parameter #1 [ <optional> $extra_parameters ]
+ Parameter #2 [ <optional> $http_method ]
+ Parameter #3 [ <optional> $request_headers ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method enableDebug ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method disableDebug ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method enableSSLChecks ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method disableSSLChecks ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method enableRedirects ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method disableRedirects ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method setCAPath ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ca_path ]
+ Parameter #1 [ <required> $ca_info ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method getCAPath ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method generateSignature ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $http_method ]
+ Parameter #1 [ <required> $url ]
+ Parameter #2 [ <optional> $extra_parameters ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout_in_milliseconds ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method setSSLChecks ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sslcheck ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method getRequestHeader ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $http_method ]
+ Parameter #1 [ <required> $url ]
+ Parameter #2 [ <optional> $extra_parameters ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:OAuth> class OAuthException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [6] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> public $lastResponse ]
+ Property [ <default> public $debugInfo ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:OAuth> class OAuthProvider ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:OAuth> final static public method reportProblem ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $oauthexception ]
+ }
+ }
+
+ Method [ <internal:OAuth> final static public method generateToken ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $size ]
+ Parameter #1 [ <optional> $strong ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [14] {
+ Method [ <internal:OAuth, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $params_array ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method consumerHandler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $function_name ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method tokenHandler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $function_name ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method timestampNonceHandler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $function_name ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method callconsumerHandler ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method calltokenHandler ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method callTimestampNonceHandler ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:OAuth> public method checkOAuthRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $uri ]
+ Parameter #1 [ <optional> $method ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method isRequestTokenEndpoint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $params_array ]
+ }
+ }
+
+ Method [ <internal:OAuth> final public method setRequestTokenPath ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $path ]
+ }
+ }
+
+ Method [ <internal:OAuth> final public method addRequiredParameter ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $req_params ]
+ }
+ }
+
+ Method [ <internal:OAuth> final public method setParam ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $param_key ]
+ Parameter #1 [ <optional> $param_val ]
+ }
+ }
+
+ Method [ <internal:OAuth> final public method removeRequiredParameter ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $req_params ]
+ }
+ }
+
+ Method [ <internal:OAuth> public method is2LeggedEndpoint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $params_array ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-oauth-php7.spec b/php-pecl-oauth-php7.spec
index 960c463..ed4e8cb 100644
--- a/php-pecl-oauth-php7.spec
+++ b/php-pecl-oauth-php7.spec
@@ -8,42 +8,26 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
-%global sub_prefix %{scl_prefix}
-%endif
-%endif
%{?scl: %scl_package php-pecl-oauth}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name oauth
-%global with_zts 0%{?__ztsphp:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%endif
Name: %{?sub_prefix}php-pecl-oauth
-Version: 1.2.3
-Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP OAuth consumer extension
Group: Development/Languages
License: BSD
URL: http://pecl.php.net/package/oauth
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
-# curl instead of libcurl for old release
-BuildRequires: curl-devel
+BuildRequires: libcurl-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -60,14 +44,12 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -82,7 +64,7 @@ OAuth is an authorization protocol built on top of HTTP which allows
applications to securely access data without having to store
user names and passwords.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -90,6 +72,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_OAUTH_VERSION/{s/.* //;s/".*$//;p}' NTS/php_oauth.h)
if test "x${extver}" != "x%{version}"; then
@@ -123,8 +108,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make install -C NTS INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
@@ -145,10 +128,6 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%clean
-rm -rf %{buildroot}
-
-
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -182,7 +161,6 @@ fi
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -197,6 +175,9 @@ fi
%changelog
+* Sun Jan 3 2016 Remi Collet <rcollet@redhat.com> - 2.0.0-1
+- update to 2.0.0 (php 7, stable)
+
* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 1.2.3-10
- allow build against rh-php56 (as more-php56)
diff --git a/php-pecl-oauth.spec b/php-pecl-oauth.spec
index 960c463..3ce24eb 100644
--- a/php-pecl-oauth.spec
+++ b/php-pecl-oauth.spec
@@ -82,7 +82,7 @@ OAuth is an authorization protocol built on top of HTTP which allows
applications to securely access data without having to store
user names and passwords.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -90,6 +90,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_OAUTH_VERSION/{s/.* //;s/".*$//;p}' NTS/php_oauth.h)
if test "x${extver}" != "x%{version}"; then