summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
commitac2a2b571326ff3444709d4d741083fa5455cec2 (patch)
tree392eddeaef9a813e89b748759a11dca964e9ad58
repo reorg
-rw-r--r--Makefile4
-rw-r--r--php-pecl-oauth.spec160
2 files changed, 164 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/php-pecl-oauth.spec b/php-pecl-oauth.spec
new file mode 100644
index 0000000..665b0c5
--- /dev/null
+++ b/php-pecl-oauth.spec
@@ -0,0 +1,160 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+%{!?php_extdir: %{expand: %%global php_extdir %(php-config --extension-dir)}}
+
+%global pecl_name oauth
+
+Name: php-pecl-oauth
+Version: 1.2.2
+Release: 3%{?dist}
+Summary: PHP OAuth consumer extension
+Group: Development/Languages
+License: BSD
+URL: http://pecl.php.net/package/oauth
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRequires: php-devel
+BuildRequires: php-pear
+# curl instead of libcurl for old release
+BuildRequires: curl-devel
+BuildRequires: pcre-devel
+
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+
+Provides: php-pecl(%{pecl_name}) = %{version}
+
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+OAuth is an authorization protocol built on top of HTTP which allows
+applications to securely access data without having to store
+user names and passwords.
+
+%prep
+%setup -q -c
+
+cp -r %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+cat >%{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+make install -C %{pecl_name}-%{version} INSTALL_ROOT=%{buildroot}
+make install -C %{pecl_name}-%{version}-zts INSTALL_ROOT=%{buildroot}
+
+# Drop in the bit of configuration
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ]; then
+%{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+%{__php} -n \
+ -d extension_dir=%{pecl_name}-%{version}/modules \
+ -d extension=%{pecl_name}.so \
+ --modules | grep OAuth
+%{__ztsphp} -n \
+ -d extension_dir=%{pecl_name}-%{version}-zts/modules \
+ -d extension=%{pecl_name}.so \
+ --modules | grep OAuth
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_name}-%{version}/LICENSE %{pecl_name}-%{version}/examples
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+%{php_ztsextdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 1.2.2-3
+- build against php 5.4
+
+* Tue Oct 04 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.2.2-2
+- ZTS extension
+
+* Fri Jul 22 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.2.2-1
+- update to 1.2.2
+
+* Fri Jul 22 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.2.1-1
+- rebuild for remi repo
+
+* Fri Jul 22 2011 F. Kooman <fkooman@tuxed.net> - 1.2.1-1
+- update to 1.2.1 (RHBZ #724872). See
+ http://pecl.php.net/package-changelog.php?package=oauth&release=1.2.1
+
+* Mon Jul 04 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.2-1
+- rebuild for remi repo
+
+* Sun Jul 03 2011 F. Kooman <fkooman@tuxed.net> - 1.2-1
+- upgrade to 1.2
+
+* Sat Jun 25 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.1.0-6
+- rebuild for remi repo
+
+* Sun Jun 19 2011 F. Kooman <fkooman@tuxed.net> - 1.1.0-6
+- add fix for http://pecl.php.net/bugs/bug.php?id=22337
+
+* Wed Jun 14 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.1.0-5
+- rebuild for remi repo
+
+* Mon Jun 13 2011 F. Kooman <fkooman@tuxed.net> - 1.1.0-5
+- remove php_apiver marco, was not used
+
+* Mon Jun 13 2011 F. Kooman <fkooman@tuxed.net> - 1.1.0-4
+- add minimal check to see if module loads
+- fix private-shared-object-provides rpmlint warning
+
+* Sat Jun 11 2011 F. Kooman - 1.1.0-3
+- BR pcre-devel
+
+* Sat May 28 2011 F. Kooman - 1.1.0-2
+- require libcurl for cURL request engine support
+
+* Sat May 28 2011 F. Kooman - 1.1.0-1
+- initial package