summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-02 08:45:08 +0100
committerRemi Collet <remi@remirepo.net>2019-12-02 08:45:08 +0100
commit7be30b08a28c83a21fbdf8f04db38e5d7c4f8adc (patch)
treeec403bf79fe5294face56e658317dd48a6030c71
parent0545355faa240c36e70be6356ea072cb4f676b99 (diff)
v2.0.4
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION48
-rw-r--r--e27ff18ac768aae1cf955111179ec68307d37475.patch36
-rw-r--r--php-pecl-oauth.spec13
4 files changed, 31 insertions, 69 deletions
diff --git a/PHPINFO b/PHPINFO
index a9d7fae..4c7d228 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -6,5 +6,4 @@ PLAINTEXT support => enabled
RSA-SHA1 support => enabled
HMAC-SHA1 support => enabled
Request engine support => php_streams, curl
-source version => $Id$
-version => 2.0.3
+version => 2.0.4
diff --git a/REFLECTION b/REFLECTION
index de8dc29..ffac051 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,38 +1,38 @@
-Extension [ <persistent> extension #118 OAuth version 2.0.3 ] {
+Extension [ <persistent> extension #123 OAuth version 2.0.4 ] {
- Constants [32] {
Constant [ string OAUTH_SIG_METHOD_HMACSHA1 ] { HMAC-SHA1 }
Constant [ string OAUTH_SIG_METHOD_HMACSHA256 ] { HMAC-SHA256 }
Constant [ string OAUTH_SIG_METHOD_RSASHA1 ] { RSA-SHA1 }
Constant [ string OAUTH_SIG_METHOD_PLAINTEXT ] { PLAINTEXT }
- Constant [ integer OAUTH_AUTH_TYPE_AUTHORIZATION ] { 3 }
- Constant [ integer OAUTH_AUTH_TYPE_URI ] { 1 }
- Constant [ integer OAUTH_AUTH_TYPE_FORM ] { 2 }
- Constant [ integer OAUTH_AUTH_TYPE_NONE ] { 4 }
+ Constant [ int OAUTH_AUTH_TYPE_AUTHORIZATION ] { 3 }
+ Constant [ int OAUTH_AUTH_TYPE_URI ] { 1 }
+ Constant [ int OAUTH_AUTH_TYPE_FORM ] { 2 }
+ Constant [ int OAUTH_AUTH_TYPE_NONE ] { 4 }
Constant [ string OAUTH_HTTP_METHOD_GET ] { GET }
Constant [ string OAUTH_HTTP_METHOD_POST ] { POST }
Constant [ string OAUTH_HTTP_METHOD_PUT ] { PUT }
Constant [ string OAUTH_HTTP_METHOD_HEAD ] { HEAD }
Constant [ string OAUTH_HTTP_METHOD_DELETE ] { DELETE }
- Constant [ integer OAUTH_REQENGINE_STREAMS ] { 1 }
- Constant [ integer OAUTH_REQENGINE_CURL ] { 2 }
- Constant [ integer OAUTH_SSLCHECK_NONE ] { 0 }
- Constant [ integer OAUTH_SSLCHECK_HOST ] { 1 }
- Constant [ integer OAUTH_SSLCHECK_PEER ] { 2 }
- Constant [ integer OAUTH_SSLCHECK_BOTH ] { 3 }
- Constant [ integer OAUTH_OK ] { 0 }
- Constant [ integer OAUTH_BAD_NONCE ] { 4 }
- Constant [ integer OAUTH_BAD_TIMESTAMP ] { 8 }
- Constant [ integer OAUTH_CONSUMER_KEY_UNKNOWN ] { 16 }
- Constant [ integer OAUTH_CONSUMER_KEY_REFUSED ] { 32 }
- Constant [ integer OAUTH_INVALID_SIGNATURE ] { 64 }
- Constant [ integer OAUTH_TOKEN_USED ] { 128 }
- Constant [ integer OAUTH_TOKEN_EXPIRED ] { 256 }
- Constant [ integer OAUTH_TOKEN_REVOKED ] { 512 }
- Constant [ integer OAUTH_TOKEN_REJECTED ] { 1024 }
- Constant [ integer OAUTH_VERIFIER_INVALID ] { 2048 }
- Constant [ integer OAUTH_PARAMETER_ABSENT ] { 4096 }
- Constant [ integer OAUTH_SIGNATURE_METHOD_REJECTED ] { 8192 }
+ Constant [ int OAUTH_REQENGINE_STREAMS ] { 1 }
+ Constant [ int OAUTH_REQENGINE_CURL ] { 2 }
+ Constant [ int OAUTH_SSLCHECK_NONE ] { 0 }
+ Constant [ int OAUTH_SSLCHECK_HOST ] { 1 }
+ Constant [ int OAUTH_SSLCHECK_PEER ] { 2 }
+ Constant [ int OAUTH_SSLCHECK_BOTH ] { 3 }
+ Constant [ int OAUTH_OK ] { 0 }
+ Constant [ int OAUTH_BAD_NONCE ] { 4 }
+ Constant [ int OAUTH_BAD_TIMESTAMP ] { 8 }
+ Constant [ int OAUTH_CONSUMER_KEY_UNKNOWN ] { 16 }
+ Constant [ int OAUTH_CONSUMER_KEY_REFUSED ] { 32 }
+ Constant [ int OAUTH_INVALID_SIGNATURE ] { 64 }
+ Constant [ int OAUTH_TOKEN_USED ] { 128 }
+ Constant [ int OAUTH_TOKEN_EXPIRED ] { 256 }
+ Constant [ int OAUTH_TOKEN_REVOKED ] { 512 }
+ Constant [ int OAUTH_TOKEN_REJECTED ] { 1024 }
+ Constant [ int OAUTH_VERIFIER_INVALID ] { 2048 }
+ Constant [ int OAUTH_PARAMETER_ABSENT ] { 4096 }
+ Constant [ int OAUTH_SIGNATURE_METHOD_REJECTED ] { 8192 }
}
- Functions {
diff --git a/e27ff18ac768aae1cf955111179ec68307d37475.patch b/e27ff18ac768aae1cf955111179ec68307d37475.patch
deleted file mode 100644
index d64c262..0000000
--- a/e27ff18ac768aae1cf955111179ec68307d37475.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From e27ff18ac768aae1cf955111179ec68307d37475 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 23 May 2019 13:19:20 +0200
-Subject: [PATCH] fix php_pcre_match_impl call for 7.4
-
----
- provider.c | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/provider.c b/provider.c
-index 1543d25..e2cd075 100644
---- a/provider.c
-+++ b/provider.c
-@@ -205,6 +205,9 @@ static int oauth_provider_parse_auth_header(php_oauth_provider *sop, char *auth_
- zval subpats, return_value, *item_param, *current_param, *current_val;
- HashPosition hpos;
- zend_string *regex = zend_string_init(OAUTH_REGEX, sizeof(OAUTH_REGEX) - 1, 0);
-+#if PHP_VERSION_ID >= 70400
-+ zend_string *s_auth_header = zend_string_init(auth_header, strlen(auth_header), 0);
-+#endif
- size_t decoded_len;
-
- if(!auth_header || strncasecmp(auth_header, "oauth", 4) || !sop) {
-@@ -224,8 +227,12 @@ static int oauth_provider_parse_auth_header(php_oauth_provider *sop, char *auth_
-
- php_pcre_match_impl(
- pce,
-+#if PHP_VERSION_ID >= 70400
-+ s_auth_header,
-+#else
- auth_header,
- strlen(auth_header),
-+#endif
- &return_value,
- &subpats,
- 1, /* global */
diff --git a/php-pecl-oauth.spec b/php-pecl-oauth.spec
index c53574c..8d4849a 100644
--- a/php-pecl-oauth.spec
+++ b/php-pecl-oauth.spec
@@ -18,15 +18,13 @@
%global ini_name 40-%{pecl_name}.ini
Name: %{?sub_prefix}php-pecl-oauth
-Version: 2.0.3
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.4
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP OAuth consumer extension
License: BSD
URL: http://pecl.php.net/package/oauth
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://github.com/php/pecl-web_services-oauth/commit/e27ff18ac768aae1cf955111179ec68307d37475.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -98,9 +96,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-sed -e '/PHP_OAUTH_VERSION/s/2.0.3-dev/2.0.3/' -i php_oauth.h
-%patch0 -p1
-
+#sed -e '/PHP_OAUTH_VERSION/s/2.0.3-dev/2.0.3/' -i php_oauth.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_OAUTH_VERSION/{s/.* //;s/".*$//;p}' php_oauth.h)
if test "x${extver}" != "x%{version}"; then
@@ -208,6 +204,9 @@ fi
%changelog
+* Mon Dec 2 2019 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.0.3-6
- rebuild for 7.4.0RC1