summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-22 07:34:07 +0200
committerRemi Collet <remi@remirepo.net>2018-10-22 07:34:07 +0200
commitf45b41d4e8a9675576b5c0daa95fdc35d150215c (patch)
tree33aaa0126c4e1e25a5cb4e01da6ae94bd8146ba3
parent296f4f696e57d14771230c9545525eca3a2c5442 (diff)
v3.3.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION22
-rw-r--r--php-pecl-nsq.spec7
3 files changed, 18 insertions, 13 deletions
diff --git a/PHPINFO b/PHPINFO
index 6e0af48..6bf321f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
nsq
nsq support => enabled
-version => 3.1.0
+version => 3.3.0
author => zhenyu.wu[email:wuzhenyu@kuangjue.com]
diff --git a/REFLECTION b/REFLECTION
index a010297..8e600de 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 nsq version 3.1.0 ] {
+Extension [ <persistent> extension #117 nsq version 3.3.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #118 nsq version 3.1.0 ] {
Property [ <default> public $nsqd_connection_fds ]
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:nsq, ctor> public method __construct ] {
- Parameters [1] {
@@ -66,13 +66,6 @@ Extension [ <persistent> extension #118 nsq version 3.1.0 ] {
Parameter #1 [ <required> $callback ]
}
}
-
- Method [ <internal:nsq> public method requeue ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $delay_time ]
- }
- }
}
}
@@ -120,7 +113,7 @@ Extension [ <persistent> extension #118 nsq version 3.1.0 ] {
Property [ <default> public $payload ]
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:nsq> public method touch ] {
- Parameters [2] {
@@ -129,6 +122,15 @@ Extension [ <persistent> extension #118 nsq version 3.1.0 ] {
}
}
+ Method [ <internal:nsq> public method requeue ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $bev_zval ]
+ Parameter #1 [ <required> $message_id ]
+ Parameter #2 [ <required> $time_ms ]
+ }
+ }
+
Method [ <internal:nsq> public method finish ] {
- Parameters [2] {
diff --git a/php-pecl-nsq.spec b/php-pecl-nsq.spec
index 30db5d2..1771c96 100644
--- a/php-pecl-nsq.spec
+++ b/php-pecl-nsq.spec
@@ -23,8 +23,8 @@
Summary: PHP extension for NSQ client
Name: %{?sub_prefix}php-pecl-nsq
-Version: 3.1.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.3.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
License: PHP
URL: http://pecl.php.net/package/nsq
@@ -224,6 +224,9 @@ fi
%changelog
+* Mon Oct 22 2018 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 3.1.0-3
- rebuild for 7.3.0beta2 new ABI