summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-20 07:24:20 +0100
committerRemi Collet <remi@php.net>2025-02-20 07:24:20 +0100
commit703d9357731deccc8c2d987029c587fd78c6f8ae (patch)
tree1c553e157eeeee723e920211979b92709ee79147
parent7e314bb5ae2c94a3372037f84a7ac23498be274d (diff)
fix lookup function prototype using patch from
https://github.com/yunnian/php-nsq/pull/76 re-license spec file to CECILL-2.1
-rw-r--r--php-pecl-nsq.spec47
1 files changed, 16 insertions, 31 deletions
diff --git a/php-pecl-nsq.spec b/php-pecl-nsq.spec
index 4424842..044cade 100644
--- a/php-pecl-nsq.spec
+++ b/php-pecl-nsq.spec
@@ -1,17 +1,13 @@
# remirepo spec file for php-pecl-nsq
#
-# Copyright (c) 2018-2023 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2018-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-nsq
%else
%global _root_prefix %{_prefix}
@@ -26,14 +22,16 @@
Summary: PHP extension for NSQ client
Name: %{?scl_prefix}php-pecl-nsq
Version: 3.5.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: https://pecl.php.net/get/%{sources}%{?prever}.tgz
License: PHP-3.01
URL: https://pecl.php.net/package/nsq
+Patch0: 0001-fix-prototype.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pkgconfig(libevent) >= 2
@@ -59,10 +57,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
+%patch -P0 -p1 -b .proto
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_NSQ_VERSION/{s/.* "//;s/".*$//;p}' php_nsq.h )
if test "x${extver}" != "x%{version}"; then
@@ -160,28 +160,8 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -195,6 +175,11 @@ fi
%changelog
+* Thu Feb 20 2025 Remi Collet <remi@remirepo.net> - 3.5.1-3
+- fix lookup function prototype using patch from
+ https://github.com/yunnian/php-nsq/pull/76
+- re-license spec file to CECILL-2.1
+
* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 3.5.1-2
- build out of sources tree