summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 14:10:03 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 14:10:03 +0200
commit668b1a4a9676eb157a1ffaa568ef74c6ef942e9d (patch)
tree2ac588c4d461ce8f5637d5c0a94ed50b372e51d8
parentb5c474d9fd0940e51188d72bc9033fabce971070 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-mysqlnd-ms-dev.spec22
1 files changed, 16 insertions, 6 deletions
diff --git a/php-pecl-mysqlnd-ms-dev.spec b/php-pecl-mysqlnd-ms-dev.spec
index c0cba67..646c01b 100644
--- a/php-pecl-mysqlnd-ms-dev.spec
+++ b/php-pecl-mysqlnd-ms-dev.spec
@@ -16,11 +16,18 @@
%global with_zts 0%{?__ztsphp:1}
%global versufix -alpha
%global svnrev 333055
+%if "%{php_version}" < "5.6"
+# After json, mysqlnd
+%global ini_name %{pecl_name}.ini
+%else
+# After 40-json, 20-mysqlnd
+%global ini_name 50-%{pecl_name}.ini
+%endif
Summary: A replication and load balancing plugin for mysqlnd
Name: %{?scl_prefix}php-pecl-mysqlnd-ms
Version: 1.6.0
-Release: 1.svn%{svnrev}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2.svn%{svnrev}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -104,7 +111,7 @@ These are the files needed to compile programs using mysqlnd_ms extension.
%prep
%setup -c -q
-cp %{SOURCE1} %{pecl_name}.ini
+cp %{SOURCE1} %{ini_name}
mv %{pecl_name}-%{version} NTS
@@ -154,14 +161,14 @@ rm -rf %{buildroot}
make install -C NTS INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make install -C ZTS INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -213,11 +220,11 @@ cd ../ZTS
#exclude %{pecl_docdir}/%{pecl_name}/examples
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
@@ -234,6 +241,9 @@ cd ../ZTS
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.6.0-2.svn333055
+- add numerical prefix to extension configuration file
+
* Sat Mar 22 2014 Remi Collet <remi@fedoraproject.org> - 1.6.0-1.svn333055
- Update to 1.6.0 (alpha) svn snapshot for php 5.6