summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-17 11:08:20 +0200
committerRemi Collet <remi@remirepo.net>2019-10-17 11:08:20 +0200
commit776b155fd7a9d3da0d8b5a61e84481deca12cf40 (patch)
treea8cdad02c1d2f5c36bb982981fba8c79017c38f1
New package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-mysqlnd-azure.spec274
5 files changed, 303 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..b06acdc
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+mysqlnd_azure
+
+mysqlnd_azure => enabled
+enabled => No
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..513600d
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,13 @@
+Extension [ <persistent> extension #124 mysqlnd_azure version 1.0.0 ] {
+
+ - Dependencies {
+ Dependency [ mysqlnd (Required) ]
+ }
+
+ - INI {
+ Entry [ mysqlnd_azure.enabled <ALL> ]
+ Current = '0'
+ }
+ }
+}
+
diff --git a/php-pecl-mysqlnd-azure.spec b/php-pecl-mysqlnd-azure.spec
new file mode 100644
index 0000000..544c75d
--- /dev/null
+++ b/php-pecl-mysqlnd-azure.spec
@@ -0,0 +1,274 @@
+# remirepo spec file for php-pecl-mysqlnd-azure
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-mysqlnd-azure
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name mysqlnd_azure
+# Need work to find how to run upstream test suite
+%global with_tests 0%{?_with_tests:1}
+# After 20-json, 20-mysqlnd
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Redirection plugin for mysqlnd
+Name: %{?sub_prefix}php-pecl-mysqlnd-azure
+Version: 1.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: PHP
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7.2.15
+BuildRequires: %{?scl_prefix}php-mysqlnd
+BuildRequires: %{?scl_prefix}php-pear
+%if %{with_tests}
+BuildRequires: %{?scl_prefix}php-mysqli
+BuildRequires: %{?scl_prefix}php-openssl
+BuildRequires: mariadb-server
+%endif
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Notice pecl_name != name
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared object
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+A PHP extension implemented using mysqlnd plugin API which provides
+redirection feature support.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{pecl_name} NTS
+rm -r NTS/.git
+chmod -x NTS/*.{c,h,txt,md}
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+
+# Check version as upstream often forget to update this
+extver=$(sed -n '/#define EXT_MYSQLND_AZURE_VERSION/{s/.* "//;s/".*$//;p}' php_mysqlnd_azure.h)
+if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
+ : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;mysqlnd_azure.enabled = 0
+EOF
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --enable-mysqlnd_azure\
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=mysqlnd.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=mysqlnd.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%endif
+
+%if %{with_tests}
+cd NTS
+RET=0
+
+: Running a server
+MYSQL_TEST_HOST=127.0.0.1
+MYSQL_TEST_PORT=3308
+MYSQL_TEST_SOCKET=$PWD/mysql.sock
+MYSQL_PID_FILE=$PWD/mysql.pid
+
+: Create the Database
+rm -rf data
+mkdir data
+%{_bindir}/mysql_install_db \
+ --force \
+ --log-error=$PWD/mysql.log \
+ --datadir=$PWD/data
+
+: Launch the Server
+%{_libexecdir}/mysqld \
+ --socket=$MYSQL_TEST_SOCKET \
+ --log-error=$PWD/mysql.log \
+ --pid-file=$MYSQL_PID_FILE \
+ --port=$MYSQL_TEST_PORT \
+ --datadir=$PWD/data &
+n=15
+while [ $n -gt 0 ]; do
+ RESPONSE=$(%{_bindir}/mysqladmin --no-defaults --socket="$MYSQL_TEST_SOCKET" --user=root ping 2>&1 || :)
+ if [ "$RESPONSE" == "mysqld is alive" ]; then
+ break
+ fi
+ n=$(expr $n - 1)
+ sleep 1
+done
+
+: Run upstream test suite
+export MYSQL_TEST_HOST
+export MYSQL_TEST_PORT
+
+if [ $n -gt 0 ]; then
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=mysqlnd.so -d extension=mysqli.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff || RET=1
+fi
+
+: Cleanup
+if [ -s $MYSQL_PID_FILE ]; then
+ kill $(cat $MYSQL_PID_FILE)
+fi
+
+exit $RET
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE.txt}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0 (stable)