summaryrefslogtreecommitdiffstats
path: root/php-pecl-mysql.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-18 07:20:32 +0200
committerRemi Collet <remi@remirepo.net>2018-07-18 07:20:32 +0200
commit871ae3ccb491a9104b3e30d11c9fc2915c3eed87 (patch)
treed5e3f81c2d1c5490cc74a215f0862ecbcb096dd7 /php-pecl-mysql.spec
parenta33012cc0f37aecbb96acd00d06a418fd0d3895a (diff)
rebuild for 7.3.0alpha4 new ABI
Diffstat (limited to 'php-pecl-mysql.spec')
-rw-r--r--php-pecl-mysql.spec41
1 files changed, 31 insertions, 10 deletions
diff --git a/php-pecl-mysql.spec b/php-pecl-mysql.spec
index b072de0..69ad61a 100644
--- a/php-pecl-mysql.spec
+++ b/php-pecl-mysql.spec
@@ -1,22 +1,29 @@
# remirepo spec file for php-pecl-mysql
#
-# Copyright (c) 2013-2017 Remi Collet
+# Copyright (c) 2013-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-mysql
+%else
+%global _root_bindir %{_bindir}
+%global _root_libexecdir %{_libexecdir}
%endif
# https://github.com/php/pecl-database-mysql/commits/master
-%global gh_commit 230a8287c04c69dfc49f6a68a5debb4e4198e98f
+%global gh_commit 647c933b6cc8f3e6ce8a466824c79143a98ee151
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php
%global gh_project pecl-database-mysql
-%global gh_date 20160812
+%global gh_date 20180226
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql
%global with_tests 0%{?_with_tests:1}
@@ -28,17 +35,17 @@ Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
%if 0%{?gh_date:1}
-Release: 0.17.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.19.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: PHP
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
Source1: %{pecl_name}.ini
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: %{?scl_prefix}php-pear
@@ -73,6 +80,10 @@ Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -127,6 +138,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
peclconf() {
%configure \
--with-mysql=mysqlnd \
@@ -148,6 +161,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{ini_name}
@@ -199,10 +214,10 @@ MYSQL_PID_FILE=$PWD/mysql.pid
rm -rf data
mkdir data
-%{_bindir}/mysql_install_db \
+%{_root_bindir}/mysql_install_db \
--datadir=$PWD/data
-%{_libexecdir}/mysqld \
+%{_root_libexecdir}/mysqld \
--socket=$MYSQL_TEST_SOCKET \
--log-error=$PWD/mysql.log \
--pid-file=$MYSQL_PID_FILE \
@@ -211,7 +226,7 @@ mkdir data
n=15
while [ $n -gt 0 ]; do
- RESPONSE=$(%{_bindir}/mysqladmin --no-defaults --socket="$MYSQL_TEST_SOCKET" --user=root ping 2>&1 || :)
+ RESPONSE=$(%{_root_bindir}/mysqladmin --no-defaults --socket="$MYSQL_TEST_SOCKET" --user=root ping 2>&1 || :)
if [ "$RESPONSE" == "mysqld is alive" ]; then
break
fi
@@ -244,7 +259,7 @@ exit $RET
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -279,6 +294,12 @@ fi
%changelog
+* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 1.0.0-0.19.20180226.647c933
+- rebuild for 7.3.0alpha4 new ABI
+
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.0.0-0.18.20180226.647c933
+- refresh to more recent snapshot for 7.3
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.0.0-0.17.20160812git230a828
- rebuild for PHP 7.2.0beta1 new API