summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-10 18:46:45 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-10 18:46:45 +0100
commitb6aa45e561898a5f5c80cd44663f7f20062438b1 (patch)
tree227ae3300090e73a3d6997f58f95eb262f2b0f4a
parent61c4e151f80f78599dde6b1b3c0a4009983205ae (diff)
php-pecl-mysql: set stability = devel in package.xml
-rw-r--r--php-pecl-mysql.spec16
1 files changed, 13 insertions, 3 deletions
diff --git a/php-pecl-mysql.spec b/php-pecl-mysql.spec
index 0c7dd53..1d24eef 100644
--- a/php-pecl-mysql.spec
+++ b/php-pecl-mysql.spec
@@ -15,12 +15,13 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
+# https://github.com/php/pecl-database-mysql/commits/master
%global gh_commit 294ce3b491ffb5ab2556b9f64ef6fb608d32e5c7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php
%global gh_project pecl-database-mysql
%global gh_date 20151007
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql
%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
# After 40-mysqlnd
@@ -31,7 +32,7 @@ Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
%if 0%{?gh_date:1}
-Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -85,7 +86,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
+%{__php} -r '
+ $pkg = simplexml_load_file("NTS/package.xml");
+ $pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
+ $pkg->version->release = "%{version}dev";
+ $pkg->stability->release = "devel";
+ $pkg->asXML("package.xml");
+'
# Don't install (register) the tests
sed -e 's/role="test"/role="src"/' -i package.xml
@@ -207,6 +214,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Jan 10 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.8.20150628git3c79a97
+- set stability=devel in package.xml
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.7.20151007git294ce3b
- rebuild for PHP 7.0.0RC5 new API version
- new snapshot