summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-21 09:42:00 +0200
committerRemi Collet <remi@remirepo.net>2021-04-21 09:42:00 +0200
commitae55f2238f3adb0ad6d83f66aa9290b85ef16627 (patch)
tree8c26a347c28ac2acbe827905d50dbb84db08dd7d
parent85019d3cab164021843b668babe775ae2050866e (diff)
refresh to more recent snapshot for PHP 8
-rw-r--r--.gitignore2
-rw-r--r--php-pecl-mysql.spec48
2 files changed, 19 insertions, 31 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/php-pecl-mysql.spec b/php-pecl-mysql.spec
index 453a6aa..f44133a 100644
--- a/php-pecl-mysql.spec
+++ b/php-pecl-mysql.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mysql
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,7 +11,6 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-mysql
%else
%global _root_bindir %{_bindir}
@@ -19,11 +18,11 @@
%endif
# https://github.com/php/pecl-database-mysql/commits/master
-%global gh_commit d7643af829314142e1edf07fb36c7ab0515f8bd5
+%global gh_commit 6ca4fa4b509819ecc4c8ff2b28080d60ad64acc6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php
%global gh_project pecl-database-mysql
-%global gh_date 20190415
+%global gh_date 20201210
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql
%global with_tests 0%{?_with_tests:1}
@@ -32,21 +31,22 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
Summary: MySQL database access functions
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
%if 0%{?gh_date:1}
-Release: 0.23.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.24.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
+URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
Source1: %{pecl_name}.ini
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: %{?scl_prefix}php-pear
%if %{with_tests}
@@ -63,44 +63,27 @@ Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
%description
This extension provides the mysql family of functions that were provided
-with PHP 3-5. These functions have been superseded by MySQLi and PDO_MySQL,
-which continue to be bundled with PHP 7.
+with PHP 3 to 5. These functions have been superseded by MySQLi and PDO_MySQL,
+which continue to be bundled with PHP 7 and newer.
-Although it should be possible to use this extension with PHP 7.0, you are
+Although it should be possible to use this extension with PHP 7 or 8, you are
strongly encouraged to port your code to use either MySQLi or PDO_MySQL,
as this extension is not maintained and is available for historical reasons only.
@@ -296,6 +279,9 @@ fi
%changelog
+* Wed Apr 21 2021 Remi Collet <remi@remirepo.net> - 1.0.0-0.24.20201210.6ca4fa4
+- refresh to more recent snapshot for PHP 8
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.0.0-0.23.20190415.d7643af
- rebuild for 7.4.0RC1