summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION87
-rw-r--r--php-pecl-mysql-xdevapi.spec7
3 files changed, 19 insertions, 77 deletions
diff --git a/PHPINFO b/PHPINFO
index 11adb75..ac04b7a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.13
+Version => mysql_xdevapi 8.0.14
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index 97bb717..481e43e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
+Extension [ <persistent> extension #122 mysql_xdevapi version 8.0.14 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -91,7 +91,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- - Classes [51] {
+ - Classes [50] {
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -417,43 +417,10 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\FieldMetadata ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [13] {
- Property [ <default> public $type ]
- Property [ <default> public $type_name ]
- Property [ <default> public $name ]
- Property [ <default> public $original_name ]
- Property [ <default> public $table ]
- Property [ <default> public $original_table ]
- Property [ <default> public $schema ]
- Property [ <default> public $catalog ]
- Property [ <default> public $collation ]
- Property [ <default> public $fractional_digits ]
- Property [ <default> public $length ]
- Property [ <default> public $flags ]
- Property [ <default> public $content_type ]
- }
-
- - Methods [1] {
- Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
- }
- }
- }
-
Class [ <internal:mysql_xdevapi> final class mysql_xdevapi\Driver ] {
- Constants [1] {
- Constant [ public string version ] { 8.0.13 }
+ Constant [ public string version ] { 8.0.14 }
}
- Static properties [0] {
@@ -505,18 +472,10 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
- Properties [0] {
}
- - Methods [20] {
+ - Methods [17] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
- Method [ <internal:mysql_xdevapi> public method executeSql ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $query ]
- Parameter #1 [ <optional> ...$args ]
- }
- }
-
Method [ <internal:mysql_xdevapi> public method sql ] {
- Parameters [1] {
@@ -537,12 +496,6 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method getClientId ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:mysql_xdevapi> public method generateUUID ] {
- Parameters [0] {
@@ -569,6 +522,12 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
+ Method [ <internal:mysql_xdevapi> public method getDefaultSchema ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mysql_xdevapi> public method getSchema ] {
- Parameters [1] {
@@ -615,19 +574,6 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method listClients ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method killClient ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> integer $client_id ]
- }
- }
-
Method [ <internal:mysql_xdevapi> public method close ] {
- Parameters [0] {
@@ -1408,7 +1354,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method getColumnCount ] {
+ Method [ <internal:mysql_xdevapi> public method getColumnsCount ] {
- Parameters [0] {
}
@@ -1494,7 +1440,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method getColumnCount ] {
+ Method [ <internal:mysql_xdevapi> public method getColumnsCount ] {
- Parameters [0] {
}
@@ -1709,7 +1655,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -1734,13 +1680,6 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method offset ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> integer $position ]
- }
- }
-
Method [ <internal:mysql_xdevapi> public method bind ] {
- Parameters [1] {
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 334a831..45d95e6 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mysql-xdevapi
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,7 +24,7 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.13
+Version: 8.0.14
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
@@ -312,6 +312,9 @@ fi
%changelog
+* Wed Jan 23 2019 Remi Collet <remi@remirepo.net> - 8.0.14-1
+- update to 8.0.14
+
* Mon Oct 22 2018 Remi Collet <remi@remirepo.net> - 8.0.13-1
- update to 8.0.13