summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION632
-rw-r--r--php-pecl-mysql-xdevapi.spec50
3 files changed, 548 insertions, 141 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index 36e6ae9..ca1b1c5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
+Extension [ <persistent> extension #72 mysql_xdevapi version 8.0.2 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -34,25 +34,23 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Functions {
Function [ <internal:mysql_xdevapi> function mysql_xdevapi\getSession ] {
- - Parameters [1] {
- Parameter #0 [ <required> string $uri_string ]
+ - Parameters [0] {
}
}
- Function [ <internal:mysql_xdevapi> function mysql_xdevapi\getNodeSession ] {
+ Function [ <internal:mysql_xdevapi> function mysql_xdevapi\expression ] {
- Parameters [1] {
- Parameter #0 [ <required> string $uri_string ]
+ Parameter #0 [ <required> string $expression ]
}
}
- Function [ <internal:mysql_xdevapi> function mysql_xdevapi\expression ] {
+ Function [ <internal:mysql_xdevapi> function mysql_xdevapi\sessions ] {
- - Parameters [1] {
- Parameter #0 [ <required> string $expression ]
+ - Parameters [0] {
}
}
}
- - Classes [41] {
+ - Classes [46] {
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -461,7 +459,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
Class [ <internal:mysql_xdevapi> final class mysql_xdevapi\Driver ] {
- Constants [1] {
- Constant [ public string version ] { 1.0.1 }
+ Constant [ public string version ] { 8.0.2 }
}
- Static properties [0] {
@@ -493,7 +491,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [15] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -546,22 +544,6 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method dropCollection ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $collection_name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method dropTable ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $table_name ]
- }
- }
-
Method [ <internal:mysql_xdevapi> public method startTransaction ] {
- Parameters [0] {
@@ -615,7 +597,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [15] {
Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\BaseSession, ctor> private method __construct ] {
}
@@ -668,22 +650,6 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method dropCollection ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $collection_name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method dropTable ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $table_name ]
- }
- }
-
Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method startTransaction ] {
- Parameters [0] {
@@ -737,7 +703,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Properties [0] {
}
- - Methods [19] {
+ - Methods [17] {
Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\BaseSession, ctor> private method __construct ] {
}
@@ -800,22 +766,6 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method dropCollection ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $collection_name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method dropTable ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $table_name ]
- }
- }
-
Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method startTransaction ] {
- Parameters [0] {
@@ -870,7 +820,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
Property [ <default> public $name ]
}
- - Methods [14] {
+ - Methods [16] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -892,16 +842,18 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method drop ] {
+ Method [ <internal:mysql_xdevapi> public method createCollection ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
}
}
- Method [ <internal:mysql_xdevapi> public method createCollection ] {
+ Method [ <internal:mysql_xdevapi> public method dropCollection ] {
- - Parameters [1] {
- Parameter #0 [ <required> string $name ]
+ - Parameters [2] {
+ Parameter #0 [ <required> string $schema_name ]
+ Parameter #1 [ <required> string $collection_name ]
}
}
@@ -918,6 +870,22 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
+ Method [ <internal:mysql_xdevapi> public method createTable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $table_name ]
+ Parameter #1 [ <optional> integer $replace_existing ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method dropTable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $schema_name ]
+ Parameter #1 [ <required> string $table_name ]
+ }
+ }
+
Method [ <internal:mysql_xdevapi> public method getTable ] {
- Parameters [1] {
@@ -941,7 +909,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Parameters [2] {
Parameter #0 [ <required> string $view_name ]
- Parameter #1 [ <required> integer $replace_existing ]
+ Parameter #1 [ <optional> integer $replace_existing ]
}
}
@@ -1116,32 +1084,6 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionDropIndex implements mysql_xdevapi\Executable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionFind implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSkippable, mysql_xdevapi\CrudOperationSortable ] {
- Constants [0] {
@@ -1371,7 +1313,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ViewCreate implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\TableCreate implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -1385,49 +1327,93 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [15] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
- Method [ <internal:mysql_xdevapi> public method definer ] {
+ Method [ <internal:mysql_xdevapi> public method addColumn ] {
- Parameters [1] {
- Parameter #0 [ <required> string $definer ]
+ Parameter #0 [ <required> object $column ]
}
}
- Method [ <internal:mysql_xdevapi> public method algorithm ] {
+ Method [ <internal:mysql_xdevapi> public method addPrimaryKey ] {
- Parameters [1] {
- Parameter #0 [ <required> string $algorithm ]
+ Parameter #0 [ <required> $primary_key ]
}
}
- Method [ <internal:mysql_xdevapi> public method security ] {
+ Method [ <internal:mysql_xdevapi> public method addIndex ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <optional> $columns ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method addUniqueIndex ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <optional> $columns ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method addForeignKey ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $table_name ]
+ Parameter #1 [ <required> object $fields ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method setInitialAutoIncrement ] {
- Parameters [1] {
- Parameter #0 [ <required> string $security ]
+ Parameter #0 [ <required> integer $init_auto_increment ]
}
}
- Method [ <internal:mysql_xdevapi> public method withCheckOption ] {
+ Method [ <internal:mysql_xdevapi> public method setDefaultCharset ] {
- Parameters [1] {
- Parameter #0 [ <required> string $check_option ]
+ Parameter #0 [ <required> string $default_charset ]
}
}
- Method [ <internal:mysql_xdevapi> public method columns ] {
+ Method [ <internal:mysql_xdevapi> public method setDefaultCollation ] {
- Parameters [1] {
- Parameter #0 [ <required> $columns ]
+ Parameter #0 [ <required> string $default_collation ]
}
}
- Method [ <internal:mysql_xdevapi> public method definedAs ] {
+ Method [ <internal:mysql_xdevapi> public method setComment ] {
- Parameters [1] {
- Parameter #0 [ <required> object $defined_as ]
+ Parameter #0 [ <required> string $comment ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method temporary ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method as ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $defined_as ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method like ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $template_table_name ]
}
}
@@ -1436,10 +1422,282 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mysql_xdevapi> public method getSqlQuery ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ViewAlter implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ColumnDefBase ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mysql_xdevapi, ctor> protected method __construct ] {
+ }
+
+ Method [ <internal:mysql_xdevapi> public method notNull ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method uniqueIndex ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method primaryKey ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method comment ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $comment ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ColumnDef extends mysql_xdevapi\ColumnDefBase ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\ColumnDefBase, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $type ]
+ Parameter #2 [ <optional> integer $length ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method setDefault ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $default_value_expr ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method defaultCurrentTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method autoIncrement ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method foreignKey ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $table_name ]
+ Parameter #1 [ <required> $fields ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method unsigned ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method decimals ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $decimals_size ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method charset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $charset ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method collation ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $collation ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method binary ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method values ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $values ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method notNull ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method uniqueIndex ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method primaryKey ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method comment ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $comment ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\GeneratedColumnDef extends mysql_xdevapi\ColumnDefBase ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\ColumnDefBase, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:mysql_xdevapi> public method stored ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method notNull ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method uniqueIndex ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method primaryKey ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\ColumnDefBase> public method comment ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $comment ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ForeignKeyDef ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mysql_xdevapi, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method fields ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fields ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method refersTo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $refers_to_table ]
+ Parameter #1 [ <required> $refers_to_columns ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method onDelete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $on_delete_mode ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method onUpdate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $on_update_mode ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ViewCreate implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -1507,7 +1765,7 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ViewDrop implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ViewAlter implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -1521,14 +1779,49 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [8] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
- Method [ <internal:mysql_xdevapi> public method ifExists ] {
+ Method [ <internal:mysql_xdevapi> public method definer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $definer ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method algorithm ] {
- Parameters [1] {
- Parameter #0 [ <required> boolean $if_exists ]
+ Parameter #0 [ <required> string $algorithm ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method security ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $security ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method withCheckOption ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $check_option ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method columns ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $columns ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method definedAs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object $defined_as ]
}
}
@@ -2317,6 +2610,119 @@ Extension [ <persistent> extension #61 mysql_xdevapi version 1.0.1 ] {
}
}
}
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\SessionConfigManager ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method save ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $input ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method list ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\SessionConfig ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method getName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method getUri ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method setUri ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method setAppData ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $value ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method getAppData ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method deleteAppData ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 1b9a35b..6d49474 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -13,13 +13,14 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql_xdevapi
+# https://bugzilla.redhat.com/show_bug.cgi?id=1470164
%global with_tests 0%{?_with_tests:1}
# After 20-json, 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 1.0.1
+Version: 8.0.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
@@ -56,10 +57,17 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+# Removed
+Obsoletes: %{name}-devel < 8.0.2
+
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -95,21 +103,14 @@ data.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-%package devel
-Summary: %{name} developer files (header)
-Group: Development/Libraries
-Requires: %{name}%{?_isa} = %{version}-%{release}
-Requires: %{?scl_prefix}php-devel%{?_isa}
-
-%description devel
-These are the files needed to compile programs using %{name}.
-
-
%prep
%setup -qc
mv %{pecl_name}-%{version} NTS
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
%patch0 -p1 -b .old
@@ -181,10 +182,7 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
-for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
+# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -224,8 +222,9 @@ MYSQLX_PID_FILE=$PWD/mysql.pid
rm -rf data
mkdir data
-%{_bindir}/mysql_install_db \
- --datadir=$PWD/data
+%{_libexecdir}/mysqld \
+ --datadir=$PWD/data \
+ --initialize
%{_libexecdir}/mysqld \
--socket=$MYSQLX_TEST_SOCKET \
@@ -298,18 +297,13 @@ fi
%endif
-%files devel
-%doc %{pecl_testdir}/%{pecl_name}
-%{php_incldir}/ext/%{pecl_name}
-
-%if %{with_zts}
-%{php_ztsincldir}/ext/%{pecl_name}
-%endif
-
-
%changelog
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 8.0.2-1
+- Update to 8.0.2 (alpha)
+- drop devel sub-package
+
* Tue Mar 14 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
-- Update to 1.0.1
+- Update to 1.0.1 (alpha)
* Thu Dec 8 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package, version 1.0.0 (alpha)