summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION124
-rw-r--r--php-pecl-mysql-xdevapi.spec11
3 files changed, 70 insertions, 67 deletions
diff --git a/PHPINFO b/PHPINFO
index 9b55e73..1c82481 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.18
+Version => mysql_xdevapi 8.0.19
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index e996921..fcba992 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
+Extension [ <persistent> extension #83 mysql_xdevapi version 8.0.19 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -29,46 +29,46 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
}
- Constants [40] {
- Constant [ string MYSQLX_VERSION ] { 8.0.18 }
- Constant [ integer MYSQLX_VERSION_ID ] { 80018 }
- Constant [ integer MYSQLX_CLIENT_SSL ] { 2048 }
- Constant [ integer MYSQLX_TYPE_DECIMAL ] { 0 }
- Constant [ integer MYSQLX_TYPE_TINY ] { 1 }
- Constant [ integer MYSQLX_TYPE_SHORT ] { 2 }
- Constant [ integer MYSQLX_TYPE_SMALLINT ] { 17 }
- Constant [ integer MYSQLX_TYPE_MEDIUMINT ] { 18 }
- Constant [ integer MYSQLX_TYPE_INT ] { 19 }
- Constant [ integer MYSQLX_TYPE_BIGINT ] { 20 }
- Constant [ integer MYSQLX_TYPE_LONG ] { 3 }
- Constant [ integer MYSQLX_TYPE_FLOAT ] { 4 }
- Constant [ integer MYSQLX_TYPE_DOUBLE ] { 5 }
- Constant [ integer MYSQLX_TYPE_NULL ] { 6 }
- Constant [ integer MYSQLX_TYPE_TIMESTAMP ] { 7 }
- Constant [ integer MYSQLX_TYPE_LONGLONG ] { 8 }
- Constant [ integer MYSQLX_TYPE_INT24 ] { 9 }
- Constant [ integer MYSQLX_TYPE_DATE ] { 10 }
- Constant [ integer MYSQLX_TYPE_TIME ] { 11 }
- Constant [ integer MYSQLX_TYPE_DATETIME ] { 12 }
- Constant [ integer MYSQLX_TYPE_YEAR ] { 13 }
- Constant [ integer MYSQLX_TYPE_NEWDATE ] { 14 }
- Constant [ integer MYSQLX_TYPE_ENUM ] { 247 }
- Constant [ integer MYSQLX_TYPE_SET ] { 248 }
- Constant [ integer MYSQLX_TYPE_TINY_BLOB ] { 249 }
- Constant [ integer MYSQLX_TYPE_MEDIUM_BLOB ] { 250 }
- Constant [ integer MYSQLX_TYPE_LONG_BLOB ] { 251 }
- Constant [ integer MYSQLX_TYPE_BLOB ] { 252 }
- Constant [ integer MYSQLX_TYPE_VAR_STRING ] { 253 }
- Constant [ integer MYSQLX_TYPE_STRING ] { 254 }
- Constant [ integer MYSQLX_TYPE_CHAR ] { 1 }
- Constant [ integer MYSQLX_TYPE_BYTES ] { 21 }
- Constant [ integer MYSQLX_TYPE_INTERVAL ] { 247 }
- Constant [ integer MYSQLX_TYPE_GEOMETRY ] { 255 }
- Constant [ integer MYSQLX_TYPE_JSON ] { 245 }
- Constant [ integer MYSQLX_TYPE_NEWDECIMAL ] { 246 }
- Constant [ integer MYSQLX_TYPE_BIT ] { 16 }
- Constant [ integer MYSQLX_LOCK_DEFAULT ] { 0 }
- Constant [ integer MYSQLX_LOCK_NOWAIT ] { 1 }
- Constant [ integer MYSQLX_LOCK_SKIP_LOCKED ] { 2 }
+ Constant [ string MYSQLX_VERSION ] { 8.0.19 }
+ Constant [ int MYSQLX_VERSION_ID ] { 80019 }
+ Constant [ int MYSQLX_CLIENT_SSL ] { 2048 }
+ Constant [ int MYSQLX_TYPE_DECIMAL ] { 0 }
+ Constant [ int MYSQLX_TYPE_TINY ] { 1 }
+ Constant [ int MYSQLX_TYPE_SHORT ] { 2 }
+ Constant [ int MYSQLX_TYPE_SMALLINT ] { 17 }
+ Constant [ int MYSQLX_TYPE_MEDIUMINT ] { 18 }
+ Constant [ int MYSQLX_TYPE_INT ] { 19 }
+ Constant [ int MYSQLX_TYPE_BIGINT ] { 20 }
+ Constant [ int MYSQLX_TYPE_LONG ] { 3 }
+ Constant [ int MYSQLX_TYPE_FLOAT ] { 4 }
+ Constant [ int MYSQLX_TYPE_DOUBLE ] { 5 }
+ Constant [ int MYSQLX_TYPE_NULL ] { 6 }
+ Constant [ int MYSQLX_TYPE_TIMESTAMP ] { 7 }
+ Constant [ int MYSQLX_TYPE_LONGLONG ] { 8 }
+ Constant [ int MYSQLX_TYPE_INT24 ] { 9 }
+ Constant [ int MYSQLX_TYPE_DATE ] { 10 }
+ Constant [ int MYSQLX_TYPE_TIME ] { 11 }
+ Constant [ int MYSQLX_TYPE_DATETIME ] { 12 }
+ Constant [ int MYSQLX_TYPE_YEAR ] { 13 }
+ Constant [ int MYSQLX_TYPE_NEWDATE ] { 14 }
+ Constant [ int MYSQLX_TYPE_ENUM ] { 247 }
+ Constant [ int MYSQLX_TYPE_SET ] { 248 }
+ Constant [ int MYSQLX_TYPE_TINY_BLOB ] { 249 }
+ Constant [ int MYSQLX_TYPE_MEDIUM_BLOB ] { 250 }
+ Constant [ int MYSQLX_TYPE_LONG_BLOB ] { 251 }
+ Constant [ int MYSQLX_TYPE_BLOB ] { 252 }
+ Constant [ int MYSQLX_TYPE_VAR_STRING ] { 253 }
+ Constant [ int MYSQLX_TYPE_STRING ] { 254 }
+ Constant [ int MYSQLX_TYPE_CHAR ] { 1 }
+ Constant [ int MYSQLX_TYPE_BYTES ] { 21 }
+ Constant [ int MYSQLX_TYPE_INTERVAL ] { 247 }
+ Constant [ int MYSQLX_TYPE_GEOMETRY ] { 255 }
+ Constant [ int MYSQLX_TYPE_JSON ] { 245 }
+ Constant [ int MYSQLX_TYPE_NEWDECIMAL ] { 246 }
+ Constant [ int MYSQLX_TYPE_BIT ] { 16 }
+ Constant [ int MYSQLX_LOCK_DEFAULT ] { 0 }
+ Constant [ int MYSQLX_LOCK_NOWAIT ] { 1 }
+ Constant [ int MYSQLX_LOCK_SKIP_LOCKED ] { 2 }
}
- Functions {
@@ -235,7 +235,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> abstract public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
}
@@ -259,7 +259,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> abstract public method skip ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $skip ]
+ Parameter #0 [ <required> int $skip ]
}
}
}
@@ -874,35 +874,35 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationLimitable> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
Method [ <internal:mysql_xdevapi> public method offset ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $position ]
+ Parameter #0 [ <required> int $position ]
}
}
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option ]
}
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $flags ]
+ Parameter #0 [ <optional> int $flags ]
}
}
}
@@ -943,14 +943,14 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationLimitable> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationSkippable> public method skip ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $position ]
+ Parameter #0 [ <required> int $position ]
}
}
@@ -1043,7 +1043,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\CrudOperationLimitable> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
@@ -1058,8 +1058,8 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Statement ] {
- Constants [2] {
- Constant [ public integer EXECUTE_ASYNC ] { 1 }
- Constant [ public integer BUFFERED ] { 2 }
+ Constant [ public int EXECUTE_ASYNC ] { 1 }
+ Constant [ public int BUFFERED ] { 2 }
}
- Static properties [0] {
@@ -1098,8 +1098,8 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Class [ <internal:mysql_xdevapi> class mysql_xdevapi\SqlStatement ] {
- Constants [2] {
- Constant [ public integer EXECUTE_ASYNC ] { 1 }
- Constant [ public integer BUFFERED ] { 2 }
+ Constant [ public int EXECUTE_ASYNC ] { 1 }
+ Constant [ public int BUFFERED ] { 2 }
}
- Static properties [0] {
@@ -1126,7 +1126,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> public method execute ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $flags ]
+ Parameter #0 [ <optional> int $flags ]
}
}
@@ -1637,7 +1637,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
@@ -1745,28 +1745,28 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
Method [ <internal:mysql_xdevapi> public method offset ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $position ]
+ Parameter #0 [ <required> int $position ]
}
}
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $lock_waiting_option ]
+ Parameter #0 [ <optional> int $lock_waiting_option ]
}
}
@@ -1821,7 +1821,7 @@ Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.18 ] {
Method [ <internal:mysql_xdevapi> public method limit ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rows ]
+ Parameter #0 [ <required> int $rows ]
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 32fbbfa..5810dd9 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mysql-xdevapi
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,12 +24,12 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.18
+Version: 8.0.19
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -317,6 +317,9 @@ fi
%changelog
+* Mon Jan 13 2020 Remi Collet <remi@remirepo.net> - 8.0.19-1
+- update to 8.0.19
+
* Tue Oct 15 2019 Remi Collet <remi@remirepo.net> - 8.0.18-1
- update to 8.0.18
- drop patches merged upstream