summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION19
-rw-r--r--php-pecl-mysql-xdevapi.spec16
3 files changed, 25 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 085fe9c..acfc68d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.20
+Version => mysql_xdevapi 8.0.21
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index 83848ee..917868c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.20 ] {
+Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.21 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -29,8 +29,8 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.20 ] {
}
- Constants [40] {
- Constant [ string MYSQLX_VERSION ] { 8.0.20 }
- Constant [ int MYSQLX_VERSION_ID ] { 80020 }
+ Constant [ string MYSQLX_VERSION ] { 8.0.21 }
+ Constant [ int MYSQLX_VERSION_ID ] { 80021 }
Constant [ int MYSQLX_CLIENT_SSL ] { 2048 }
Constant [ int MYSQLX_TYPE_DECIMAL ] { 0 }
Constant [ int MYSQLX_TYPE_TINY ] { 1 }
@@ -590,7 +590,7 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.20 ] {
Property [ <default> public $name ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -614,8 +614,17 @@ Extension [ <persistent> extension #87 mysql_xdevapi version 8.0.20 ] {
Method [ <internal:mysql_xdevapi> public method createCollection ] {
- - Parameters [1] {
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <optional> string $options ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method modifyCollection ] {
+
+ - Parameters [2] {
Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $options ]
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 954885b..ba8df6c 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -18,13 +18,13 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mysql_xdevapi
# Need work to find how to run upstream test suite
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
# After 20-json, 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.20
+Version: 8.0.21
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
@@ -38,11 +38,11 @@ BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: protobuf-devel
+BuildRequires: protobuf-devel > 3
BuildRequires: protobuf-c-devel
BuildRequires: boost-devel >= 1.53
BuildRequires: openssl-devel
-%if %{with_tests}
+%if %{with tests}
BuildRequires: community-mysql-server >= 5.7.12
BuildRequires: %{?scl_prefix}php-mysqli
%endif
@@ -65,7 +65,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
# Removed
Obsoletes: %{name}-devel < 8.0.2
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -227,7 +227,7 @@ cd ../ZTS
%endif
-%if %{with_tests}
+%if %{with tests}
cd ../NTS
RET=0
@@ -317,6 +317,10 @@ fi
%changelog
+* Mon Jul 13 2020 Remi Collet <remi@remirepo.net> - 8.0.21-1
+- update to 8.0.21
+- raise dependency on protobuf 3 (drop EL-7 compatibility)
+
* Tue Apr 28 2020 Remi Collet <remi@remirepo.net> - 8.0.20-1
- update to 8.0.20