summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-20 07:19:02 +0200
committerRemi Collet <remi@remirepo.net>2018-04-20 07:19:02 +0200
commitc1d8e4abb3d90e29329793b6ec3d9ca1f40338e2 (patch)
tree2b4142aa4f1fbc6926664f05d53179c28ca91c58
parent65995bb610d180a791c4ee784e34af63f2b832b3 (diff)
v8.0.11 (stable)
-rw-r--r--REFLECTION411
-rw-r--r--mysql_xdevapi-build.patch13
-rw-r--r--php-pecl-mysql-xdevapi.spec30
3 files changed, 88 insertions, 366 deletions
diff --git a/REFLECTION b/REFLECTION
index 09f68b4..ce65d01 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,8 +1,9 @@
-Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
+Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
- Dependencies {
Dependency [ standard (Required) ]
Dependency [ mysqlnd (Required) ]
+ Dependency [ hash (Required) ]
Dependency [ json (Required) ]
}
@@ -27,7 +28,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- - Constants [35] {
+ - Constants [38] {
Constant [ integer MYSQLX_CLIENT_SSL ] { 2048 }
Constant [ integer MYSQLX_TYPE_DECIMAL ] { 0 }
Constant [ integer MYSQLX_TYPE_TINY ] { 1 }
@@ -63,6 +64,9 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
Constant [ integer MYSQLX_TYPE_JSON ] { 245 }
Constant [ integer MYSQLX_TYPE_NEWDECIMAL ] { 246 }
Constant [ integer MYSQLX_TYPE_BIT ] { 16 }
+ Constant [ integer MYSQLX_LOCK_DEFAULT ] { 0 }
+ Constant [ integer MYSQLX_LOCK_NOWAIT ] { 1 }
+ Constant [ integer MYSQLX_LOCK_SKIP_LOCKED ] { 2 }
}
- Functions {
@@ -79,7 +83,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- - Classes [36] {
+ - Classes [34] {
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -179,53 +183,6 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\Session ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [5] {
- Method [ <internal:mysql_xdevapi> abstract public method getSchemas ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> abstract public method getSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> abstract public method createSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> abstract public method dropSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> abstract public method close ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\CrudOperationBindable ] {
- Constants [0] {
@@ -488,7 +445,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
Class [ <internal:mysql_xdevapi> final class mysql_xdevapi\Driver ] {
- Constants [1] {
- Constant [ public string version ] { 8.0.4 }
+ Constant [ public string version ] { 8.0.11 }
}
- Static properties [0] {
@@ -506,7 +463,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\BaseSession implements mysql_xdevapi\Session ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\XSession ] {
- Constants [0] {
}
@@ -520,247 +477,13 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
- Properties [0] {
}
- - Methods [18] {
+ - Methods [1] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
-
- Method [ <internal:mysql_xdevapi> public method getServerVersion ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method getClientId ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method generateUUID ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method quoteName ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Session> public method getSchemas ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Session> public method getSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Session> public method createSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Session> public method dropSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method startTransaction ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method commit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method rollback ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method setSavepoint ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method rollbackTo ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method releaseSavepoint ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method listClients ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method killClient ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> integer $client_id ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Session> public method close ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\XSession extends mysql_xdevapi\BaseSession implements mysql_xdevapi\Session ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [18] {
- Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\BaseSession, ctor> private method __construct ] {
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method getServerVersion ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method getClientId ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method generateUUID ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method quoteName ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method getSchemas ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method getSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method createSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method dropSchema ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method startTransaction ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method commit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method rollback ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method setSavepoint ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method rollbackTo ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method releaseSavepoint ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> string $name ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method listClients ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method killClient ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> integer $client_id ]
- }
- }
-
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method close ] {
-
- - Parameters [0] {
- }
- }
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeSession extends mysql_xdevapi\BaseSession implements mysql_xdevapi\Session ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Session ] {
- Constants [0] {
}
@@ -775,7 +498,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
- Methods [20] {
- Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\BaseSession, ctor> private method __construct ] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
Method [ <internal:mysql_xdevapi> public method executeSql ] {
@@ -788,108 +511,108 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Method [ <internal:mysql_xdevapi, overwrites mysql_xdevapi\BaseSession, prototype mysql_xdevapi\BaseSession> public method quoteName ] {
+ Method [ <internal:mysql_xdevapi> public method quoteName ] {
- Parameters [1] {
Parameter #0 [ <required> string $name ]
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method getServerVersion ] {
+ Method [ <internal:mysql_xdevapi> public method getServerVersion ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method getClientId ] {
+ Method [ <internal:mysql_xdevapi> public method getClientId ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method generateUUID ] {
+ Method [ <internal:mysql_xdevapi> public method generateUUID ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method getSchemas ] {
+ Method [ <internal:mysql_xdevapi> public method createSchema ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method getSchema ] {
+ Method [ <internal:mysql_xdevapi> public method dropSchema ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method createSchema ] {
+ Method [ <internal:mysql_xdevapi> public method getSchemas ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method dropSchema ] {
+ Method [ <internal:mysql_xdevapi> public method getSchema ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method startTransaction ] {
+ Method [ <internal:mysql_xdevapi> public method startTransaction ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method commit ] {
+ Method [ <internal:mysql_xdevapi> public method commit ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method rollback ] {
+ Method [ <internal:mysql_xdevapi> public method rollback ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method setSavepoint ] {
+ Method [ <internal:mysql_xdevapi> public method setSavepoint ] {
- Parameters [1] {
Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method rollbackTo ] {
+ Method [ <internal:mysql_xdevapi> public method rollbackTo ] {
- Parameters [1] {
Parameter #0 [ <optional> string $name ]
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method releaseSavepoint ] {
+ Method [ <internal:mysql_xdevapi> public method releaseSavepoint ] {
- Parameters [1] {
Parameter #0 [ <optional> string $name ]
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method listClients ] {
+ Method [ <internal:mysql_xdevapi> public method listClients ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession> public method killClient ] {
+ Method [ <internal:mysql_xdevapi> public method killClient ] {
- Parameters [1] {
Parameter #0 [ <required> integer $client_id ]
}
}
- Method [ <internal:mysql_xdevapi, inherits mysql_xdevapi\BaseSession, prototype mysql_xdevapi\Session> public method close ] {
+ Method [ <internal:mysql_xdevapi> public method close ] {
- Parameters [0] {
}
@@ -897,7 +620,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeSchema implements mysql_xdevapi\DatabaseObject ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Schema implements mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
}
@@ -983,7 +706,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollection implements mysql_xdevapi\SchemaObject, mysql_xdevapi\DatabaseObject ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Collection implements mysql_xdevapi\SchemaObject, mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
}
@@ -1107,7 +830,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionAdd implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\CollectionAdd implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -1133,7 +856,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionFind implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSortable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\CollectionFind implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSortable ] {
- Constants [0] {
}
@@ -1202,13 +925,15 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $lock_waiting_option ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $lock_waiting_option ]
}
}
@@ -1220,7 +945,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionModify implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSkippable, mysql_xdevapi\CrudOperationSortable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\CollectionModify implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSkippable, mysql_xdevapi\CrudOperationSortable ] {
- Constants [0] {
}
@@ -1334,7 +1059,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeCollectionRemove implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSortable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\CollectionRemove implements mysql_xdevapi\Executable, mysql_xdevapi\CrudOperationBindable, mysql_xdevapi\CrudOperationLimitable, mysql_xdevapi\CrudOperationSortable ] {
- Constants [0] {
}
@@ -1381,7 +1106,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeStatement ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Statement ] {
- Constants [2] {
Constant [ public integer EXECUTE_ASYNC ] { 1 }
@@ -1421,7 +1146,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeSqlStatement ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\SqlStatement ] {
- Constants [2] {
Constant [ public integer EXECUTE_ASYNC ] { 1 }
@@ -1472,7 +1197,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\NodeBaseResult ] {
+ Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\BaseResult ] {
- Constants [0] {
}
@@ -1501,7 +1226,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\NodeDocResult implements mysql_xdevapi\NodeBaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\DocResult implements mysql_xdevapi\BaseResult, Traversable ] {
- Constants [0] {
}
@@ -1531,13 +1256,13 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarnings ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarnings ] {
- Parameters [0] {
}
@@ -1545,7 +1270,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\NodeResult implements mysql_xdevapi\NodeBaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\Result implements mysql_xdevapi\BaseResult, Traversable ] {
- Constants [0] {
}
@@ -1559,7 +1284,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -1575,25 +1300,19 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method getDocumentId ] {
+ Method [ <internal:mysql_xdevapi> public method getGeneratedIds ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi> public method getDocumentIds ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarningCount ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarnings ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarnings ] {
- Parameters [0] {
}
@@ -1601,7 +1320,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\NodeRowResult implements mysql_xdevapi\NodeBaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\RowResult implements mysql_xdevapi\BaseResult, Traversable ] {
- Constants [0] {
}
@@ -1631,13 +1350,13 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarnings ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarnings ] {
- Parameters [0] {
}
@@ -1663,7 +1382,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\NodeSqlStatementResult implements mysql_xdevapi\NodeBaseResult, Traversable ] {
+ Class [ <internal:mysql_xdevapi> <iterateable> class mysql_xdevapi\SqlStatementResult implements mysql_xdevapi\BaseResult, Traversable ] {
- Constants [0] {
}
@@ -1711,19 +1430,19 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method getDocumentId ] {
+ Method [ <internal:mysql_xdevapi> public method getGeneratedIds ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
- Parameters [0] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\NodeBaseResult> public method getWarnings ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarnings ] {
- Parameters [0] {
}
@@ -1847,7 +1566,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeTable implements mysql_xdevapi\SchemaObject, mysql_xdevapi\DatabaseObject ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Table implements mysql_xdevapi\SchemaObject, mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
}
@@ -1928,7 +1647,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeTableDelete implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\TableDelete implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -1989,7 +1708,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeTableInsert implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\TableInsert implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -2022,7 +1741,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeTableSelect implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\TableSelect implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
@@ -2091,13 +1810,15 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
Method [ <internal:mysql_xdevapi> public method lockShared ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $lock_waiting_option ]
}
}
Method [ <internal:mysql_xdevapi> public method lockExclusive ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $lock_waiting_option ]
}
}
@@ -2109,7 +1830,7 @@ Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.4 ] {
}
}
- Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NodeTableUpdate implements mysql_xdevapi\Executable ] {
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\TableUpdate implements mysql_xdevapi\Executable ] {
- Constants [0] {
}
diff --git a/mysql_xdevapi-build.patch b/mysql_xdevapi-build.patch
deleted file mode 100644
index 74af55c..0000000
--- a/mysql_xdevapi-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -up ./config.m4.old ./config.m4
---- ./config.m4.old 2017-03-14 08:58:13.000000000 +0100
-+++ ./config.m4 2017-03-14 08:58:19.000000000 +0100
-@@ -22,6 +22,9 @@ PHP_ARG_ENABLE(mysql-xdevapi-message-cla
- [ --enable-mysql-xdevapi-message-classes
- Enable support for the experimental message classes in mysql-xdevapi], yes, no)
-
-+PHP_ARG_WITH(openssl, for OpenSSL support,
-+[ --with-openssl[=DIR] Include OpenSSL support (requires OpenSSL >= 1.0.1)])
-+
- dnl If some extension uses mysql-xdevapi it will get compiled in PHP core
- if test "$PHP_MYSQL_XDEVAPI" != "no" || test "$PHP_MYSQL_XDEVAPI_ENABLED" = "yes"; then
- PHP_REQUIRE_CXX
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 819bb7e..06855db 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -1,11 +1,15 @@
# remirepo spec file for php-pecl-mysql-xdevapi
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-mysql-xdevapi
@@ -20,7 +24,7 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.3
+Version: 8.0.11
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
@@ -28,11 +32,11 @@ Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# Workaround for out-of-tree build
-Patch0: %{pecl_name}-build.patch
-
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-mysqlnd
+BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: protobuf-devel
@@ -48,6 +52,7 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
+Requires: %{?scl_prefix}php-hash%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -101,6 +106,9 @@ data.
* Modern practices and syntax styles are used to get away from traditional
SQL-String-Building. See Chapter 10, Building Expressions.
+Documentation: http://php.net/mysql-xdevapi
+
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -114,8 +122,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .old
-
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_MYSQL_XDEVAPI_VERSION/{s/.* "//;s/".*$//;p}' php_mysql_xdevapi.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -151,6 +157,8 @@ EOF
peclconf() {
%configure \
--enable-mysql-xdevapi \
+ --with-boost \
+ --with-protobuf \
--with-php-config=$1
}
@@ -266,7 +274,7 @@ exit $RET
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -301,6 +309,12 @@ fi
%changelog
+* Fri Apr 20 2018 Remi Collet <remi@remirepo.net> - 8.0.11-1
+- update to 8.0.11 (stable)
+
+* Thu Feb 1 2018 Remi Collet <remi@remirepo.net> - 8.0.4-1
+- Update to 8.0.4 (alpha)
+
* Fri Nov 3 2017 Remi Collet <remi@remirepo.net> - 8.0.3-1
- Update to 8.0.3 (alpha)