summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-10 06:52:25 +0200
committerRemi Collet <remi@remirepo.net>2018-08-10 06:52:25 +0200
commit8610e2a620bfc597e5cd79300d304d4573c83d37 (patch)
treea4863d219e0dc9329cd033c15ff015c1862780d1
parentc60391afab65e634eab6193fb4b6b2423034509f (diff)
v8.0.12
-rw-r--r--5.patch83
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION539
-rw-r--r--f7fe2b6f7a184c92ff50290f3c2adfd4dcead010.patch94
-rw-r--r--php-pecl-mysql-xdevapi.spec13
5 files changed, 499 insertions, 232 deletions
diff --git a/5.patch b/5.patch
deleted file mode 100644
index a545044..0000000
--- a/5.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From 56893f68273cd9d1353645ffc3f39861e39bb7c9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 18 Jul 2018 13:03:28 +0200
-Subject: [PATCH] fix for 7.3.0alpha4
-
----
- mysqlx_base_result_iterator.cc | 2 ++
- mysqlx_doc_result_iterator.cc | 2 ++
- mysqlx_result_iterator.cc | 2 ++
- mysqlx_row_result_iterator.cc | 2 ++
- mysqlx_sql_statement_result_iterator.cc | 2 ++
- 5 files changed, 10 insertions(+)
-
-diff --git a/mysqlx_base_result_iterator.cc b/mysqlx_base_result_iterator.cc
-index 2c9eae4..0a7c315 100644
---- a/mysqlx_base_result_iterator.cc
-+++ b/mysqlx_base_result_iterator.cc
-@@ -193,7 +193,9 @@ void
- mysqlx_register_base_result_iterator(zend_class_entry * ce)
- {
- ce->get_iterator = mysqlx_base_result_create_iterator;
-+#if PHP_VERSION_ID < 70300
- ce->iterator_funcs.funcs = &mysqlx_base_result_iterator_funcs;
-+#endif
-
- zend_class_implements(ce, 1, zend_ce_traversable);
- }
-diff --git a/mysqlx_doc_result_iterator.cc b/mysqlx_doc_result_iterator.cc
-index 9c57a21..2536ad1 100644
---- a/mysqlx_doc_result_iterator.cc
-+++ b/mysqlx_doc_result_iterator.cc
-@@ -198,7 +198,9 @@ void
- mysqlx_register_doc_result_iterator(zend_class_entry * ce)
- {
- ce->get_iterator = mysqlx_doc_result_create_iterator;
-+#if PHP_VERSION_ID < 70300
- ce->iterator_funcs.funcs = &mysqlx_doc_result_iterator_funcs;
-+#endif
-
- zend_class_implements(ce, 1, zend_ce_traversable);
- }
-diff --git a/mysqlx_result_iterator.cc b/mysqlx_result_iterator.cc
-index ff52615..46f251c 100644
---- a/mysqlx_result_iterator.cc
-+++ b/mysqlx_result_iterator.cc
-@@ -192,7 +192,9 @@ void
- mysqlx_register_result_iterator(zend_class_entry * ce)
- {
- ce->get_iterator = mysqlx__result_create_iterator;
-+#if PHP_VERSION_ID < 70300
- ce->iterator_funcs.funcs = &mysqlx__result_iterator_funcs;
-+#endif
-
- zend_class_implements(ce, 1, zend_ce_traversable);
- }
-diff --git a/mysqlx_row_result_iterator.cc b/mysqlx_row_result_iterator.cc
-index a26617d..77eebf9 100644
---- a/mysqlx_row_result_iterator.cc
-+++ b/mysqlx_row_result_iterator.cc
-@@ -192,7 +192,9 @@ void
- mysqlx_register_row_result_iterator(zend_class_entry * ce)
- {
- ce->get_iterator = mysqlx_row_result_create_iterator;
-+#if PHP_VERSION_ID < 70300
- ce->iterator_funcs.funcs = &mysqlx_row_result_iterator_funcs;
-+#endif
-
- zend_class_implements(ce, 1, zend_ce_traversable);
- }
-diff --git a/mysqlx_sql_statement_result_iterator.cc b/mysqlx_sql_statement_result_iterator.cc
-index 55640b4..a970244 100644
---- a/mysqlx_sql_statement_result_iterator.cc
-+++ b/mysqlx_sql_statement_result_iterator.cc
-@@ -191,7 +191,9 @@ void
- mysqlx_register_sql_statement_result_iterator(zend_class_entry * ce)
- {
- ce->get_iterator = mysqlx_sql_result_create_iterator;
-+#if PHP_VERSION_ID < 70300
- ce->iterator_funcs.funcs = &mysqlx_sql_result_iterator_funcs;
-+#endif
-
- zend_class_implements(ce, 1, zend_ce_traversable);
- }
diff --git a/PHPINFO b/PHPINFO
index 8be431d..31daad3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.11
+Version => mysql_xdevapi 8.0.12
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index ce65d01..9591731 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
+Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -72,7 +72,8 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
- Functions {
Function [ <internal:mysql_xdevapi> function mysql_xdevapi\getSession ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $uri ]
}
}
Function [ <internal:mysql_xdevapi> function mysql_xdevapi\expression ] {
@@ -83,7 +84,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- - Classes [34] {
+ - Classes [50] {
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -445,7 +446,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Class [ <internal:mysql_xdevapi> final class mysql_xdevapi\Driver ] {
- Constants [1] {
- Constant [ public string version ] { 8.0.11 }
+ Constant [ public string version ] { 8.0.12 }
}
- Static properties [0] {
@@ -502,6 +503,11 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
Method [ <internal:mysql_xdevapi> public method executeSql ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $query ]
+ Parameter #1 [ <optional> ...$args ]
+ }
}
Method [ <internal:mysql_xdevapi> public method sql ] {
@@ -538,13 +544,15 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method createSchema ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $schema_name ]
}
}
Method [ <internal:mysql_xdevapi> public method dropSchema ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $schema_name ]
}
}
@@ -556,7 +564,8 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method getSchema ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $name ]
}
}
@@ -581,21 +590,21 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method setSavepoint ] {
- Parameters [1] {
- Parameter #0 [ <optional> $name ]
+ Parameter #0 [ <optional> $savepoint_name ]
}
}
Method [ <internal:mysql_xdevapi> public method rollbackTo ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $name ]
+ Parameter #0 [ <required> string $savepoint_name ]
}
}
Method [ <internal:mysql_xdevapi> public method releaseSavepoint ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $name ]
+ Parameter #0 [ <required> string $savepoint_name ]
}
}
@@ -666,16 +675,15 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method dropCollection ] {
- - Parameters [2] {
- Parameter #0 [ <required> string $schema_name ]
- Parameter #1 [ <required> string $collection_name ]
+ - Parameters [1] {
+ Parameter #0 [ <required> string $collection_name ]
}
}
Method [ <internal:mysql_xdevapi> public method getCollection ] {
- Parameters [1] {
- Parameter #0 [ <required> string $name ]
+ Parameter #0 [ <required> string $collection_name ]
}
}
@@ -688,7 +696,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method getTable ] {
- Parameters [1] {
- Parameter #0 [ <required> string $name ]
+ Parameter #0 [ <required> string $table_name ]
}
}
@@ -700,7 +708,8 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method getCollectionAsTable ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string $collection_name ]
}
}
}
@@ -772,14 +781,14 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method modify ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $search_condition ]
+ Parameter #0 [ <required> string $search_condition ]
}
}
Method [ <internal:mysql_xdevapi> public method remove ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $search_condition ]
+ Parameter #0 [ <required> string $search_condition ]
}
}
@@ -916,7 +925,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method skip ] {
+ Method [ <internal:mysql_xdevapi> public method offset ] {
- Parameters [1] {
Parameter #0 [ <required> integer $position ]
@@ -939,7 +948,8 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $flags ]
}
}
}
@@ -959,7 +969,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [12] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -1002,7 +1012,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method unset ] {
- Parameters [1] {
- Parameter #0 [ <required> $variables ]
+ Parameter #0 [ <required> $fields ]
}
}
@@ -1010,14 +1020,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
- Parameters [2] {
Parameter #0 [ <required> string $collection_field ]
- Parameter #1 [ <optional> $expression_or_literal ]
- }
- }
-
- Method [ <internal:mysql_xdevapi> public method merge ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $document ]
+ Parameter #1 [ <required> $expression_or_literal ]
}
}
@@ -1044,13 +1047,6 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi> public method arrayDelete ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $collection_field ]
- }
- }
-
Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\Executable> public method execute ] {
- Parameters [0] {
@@ -1175,6 +1171,10 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
Method [ <internal:mysql_xdevapi> public method execute ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $flags ]
+ }
}
Method [ <internal:mysql_xdevapi> public method hasMoreResults ] {
@@ -1212,7 +1212,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
- Methods [2] {
- Method [ <internal:mysql_xdevapi> abstract public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi> abstract public method getWarningsCount ] {
- Parameters [0] {
}
@@ -1256,7 +1256,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningsCount ] {
- Parameters [0] {
}
@@ -1306,7 +1306,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningsCount ] {
- Parameters [0] {
}
@@ -1350,7 +1350,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningsCount ] {
- Parameters [0] {
}
@@ -1436,7 +1436,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
- Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningCount ] {
+ Method [ <internal:mysql_xdevapi, prototype mysql_xdevapi\BaseResult> public method getWarningsCount ] {
- Parameters [0] {
}
@@ -1623,13 +1623,15 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method insert ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$columns ]
}
}
Method [ <internal:mysql_xdevapi> public method select ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$columns ]
}
}
@@ -1729,7 +1731,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method values ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $row_values ]
+ Parameter #0 [ <required> array $row_values ]
}
}
@@ -1762,7 +1764,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
Method [ <internal:mysql_xdevapi> public method where ] {
- Parameters [1] {
- Parameter #0 [ <required> $projection ]
+ Parameter #0 [ <required> $where_expr ]
}
}
@@ -1891,6 +1893,451 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.11 ] {
}
}
}
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\NativeConnection ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mysql_xdevapi> public method connect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $hostname ]
+ Parameter #1 [ <required> integer $port ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method send ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $payload ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method receive ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $how_many ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\ProtocolFrameCodec ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> object or NULL $connection ]
+ Parameter #1 [ <required> integer $message_type ]
+ Parameter #2 [ <required> string $message ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method receive ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object or NULL $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__ok ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi> public method get_message ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__error ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $message ]
+ Property [ <default> public $sql_state ]
+ Property [ <default> public $code ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__capability ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method echo ] {
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__capabilities ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object $capability ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__capabilities_get ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi> public method send ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method read_response ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__capabilities_set ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> object $capabilities ]
+ Parameter #1 [ <required> object $pfc ]
+ Parameter #2 [ <optional> object $connection ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method read_response ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__auth_start ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi> public method send ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $auth_mechanism ]
+ Parameter #1 [ <required> string $auth_data ]
+ Parameter #2 [ <required> object $pfc ]
+ Parameter #3 [ <optional> object $connection ]
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method read_response ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__auth_ok ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi> public method response ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__stmt_execute ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi> public method send ] {
+ }
+
+ Method [ <internal:mysql_xdevapi> public method read_response ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object $pfc ]
+ Parameter #1 [ <required> object $connection ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__stmt_execute_ok ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_column_metadata ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [13] {
+ Property [ <default> public $type ]
+ Property [ <default> public $type_name ]
+ Property [ <default> public $name ]
+ Property [ <default> public $original_name ]
+ Property [ <default> public $table ]
+ Property [ <default> public $original_table ]
+ Property [ <default> public $schema ]
+ Property [ <default> public $catalog ]
+ Property [ <default> public $collation ]
+ Property [ <default> public $fractional_digits ]
+ Property [ <default> public $length ]
+ Property [ <default> public $flags ]
+ Property [ <default> public $content_type ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_resultset_metadata ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mysql_xdevapi> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object $capability ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_data_row ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+ }
+
+ Method [ <internal:mysql_xdevapi> public method decode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object $metadata ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mysql_xdevapi> class mysqlx_message__data_fetch_done ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/f7fe2b6f7a184c92ff50290f3c2adfd4dcead010.patch b/f7fe2b6f7a184c92ff50290f3c2adfd4dcead010.patch
deleted file mode 100644
index 8485ee1..0000000
--- a/f7fe2b6f7a184c92ff50290f3c2adfd4dcead010.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From f7fe2b6f7a184c92ff50290f3c2adfd4dcead010 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 29 Jun 2018 10:10:38 +0200
-Subject: [PATCH] fix some [-Wformat=], [-Werror=format-security] and
- [-Wformat-extra-args] build warnings
-
----
- .gitignore | 1 +
- messages/mysqlx_resultset__data_row.cc | 5 ++---
- util/exceptions.cc | 4 ++--
- xmysqlnd/xmysqlnd_session.cc | 4 ++--
- xmysqlnd/xmysqlnd_wireprotocol.cc | 2 +-
- 5 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/messages/mysqlx_resultset__data_row.cc b/messages/mysqlx_resultset__data_row.cc
-index 20cb05e..0d2f660 100644
---- a/messages/mysqlx_resultset__data_row.cc
-+++ b/messages/mysqlx_resultset__data_row.cc
-@@ -318,8 +318,7 @@ MYSQL_XDEVAPI_PHP_METHOD(mysqlx_data_row, decode)
- (unsigned int) day,
- (unsigned int) hours,
- (unsigned int) minutes,
-- (unsigned int) seconds,
-- (unsigned int) useconds));
-+ (unsigned int) seconds));
- #undef DATETIME_FMT_STR
- break;
- }
-@@ -360,7 +359,7 @@ MYSQL_XDEVAPI_PHP_METHOD(mysqlx_data_row, decode)
- break;
- }
- if (buf_size == 1) {
-- php_error_docref(nullptr, E_WARNING, "Unexpected value %d for first byte of TIME");
-+ php_error_docref(nullptr, E_WARNING, "Unexpected value for first byte of TIME");
- }
- const uint8_t scale = buf[0];
- const uint8_t last_byte = buf[buf_size - 1]; /* last byte is the sign and the last 4 bits, if any */
-diff --git a/util/exceptions.cc b/util/exceptions.cc
-index a611ea2..ed8def7 100644
---- a/util/exceptions.cc
-+++ b/util/exceptions.cc
-@@ -154,7 +154,7 @@ void raise_doc_ref_exception(const doc_ref_exception& e)
- };
- const int severity = severity_mapping.at(e.severity);
- const char* what = e.what();
-- php_error_docref(nullptr, severity, what);
-+ php_error_docref(nullptr, severity, "%s", what);
- }
- /* }}} */
-
-@@ -179,7 +179,7 @@ void raise_unknown_exception()
- /* {{{ mysqlx::util::log_warning */
- void log_warning(const string& msg)
- {
-- php_error_docref(nullptr, E_WARNING, msg.c_str());
-+ php_error_docref(nullptr, E_WARNING, "%s", msg.c_str());
- }
- /* }}} */
-
-diff --git a/xmysqlnd/xmysqlnd_session.cc b/xmysqlnd/xmysqlnd_session.cc
-index f9a9fa4..617bb0a 100644
---- a/xmysqlnd/xmysqlnd_session.cc
-+++ b/xmysqlnd/xmysqlnd_session.cc
-@@ -1239,7 +1239,7 @@ XMYSQLND_METHOD(xmysqlnd_session_data, authenticate)(
- os << "[HY000] Authentication failed using "
- << boost::join(auth_mech_names, ", ")
- << ". Check username and password or try a secure connection";
-- php_error_docref(nullptr, E_WARNING, os.str().c_str());
-+ php_error_docref(nullptr, E_WARNING, "%s", os.str().c_str());
- }
- }
- }
-@@ -2983,7 +2983,7 @@ XMYSQLND_SESSION_AUTH_DATA * extract_auth_information(const util::Url& node_url)
- XMYSQLND_SESSION_AUTH_DATA * auth = new XMYSQLND_SESSION_AUTH_DATA;
-
- if( nullptr == auth ) {
-- php_error_docref(nullptr, E_WARNING, "Coulnd't allocate %u bytes",
-+ php_error_docref(nullptr, E_WARNING, "Coulnd't allocate %lu bytes",
- sizeof(XMYSQLND_SESSION_AUTH_DATA));
- DBG_RETURN(nullptr);
- }
-diff --git a/xmysqlnd/xmysqlnd_wireprotocol.cc b/xmysqlnd/xmysqlnd_wireprotocol.cc
-index 0c7bb69..637bfe8 100644
---- a/xmysqlnd/xmysqlnd_wireprotocol.cc
-+++ b/xmysqlnd/xmysqlnd_wireprotocol.cc
-@@ -181,7 +181,7 @@ xmysqlnd_inspect_changed_exec_state(const struct st_xmysqlnd_on_execution_state_
- case Mysqlx::Notice::SessionStateChanged::ROWS_MATCHED: state_type = EXEC_STATE_ROWS_MATCHED; break;
- default:
- DBG_ERR_FMT("Unknown param name %d. Please add it to the switch", message.param());
-- php_error_docref("Unknown param name %d in %s::%d. Please add it to the switch", message.param(), __FILE__, __LINE__);
-+ php_error_docref(nullptr, E_WARNING, "Unknown param name %d in %s::%d. Please add it to the switch", message.param(), __FILE__, __LINE__);
- break;
- }
- if (state_type != EXEC_STATE_NONE) {
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index c56a2b0..18df5b8 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -24,16 +24,13 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.11
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 8.0.12
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: https://github.com/php/pecl-database-mysql_xdevapi/commit/f7fe2b6f7a184c92ff50290f3c2adfd4dcead010.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/php/pecl-database-mysql_xdevapi/pull/5.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel > 7.1
@@ -128,9 +125,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
-%patch1 -p1 -b .pr5
-
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_MYSQL_XDEVAPI_VERSION/{s/.* "//;s/".*$//;p}' php_mysql_xdevapi.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -318,6 +312,9 @@ fi
%changelog
+* Fri Aug 10 2018 Remi Collet <remi@remirepo.net> - 8.0.12-1
+- update to 8.0.12
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 8.0.11-3
- rebuild for 7.3.0alpha4 new ABI, using patch from
https://github.com/php/pecl-database-mysql_xdevapi/pull/5