summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-22 10:30:13 +0200
committerRemi Collet <remi@remirepo.net>2018-10-22 10:30:13 +0200
commit5178b902f91c18cf833d892a7fbe1197928c9346 (patch)
treea5d51e3f177af546336ab4114d110bdb188e1591
parent77a9766ccefc492125d64fdb96399a8a24988701 (diff)
v8.0.13
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-mysql-xdevapi.spec9
3 files changed, 60 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index 31daad3..11adb75 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.12
+Version => mysql_xdevapi 8.0.13
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index 9591731..97bb717 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
+Extension [ <persistent> extension #116 mysql_xdevapi version 8.0.13 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -76,6 +76,13 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
Parameter #0 [ <required> string $uri ]
}
}
+ Function [ <internal:mysql_xdevapi> function mysql_xdevapi\getClient ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $uri ]
+ Parameter #1 [ <optional> string or NULL $client_options ]
+ }
+ }
Function [ <internal:mysql_xdevapi> function mysql_xdevapi\expression ] {
- Parameters [1] {
@@ -84,7 +91,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
}
}
- - Classes [50] {
+ - Classes [51] {
Interface [ <internal:mysql_xdevapi> interface mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -446,7 +453,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
Class [ <internal:mysql_xdevapi> final class mysql_xdevapi\Driver ] {
- Constants [1] {
- Constant [ public string version ] { 8.0.12 }
+ Constant [ public string version ] { 8.0.13 }
}
- Static properties [0] {
@@ -629,6 +636,38 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
}
}
+ Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Client ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
+ }
+
+ Method [ <internal:mysql_xdevapi> public method getSession ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mysql_xdevapi> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mysql_xdevapi> class mysql_xdevapi\Schema implements mysql_xdevapi\DatabaseObject ] {
- Constants [0] {
@@ -853,7 +892,7 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:mysql_xdevapi, ctor> private method __construct ] {
}
@@ -862,6 +901,13 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:mysql_xdevapi> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $json ]
+ }
+ }
}
}
@@ -1911,9 +1957,10 @@ Extension [ <persistent> extension #117 mysql_xdevapi version 8.0.12 ] {
- Methods [3] {
Method [ <internal:mysql_xdevapi> public method connect ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> string $hostname ]
- Parameter #1 [ <required> integer $port ]
+ Parameter #1 [ <optional> integer $port ]
+ Parameter #2 [ <optional> integer $connection_timeout ]
}
}
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 54cc530..334a831 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -24,8 +24,8 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.12
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 8.0.13
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -40,7 +40,7 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: protobuf-devel
BuildRequires: protobuf-c-devel
-BuildRequires: boost-devel
+BuildRequires: boost-devel >= 1.53
BuildRequires: openssl-devel
%if %{with_tests}
BuildRequires: community-mysql-server >= 5.7.12
@@ -312,6 +312,9 @@ fi
%changelog
+* Mon Oct 22 2018 Remi Collet <remi@remirepo.net> - 8.0.13-1
+- update to 8.0.13
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 8.0.12-2
- rebuild for 7.3.0beta2 new ABI